FAQ Manager

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
omassil
Registered User
Posts: 8
Joined: Fri Mar 20, 2009 1:12 am

Re: FAQ Manager

Post by omassil » Sun Mar 22, 2009 9:39 am

great MOD! So easy to install... thanks! :D

Jaztar
Registered User
Posts: 142
Joined: Sat May 26, 2007 11:30 am

Re: FAQ Manager

Post by Jaztar » Tue Mar 24, 2009 1:32 pm

Hi,

I want to install this MOD. Does it work for v3.0.4?

Cheers.

sunnyebiz
Registered User
Posts: 46
Joined: Thu Mar 05, 2009 2:31 pm

Re: FAQ Manager

Post by sunnyebiz » Tue Mar 24, 2009 2:41 pm

Hi i uploaded all the files on root to my forum,but faq manager is not showing in ACP .

Hielke
Registered User
Posts: 37
Joined: Wed Mar 04, 2009 9:29 am
Location: The Netherlands
Contact:

Re: FAQ Manager

Post by Hielke » Tue Mar 24, 2009 2:46 pm

sunnyebiz wrote:Hi i uploaded all the files on root to my forum,but faq manager is not showing in ACP .
Didn´t you upload them in the rood map? So it's not www.yoursite.com/root/files.ext

Jaztar
Registered User
Posts: 142
Joined: Sat May 26, 2007 11:30 am

Re: FAQ Manager

Post by Jaztar » Wed Mar 25, 2009 3:17 am

Jaztar wrote:Hi,

I want to install this MOD. Does it work for v3.0.4?

Cheers.
Any feedback appreciated. Thanks.

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: FAQ Manager

Post by EXreaction » Wed Mar 25, 2009 3:22 am

If it wouldn't work I would have updated it. This works for every version of phpBB3, probably even will for 3.2.x.

Jaztar
Registered User
Posts: 142
Joined: Sat May 26, 2007 11:30 am

Re: FAQ Manager

Post by Jaztar » Wed Mar 25, 2009 6:19 am

I'm having trouble installing this mod.

Uploaded files to correct folders. Ran install file.

I don't see it anywhere. Using 3.0.4. Any help appreciated. Cheers.

Jaztar
Registered User
Posts: 142
Joined: Sat May 26, 2007 11:30 am

Re: FAQ Manager

Post by Jaztar » Wed Mar 25, 2009 7:09 am

If you do not know how or do not want to install modules yourself you may use the included install_modules.php script in the contrib/ folder.
Simply upload it to your root phpBB directoy, view the file in your web browser, and the modules will get added automatically. Be sure to delete it once you are done.
It reads "simply upload it...", when in fact it could be taken to mean the contrib folder.

Nevertheless, I figured it's the install_modules.php file which needs to be installed in the root phpBB3 directory.

Great MOD. Thanks.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: FAQ Manager

Post by Desdenova » Wed Apr 08, 2009 2:22 pm

Found a bug in the file writing process. Upon file load, all the &'s are converted to &, but not converted back to & upon the write if you are not editing the specific field where the & is located.

This breaks the XHTML 1.0 Strict Validation of the FAQ when the FAQ editor is used on an FAQ file. I'll try to go through the code sometime later to pinpoint the exact problem, if I can get the time to.

Tsoe
Registered User
Posts: 14
Joined: Wed Apr 08, 2009 3:06 pm

Re: FAQ Manager

Post by Tsoe » Wed Apr 08, 2009 8:52 pm

Exactly that what I was looking for. Thanks!

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: FAQ Manager

Post by EXreaction » Wed Apr 08, 2009 9:15 pm

& is not converted to allow administrators to put HTML code in the FAQ.

I don't think it should be converting & to & though.

Desdenova
Registered User
Posts: 646
Joined: Sat Feb 23, 2008 7:25 pm

Re: FAQ Manager

Post by Desdenova » Thu Apr 09, 2009 1:27 pm

EXreaction wrote:& is not converted to allow administrators to put HTML code in the FAQ.

I don't think it should be converting & to & though.
Well then, it would seem that outside of the field being edited, it must be converting to & and leaving it alone in the field being entered, then. I'll look in a moment and edit/reply.

Edit: Found it! Lines 293, 294 of includes/acp/acp_faq_manager.php

Code: Select all

		0 => '" . str_replace("'", "\'", htmlspecialchars_decode($name)) . "',
		1 => '" . str_replace("'", "\'", htmlspecialchars_decode($value)) . "'
Using htmlspecialchars_decode() is what is doing it. ;)

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: FAQ Manager

Post by EXreaction » Thu Apr 09, 2009 3:05 pm

I'll certainly look into it and fix it when I get the chance, but it probably won't be for a few weeks.

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: FAQ Manager

Post by spaceace » Fri May 08, 2009 12:55 am

works great. thanks :mrgreen:

Oscarzx
Registered User
Posts: 7
Joined: Sat May 30, 2009 8:04 pm

Re: FAQ Manager

Post by Oscarzx » Sat May 30, 2009 8:07 pm

does this work with phpbb3 v3.0.4?? it is really needed..

Locked

Return to “[3.0.x] MOD Database Releases”