Genders

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
TMorph
Registered User
Posts: 31
Joined: Mon May 30, 2005 7:23 am
Location: Silent Hill
Contact:

Re: Genders

Post by TMorph »

In the new version, it would be interesting to put it as compulsory when registering users. Greetings and thanks for the mod.
I feel my English, Translation with translator
CiberMorph
CiberMorph-phpbb3
stefano69
Registered User
Posts: 3
Joined: Wed Aug 05, 2009 9:09 pm

Re: Genders

Post by stefano69 »

I have a problem when you paste the code in language / en / acp / styles.php

Code: Select all

//-- mod : Genders ------------------------------------------------------------
//-- add
$lang = array_merge($lang, array(
	'IMG_ICON_GENDER_X'	=> 'Gender: None specified',
	'IMG_ICON_GENDER_M'	=> 'Gender: Male',
	'IMG_ICON_GENDER_F'	=> 'Gender: Female',
));
//-- fin mod : Genders --------------------------------------------------------
in the ACP to bookmark style does not work, perhaps someone knows what is going on please help.

Sorry for my english :roll: I come from a Polish
iDon
Registered User
Posts: 180
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by iDon »

Ive uploaded the functions file to its correct place and edited all the files correctly and also uploaded the images,refreshed,cleared the cache and image sets and yet i cant find no where to choose the gender,it does not appear in the profile,what can be wrong?i have phpbb 3.0.5
Formerly known as Xx_iDon_xX
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

Xx_iDon_xX wrote:Ive uploaded the functions file to its correct place and edited all the files correctly and also uploaded the images,refreshed,cleared the cache and image sets and yet i cant find no where to choose the gender,it does not appear in the profile,what can be wrong?i have phpbb 3.0.5
Have you looked in the UCP under the profile tab.
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

stefano69 wrote:I have a problem when you paste the code in language / en / acp / styles.php

Code: Select all

//-- mod : Genders ------------------------------------------------------------
//-- add
$lang = array_merge($lang, array(
	'IMG_ICON_GENDER_X'	=> 'Gender: None specified',
	'IMG_ICON_GENDER_M'	=> 'Gender: Male',
	'IMG_ICON_GENDER_F'	=> 'Gender: Female',
));
//-- fin mod : Genders --------------------------------------------------------
in the ACP to bookmark style does not work, perhaps someone knows what is going on please help.

Sorry for my english :roll: I come from a Polish

Are you sure you added that before

Code: Select all

?>

And not after it.
iDon
Registered User
Posts: 180
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by iDon »

CemetaryMan wrote:
Xx_iDon_xX wrote:Ive uploaded the functions file to its correct place and edited all the files correctly and also uploaded the images,refreshed,cleared the cache and image sets and yet i cant find no where to choose the gender,it does not appear in the profile,what can be wrong?i have phpbb 3.0.5
Have you looked in the UCP under the profile tab.
Yea theres nothing there,i know i edited the files correctly.
Formerly known as Xx_iDon_xX
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.
stefano69
Registered User
Posts: 3
Joined: Wed Aug 05, 2009 9:09 pm

Re: Genders

Post by stefano69 »

CemetaryMan wrote:
Are you sure you added that before

Code: Select all

?>

And not after it.
after I added, follow the instructions.
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

stefano69 wrote:
CemetaryMan wrote:
Are you sure you added that before

Code: Select all

?>

And not after it.
after I added, follow the instructions.
It is supposed to be added "before" you will mess up the file adding it after it, cause "?>" marks the end of the file.
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

Xx_iDon_xX wrote:
CemetaryMan wrote:
Xx_iDon_xX wrote:Ive uploaded the functions file to its correct place and edited all the files correctly and also uploaded the images,refreshed,cleared the cache and image sets and yet i cant find no where to choose the gender,it does not appear in the profile,what can be wrong?i have phpbb 3.0.5
Have you looked in the UCP under the profile tab.
Yea theres nothing there,i know i edited the files correctly.

All i can say then is recheck and if you have the back up file redo the edit on that one and upload it. Could be just a misplaced } or missing a ' something very small.
stefano69
Registered User
Posts: 3
Joined: Wed Aug 05, 2009 9:09 pm

Re: Genders

Post by stefano69 »

CemetaryMan wrote:
It is supposed to be added "before" you will mess up the file adding it after it, cause "?>" marks the end of the file.
I added the ">" is still the same :cry:
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

stefano69 wrote:
CemetaryMan wrote:
It is supposed to be added "before" you will mess up the file adding it after it, cause "?>" marks the end of the file.
I added the ">" is still the same :cry:
Is there a "?>" before

Code: Select all

    //-- mod : Genders ------------------------------------------------------------
    //-- add
    $lang = array_merge($lang, array(
       'IMG_ICON_GENDER_X'   => 'Gender: None specified',
       'IMG_ICON_GENDER_M'   => 'Gender: Male',
       'IMG_ICON_GENDER_F'   => 'Gender: Female',
    ));
    //-- fin mod : Genders -------------------------------------------------------- 
If there is then you need to move it after it so that the

Code: Select all

?>
is at the bottom of the file.
thecrewstyle
Registered User
Posts: 126
Joined: Sun Apr 22, 2007 5:52 am

Re: Genders

Post by thecrewstyle »

This is the way how i force the members to select their sex on the registration?
http://www.phpbb.com/community/viewtopi ... 0#p8954955
iDon
Registered User
Posts: 180
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by iDon »

Anybody?where exactly does the gender show?do i do it on the acp?because its not showing in the ucp
Formerly known as Xx_iDon_xX
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.
newborn
Registered User
Posts: 4
Joined: Sun Aug 09, 2009 11:09 am

Re: Genders

Post by newborn »

Can anyone help me out a bit here. I'm having some issues. I use the previsious version of this mod in another forum that works good. Now i'm building up a new forum using this last version , running on: 3.0.5

Having some troubles with showing the icons in view topic. Does not apear.
Image

Having some troubles with showing the gender name in profile.
Image

In user profile appear like this
Image
Attachments
scr1.jpg
scr1.jpg (31.75 KiB) Viewed 338 times
scr2.jpg
scr2.jpg (55.36 KiB) Viewed 338 times
scr3.jpg
scr3.jpg (23.19 KiB) Viewed 338 times
CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan »

Check that you uploaded the images to the style you are using then purge the imageset cache.
Locked

Return to “[3.0.x] MOD Database Releases”