Genders

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
newborn
Registered User
Posts: 4
Joined: Sun Aug 09, 2009 11:09 am

Re: Genders

Post by newborn » Sun Aug 09, 2009 2:19 pm

CemetaryMan wrote:Check that you uploaded the images to the style you are using then purge the imageset cache.

Yes I‘am upload the images and purge imageset cash. My second problem - gender is not indicated in the profile

CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan » Sun Aug 09, 2009 2:41 pm

which folder did you upload the images to?

newborn
Registered User
Posts: 4
Joined: Sun Aug 09, 2009 11:09 am

Re: Genders

Post by newborn » Sun Aug 09, 2009 2:55 pm

CemetaryMan wrote:which folder did you upload the images to?
here

Code: Select all

\www\styles\DarkFantasy\imageset
DarkFantasy theme based on subsilver2 theme.

CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: Genders

Post by CemetaryMan » Sun Aug 09, 2009 3:14 pm

Go to ACP - Styles - Imageset - refresh the Dark Style
Then remove the cache from your browser.
Then refresh the pages and see if they appear.
If that doesnt help, double check your edits and another option is to manually delete the cache from the server, I have had to do that a couple of times for the edits to show, just remember not to delete the .htaccess and index.html.

newborn
Registered User
Posts: 4
Joined: Sun Aug 09, 2009 11:09 am

Re: Genders

Post by newborn » Sun Aug 09, 2009 3:59 pm

CemetaryMan wrote:Go to ACP - Styles - Imageset - refresh the Dark Style
Then remove the cache from your browser.
Then refresh the pages and see if they appear.
If that doesnt help, double check your edits and another option is to manually delete the cache from the server, I have had to do that a couple of times for the edits to show, just remember not to delete the .htaccess and index.html.

i've done it - dut it didn't help =(


maybe the problem is in sql - here is the code of db_update.php that I used, because the standard db_update.php did not match

Xx_iDon_xX
Registered User
Posts: 179
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by Xx_iDon_xX » Mon Aug 10, 2009 10:42 am

hello,i installed the genders mod manually and it didnt work for me,ok,so i uninstalled it,and installed it via automod,now everything went ok and succesful,but i created a double

Code: Select all

ALTER TABLE phpbb_users ADD user_gender TINYINT(1) UNSIGNED NOT NULL DEFAULT 0;
in the database,so i want to know how do i delete it?what sql inquiry do i have to do in order for me to erase one of the tables since theres 2? this is the message i get when trying to clicl on a members name on the forum or when i try to click on a topic/post

Code: Select all

Fatal error: Cannot redeclare get_user_gender() (previously declared in /home/content/x/x/i/xxidonxx/html/includes/functions_genders.php:26) in /home/content/x/x/i/xxidonxx/html/includes/functions_genders.php on line 54
please i need help.
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

icywind335
Registered User
Posts: 3
Joined: Tue Jul 28, 2009 7:05 am

Re: Genders

Post by icywind335 » Mon Aug 10, 2009 12:30 pm

Is it available for phpBB 3.0.5?

Xx_iDon_xX
Registered User
Posts: 179
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by Xx_iDon_xX » Mon Aug 10, 2009 12:42 pm

icywind335 wrote:Is it available for phpBB 3.0.5?

Yes
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Xx_iDon_xX
Registered User
Posts: 179
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by Xx_iDon_xX » Mon Aug 10, 2009 1:38 pm

Xx_iDon_xX wrote:hello,i installed the genders mod manually and it didnt work for me,ok,so i uninstalled it,and installed it via automod,now everything went ok and succesful,but i created a double

Code: Select all

ALTER TABLE phpbb_users ADD user_gender TINYINT(1) UNSIGNED NOT NULL DEFAULT 0;
in the database,so i want to know how do i delete it?what sql inquiry do i have to do in order for me to erase one of the tables since theres 2? this is the message i get when trying to clicl on a members name on the forum or when i try to click on a topic/post

Code: Select all

Fatal error: Cannot redeclare get_user_gender() (previously declared in /home/content/x/x/i/xxidonxx/html/includes/functions_genders.php:26) in /home/content/x/x/i/xxidonxx/html/includes/functions_genders.php on line 54
please i need help.

Anybody?
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Xx_iDon_xX
Registered User
Posts: 179
Joined: Sat May 30, 2009 8:23 am
Location: Tampa, FL
Contact:

Re: Genders

Post by Xx_iDon_xX » Mon Aug 10, 2009 6:34 pm

Bump...Anybody?
Knowledge is free. We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

thecrewstyle
Registered User
Posts: 126
Joined: Sun Apr 22, 2007 5:52 am

Re: Genders

Post by thecrewstyle » Tue Aug 11, 2009 5:16 pm

Hi,
I managed to make it appear when someone is registering on the forum (with this http://www.phpbb.com/community/viewtopi ... 0#p8944875), and he will choose the sex, but how i manage to make mandatory. Somebody can help me? How Could I make it a required field?
Thanks

ash369
Registered User
Posts: 51
Joined: Sun Jul 19, 2009 11:33 am
Location: United Kingdom
Contact:

Re: Genders

Post by ash369 » Tue Aug 11, 2009 6:28 pm

Hey everyone.

I have a problem, like an idiot i ran the db_update.php before editing the files and i can't see the gender column. I get this SQL error when i try and run it again.

General Error

Code: Select all

SQL ERROR [ mysqli ]

Duplicate column name 'user_gender' [1060]

SQL

ALTER TABLE `phpbb3_users` ADD COLUMN `user_gender` tinyint(1) DEFAULT '1' NOT NULL

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/db/db_tools.php
LINE: 900
CALL: dbal_mysqli->sql_query()

FILE: includes/db/db_tools.php
LINE: 1219
CALL: phpbb_db_tools->_sql_run_sql()

FILE: db_update.php
LINE: 32
CALL: phpbb_db_tools->sql_column_add()
I guess i have to remove the column and add it again?
But how. Help please? :(

Or maybe i have a different problem? :/

thecrewstyle
Registered User
Posts: 126
Joined: Sun Apr 22, 2007 5:52 am

Re: Genders

Post by thecrewstyle » Wed Aug 12, 2009 3:46 pm

thecrewstyle wrote:Hi,
I managed to make it appear when someone is registering on the forum (with this http://www.phpbb.com/community/viewtopi ... 0#p8944875), and he will choose the sex, but how i manage to make mandatory. Somebody can help me? How Could I make it a required field?
Thanks
bump

thecrewstyle
Registered User
Posts: 126
Joined: Sun Apr 22, 2007 5:52 am

Re: Genders

Post by thecrewstyle » Thu Aug 13, 2009 7:14 pm

up

thecrewstyle
Registered User
Posts: 126
Joined: Sun Apr 22, 2007 5:52 am

Re: Genders

Post by thecrewstyle » Fri Aug 14, 2009 9:33 am

up

Locked

Return to “[3.0.x] MOD Database Releases”