Soft Delete

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
jmjm003
Registered User
Posts: 275
Joined: Sat Dec 22, 2007 7:05 pm

Re: Soft Delete

Post by jmjm003 »

Do you have an ETA on your next release EXreaction?
When ready, will it address this problem I had?
http://www.phpbb.com/community/viewtopi ... 5#p4351515

Not at all trying to pressure you into a faster update. I completely understand that life comes before MODs.

I would like to go live with your MOD before handing the keys over to a few more moderators.
I'm fine with letting them soft delete. I however would like to have final say.

Thank you.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

After I release the Beta version of the User Blog Mod I will be taking another look at this mod (within a few days if things keep going smoothly).

I have that post in my to do list and I will take a look at it when I get that far. :)
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

I'm not sure, but I think this is interfering with my permission to delete shadow topics in the MCP, because even though I have yes to all my permission for my custom made group, the only group I'm in, I keep getting the following error:

You do not have the necessary permissions to complete this operation.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

If the topic is already soft deleted you must give yourself permission to hard delete it.
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

I have permission to hard delete topics. I have done it in fact. Problem is if I soft/hard delete the shadowed topic by clicking on it I'll be deleting the actual topic where it's moved to. I need to be able to do it using the MCP where it says [Delete shadowed topic]
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

Oh, I thought you were talking about something else.

I will look into that as well.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

Ok, I have fixed all of the bugs that were reported (I hope) and released 1.0.7.
http://lithiumstudios.org/forum/viewtop ... 2780#p2717
jmjm003
Registered User
Posts: 275
Joined: Sat Dec 22, 2007 7:05 pm

Re: Soft Delete

Post by jmjm003 »

I will get back to you as soon as I have time to install it again.
Thank you!

:::Does the Happy Dance::: :D
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

Do I need to upload the included files listed in the update from 1.06 to 1.07 and run the install.php again? Also will this make it so I can delete shadowed topics from the MCP?

Dude. I just found a duplicate edit for the styles/prosilver/template/mcp_forum.html

Find
Tip: This may be a partial find and not the whole line.

Code: Select all

<li class="row<!-- IF topicrow.S_ROW_COUNT is odd -->
In-line Find
Tip: This is a partial match of a line for in-line operations.

Code: Select all

" <!-- IF topicrow.S_TOPIC_DELETED -->style="background-color: #33FF00;"<!-- ENDIF -->
In-line Replace With

Code: Select all

<!-- IF topicrow.S_TOPIC_DELETED --> reported<!-- ENDIF -->"
I was instructed to do this when installing your previous version as the full install. Not as an upgrade. I had no previous versions of your mod on. Just 1.0.6. So, it makes me question if this is a good idea or will it mess up my board? I noticed something similar in the instructions before that for the language/en/viewforum.php where it says:

Find
Tip: This may be a partial find and not the whole line.

Code: Select all

'DELETED_POST_SHOW'				=> 'This post has been soft deleted.  Click here to show the post.',
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code: Select all

	'SOFT_DELETED'					=> 'Soft Deleted',
There's already a line there that says

Code: Select all

	'TOPIC_SOFT_DELETED'			=> 'This topic has been deleted.',
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

It should not say to copy the install.php file. I think I forgot to remove that.

Yes, you can delete the shadow topics correctly now.


Other than the install.php file, follow the upgrade instructions exactly as it says.
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

EXreaction wrote:It should not say to copy the install.php file. I think I forgot to remove that.

Yes, you can delete the shadow topics correctly now.


Other than the install.php file, follow the upgrade instructions exactly as it says.
Yea, but the styles/prosilver/template/mcp_forum.html, is telling me to replace " <!-- IF topicrow.S_TOPIC_DELETED -->style="background-color: #33FF00;"<!-- ENDIF --> with <!-- IF topicrow.S_TOPIC_DELETED --> reported<!-- ENDIF -->" and it's already been done.
Last edited by Renodil on Sun Mar 02, 2008 5:07 am, edited 2 times in total.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: Soft Delete

Post by EXreaction »

No it does not.

<!-- IF topicrow.S_TOPIC_DELETED -->style="background-color: #33FF00;"<!-- ENDIF --> was added by a previous version and needs to be replaced.
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

Oh duh. I didn't realize this was one of the lines with a color code. I edited it to be the same as a color on the forum. E1EBF2 :oops:

You made a mistake too though. In the next template edit styles/prosilver/template/mcp_topic.html you forgot the space after the ".

Code: Select all

"<!-- IF topicrow.S_TOPIC_DELETED --> style="background-color: #33FF00;"<!-- ENDIF -->
Another problem. The replace with for the last file edit for prosilver, namely styles/prosilver/template/viewtopic_body.html shows nothing. You're supposed to delete the

Code: Select all

	<!-- IF postrow.S_POST_DELETED-->
		<script type="text/javascript" src="{T_TEMPLATE_PATH}/mods/soft_delete.js"></script>
		<div id="d{postrow.POST_ID}" class="post" style="background-color: #33FF00;">
			<div class="inner"><span class="corners-top"><span></span></span>
				<div class="postbody" style="width: 100%;">
					<div style="text-align: center;">
						<a href="#none" onClick="toggleDiv('p{postrow.POST_ID}'); toggleDiv('d{postrow.POST_ID}');">{L_DELETED_POST_SHOW}</a>
						<noscript><br/>{L_POST_SHOW_NO_JS}</noscript>
					</div>
				</div>
			<div class="back2top"><a href="#wrap" class="top" title="{L_BACK_TO_TOP}">{L_BACK_TO_TOP}</a></div>
			<span class="corners-bottom"><span></span></span></div>
		</div>
	<!-- ENDIF -->
?
jmjm003
Registered User
Posts: 275
Joined: Sat Dec 22, 2007 7:05 pm

Re: Soft Delete

Post by jmjm003 »

Have installed the latest release now.
I did a clean install of the mod rather than doing an upgrade.
Copy topic error is no longer happening to me. Thank you.

However, maybe it's just me. After setting permissions for me to be able to hard delete. I'm unable to use the Quick-mod tools: at the bottom of topics to do a hard delete. I first soft delete the topic, then try to hard delete and get the message I do not have the permissions to do so. Yet I can hard delete post within the topic until it's gone.

Am I missing a permission setting somewhere else? Or is there a bug with Quick-mod tools: ?

Thanks EXreaction for your work and help.
User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Soft Delete

Post by Renodil »

I was just about to say the same thing. We can now delete shadowed topics, but we can no longer delete topics themselves using the Quick-mod tools. You fixed one problem and created another identical problem. BTW, how do we change the color now. It's on ECD5D8 and I can't find that code anywhere on the xml file. I hate pink. And what happened to the JavaScript that had you click a link to see the soft delete? Should I just go ahead and delete that .js file now?
Locked

Return to “[3.0.x] MOD Database Releases”