Page 15 of 24

Re: Advanced Double Activation Pack

Posted: Mon May 25, 2009 11:05 pm
by katib
Thanks for help
The above code worked fine: the justification input box appears correctelly
However, the new user gets his account activated after an admin activate it, without clicking the activation link from an email :shock:
if the new user click this link, he gets: account already activated
so the two mod are probabelly incompatible

Re: Advanced Double Activation Pack

Posted: Tue May 26, 2009 3:47 pm
by Martin Truckenbrodt
Hello katib,
normally the administrators only have to wait for an email which is been sent after thene registered user has verified his email address in the first step.
If an administrator looks under ACP->MAIN PAGE->INACTIVE USERS and then activates the users which have been listed their then the default way is broken.

Bye Martin

Re: Advanced Double Activation Pack

Posted: Wed May 27, 2009 9:26 pm
by katib
Thanks a lot Martin for explanations
I have got the logic behind !! ;)
Well, the INACTIVE USERS list has several fielsd: Username, date of registration, last visit...etc,

Image

So is it possible to add the following field ?
Status: waiting email verification/email verified
(foe eaxample: if a user click the activation link within email, status will idicates: "email verified"
so admin wont activate the new user untill email has been verified

Re: Advanced Double Activation Pack

Posted: Thu May 28, 2009 11:33 am
by Martin Truckenbrodt
Hello katib,
this will come with version 1.4.0. It's included by now but other things in 1.4.0 are not working well at the moment.

Bye Martin

Re: Advanced Double Activation Pack

Posted: Thu May 28, 2009 8:40 pm
by katib
@ Martin Truckenbrodt
Thanks a lot it will be a handy feature :)

Re: Advanced Double Activation Pack

Posted: Fri May 29, 2009 7:16 pm
by Monteria
Martin, Great Mod!

I loaded version 1.2.4 on my phpbb3.0.4 today via. MODX install, completed the DIY and cleared all cache manually.

It worked perfectly except that the admins (founders) are not receiving any e-mail after the registrants have completed e-mail confirmation.

I am running a "Milky Way" style. Does that have anything to do with it?

I'm sorry but I am a total novice. I don't know what other information to give you..... Any ideas?

Re: Advanced Double Activation Pack

Posted: Fri May 29, 2009 8:55 pm
by Martin Truckenbrodt
Hello,
normally the problem schould not be related to the template files.

Please check your includes/ucp/ucp_activate.php manually. http://www.phpbb.com/mods/installing/

Bye Martin

Re: Advanced Double Activation Pack

Posted: Sat May 30, 2009 7:01 pm
by Monteria
You are the man, Marty!

I don't know where the error was but I took an original copy of includes/ucp/ucp_activate.php out of the backup file I had saved and manually edited it by emulation of the DIY in install.XML.

I'm curious why the MODX install didn't work properly but it does not matter any more.

Thanks again,

Steve

Re: Advanced Double Activation Pack

Posted: Sat May 30, 2009 8:58 pm
by Martin Truckenbrodt
Hello Steve,
no problem!

Thank you very much for the feedback!

Bye Martin

Re: Advanced Double Activation Pack

Posted: Thu Jun 11, 2009 8:17 pm
by NicksNet
Hello,

thanks for the mod, but i have a problem with activation:

i (admin) receive the email with activationlink, but if i click this link im logged out completle every time, because my sid will not included...

Code: Select all

http://tattoo-freun.de/adm/index.php?i=users&mode=verify&u=109

so i tested to includ the sid manually, but now its opens following errorcode:

Code: Select all

Fatal error: Maximum execution time of 30 seconds exceeded in .../includes/functions_content.php on line 1184
(... is cleaned rootpath ;) )

my links to test is:

Code: Select all

http://tattoo-freun.de/adm/index.php?i=users&mode=verify&u=109&sid=blablabla and http://tattoo-freun.de/adm/index.php?sid=blablabla&i=users&mode=verify&u=109
(blablabla is cleaned sid ;) )

how can i fix it, so that the link in adminmail is working???

MfG Nick

Re: Advanced Double Activation Pack

Posted: Thu Jun 11, 2009 8:33 pm
by Martin Truckenbrodt
Hello,
which version have you installed - 1.0.9 or 1.2.4?
1.0.9 is buggy http://www.phpbb.com/community/viewtopi ... 5#p4231435 but 1.2.4 should be well working.
BTW: I hope to complete 1.4.0 tomorrow.

To use the verify link from the email you have to be logged in to your board using the auto login. When you are clicking or opening the verify links you are asked for the password to get in into the ACP.

Have you purged the board cache? Are the ACP modules installed correctly?

Bye Martin

Re: Advanced Double Activation Pack

Posted: Fri Jun 12, 2009 12:14 am
by NicksNet
Martin Truckenbrodt wrote:Hello,
which version have you installed - 1.0.9 or 1.2.4?
1.0.9 is buggy http://www.phpbb.com/community/viewtopi ... 5#p4231435 but 1.2.4 should be well working.
BTW: I hope to complete 1.4.0 tomorrow.

To use the verify link from the email you have to be logged in to your board using the auto login. When you are clicking or opening the verify links you are asked for the password to get in into the ACP.

Have you purged the board cache? Are the ACP modules installed correctly?

Bye Martin
very interesting... i have downloaded the mod yesterday (now its 02:11am in germany^^) from first post and its version 1.0.9 - why you do not add the newer version here, if the 1.0.9 is buggy :shock: :?:

and 1. i use autologin every time, 2. i purge cache every time i add, edit or update a mod ;)


i will update to 1.2.4 (hopefully i can update) - or its better to wait for 1.4.0?

regards


EDIT: l0l, am namen hätte ichs merken müssen :lol:

Die Datei ./../files/2_6029bfb58637548defb14e5312698881 existiert nicht.

wie komme ich an die 1.2.4er ran?

Re: Advanced Double Activation Pack

Posted: Fri Jun 12, 2009 8:26 am
by Martin Truckenbrodt
Hello,
1.2.4 is not added here to the MOD DB cause it has been denied on validation processes by two or three minor problems. I decided to include two new features and not only to fix these small problems for a 1.2.5 release.

On Wednesday I've reinitialized my virtual webserver. Before I've backuped the files with FileZilla but the attachment saved at the phpBB3 installation haven't been downloaded. I don't know why. But now 1.2.4 is available again.

Thank you very much fpr the feedback.

Please give me this day today for 1.4.0.

German translation of this post per PM. ;)

Bye Martin

Re: Advanced Double Activation Pack

Posted: Fri Jun 12, 2009 2:30 pm
by NicksNet
Martin Truckenbrodt wrote:Hello,
1.2.4 is not added here to the MOD DB cause it has been denied on validation processes by two or three minor problems. I decided to include two new features and not only to fix these small problems for a 1.2.5 release.

On Wednesday I've reinitialized my virtual webserver. Before I've backuped the files with FileZilla but the attachment saved at the phpBB3 installation haven't been downloaded. I don't know why. But now 1.2.4 is available again.

Thank you very much fpr the feedback.

Please give me this day today for 1.4.0.

German translation of this post per PM. ;)

Bye Martin
first... german translation not required :roll: - read and understand of english posts is much easier than posting ;)

second... i can wait for 1.4.0 - no panic

but finally one question i have: is it better to uninstall old version or can i update to 1.4.0 without problems? or should i update to 1.2.4 and then to 1.4.0?

thanks

Re: Advanced Double Activation Pack

Posted: Fri Jun 12, 2009 2:39 pm
by Martin Truckenbrodt
Hello,
it's better to uninstall 1.0.9 first. At least the database changes.

I've finished all tests an a 1.4.0 installation some minutes ago.

Now I only have to make the package and to check it with MPV. Perhaps one hour till 1.4.0 will be released.

Bye Martin