Rules page

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: Rules page

Post by MydnyteSyn » Mon May 12, 2008 3:17 am

Great, thank you :)

User avatar
LxPower*
Registered User
Posts: 82
Joined: Wed Jan 03, 2007 2:31 am
Location: C:\

Re: Rules page

Post by LxPower* » Wed May 14, 2008 7:57 pm

Very weird mine rules work fine but this icon don´t show up...
I Upload it to
/styles/prosilver/theme/images/

And i looked to :

faq.php,
includes/functions.php,
language/en/common.php


All files all seems to be fine.

Also i chek .css files
Here are my lines:

styles/prosilver/template/overall_header.html

Code: Select all

			<ul class="linklist rightside">
				<li class="icon-rules"><a href="{U_RULES}" title="{L_RULES_PAGE}">{L_RULES}</a></li>
				<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
styles/prosilver/theme/bidi.css

Code: Select all

.rtl .sitehome, .rtl .icon-faq, .rtl .icon-rules, .rtl .icon-members,...
styles/prosilver/theme/buttons.css

Code: Select all

.sitehome, .icon-faq, .icon-rules, .icon-members,...
styles/prosilver/theme/colours.css

Code: Select all

.icon-faq						{ background-image: url("{T_THEME_PATH}/images/icon_faq.gif"); }
.icon-rules						{ background-image: url("{T_THEME_PATH}/images/icon_rules.gif"); }
.icon-members					{ background-image: url("{T_THEME_PATH}/images/icon_members.gif"); }
And i Refreshed prosilver style and also chase ..

Eny Ideas ?

For eviL<3 Thanks for very good mod and keep up your nice codding.
phpBB Just The Best !

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Rules page

Post by igorw » Wed May 14, 2008 8:28 pm

You refreshed theme and imageset?
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

User avatar
LxPower*
Registered User
Posts: 82
Joined: Wed Jan 03, 2007 2:31 am
Location: C:\

Re: Rules page

Post by LxPower* » Wed May 14, 2008 8:45 pm

eviL<3 wrote:You refreshed theme and imageset?
Yep i refreshed twice ...
And also Cache prosilver

Its fine now...

My little mistake ;)

Thanks for help :)
phpBB Just The Best !

bluedolphin
Registered User
Posts: 11
Joined: Wed Jan 23, 2008 1:04 pm

Re: Rules page

Post by bluedolphin » Sat May 17, 2008 4:51 am

Is this MOD working for phpbb 3.0.1?
I tried to install the MOD but I got a blank page when I tried to access my forum.
I realised that the blank page happened after I modified the common.php
So is that the problem?

For this code

Code: Select all

'RULES_VOTE_CANNOT'
Add after

Code: Select all

//-- mod : Rules page ------------------------------------------------------------
//-- add
	'RULES_PAGE'				=> 'Board Rules',
	'RULES'						=> 'Rules',
//-- fin mod : Rules page --------------------------------------------------------
Do I add the code immediately after the 'RULES_VOTE_CANNOT' words or after that line so that it becomes

Code: Select all

	'RULES_VOTE_CANNOT'			=> 'You <strong>cannot</strong> vote in polls in this forum',
//-- mod : Rules page ------------------------------------------------------------
//-- add
	'RULES_PAGE'				=> 'Board Rules',
	'RULES'						=> 'Rules',
//-- fin mod : Rules page --------------------------------------------------------

User avatar
SAFFLEUR
Registered User
Posts: 323
Joined: Thu Nov 24, 2005 5:56 am
Location: Lenoir NC
Contact:

Re: Rules page

Post by SAFFLEUR » Sat May 17, 2008 5:07 am

bluedolphin wrote:Is this MOD working for phpbb 3.0.1?
I tried to install the MOD but I got a blank page when I tried to access my forum.
I realised that the blank page happened after I modified the common.php
So is that the problem?

This is how it should look

Code: Select all

	'RULES_VOTE_CANNOT'			=> 'You <strong>cannot</strong> vote in polls in this forum',
	
//-- mod : Rules page ------------------------------------------------------------
//-- add
	'RULES_PAGE'				=> 'Board Rules',
	'RULES'						=> 'Rules',
//-- fin mod : Rules page --------------------------------------------------------

bluedolphin
Registered User
Posts: 11
Joined: Wed Jan 23, 2008 1:04 pm

Re: Rules page

Post by bluedolphin » Sat May 17, 2008 5:26 pm

SAFFLEUR wrote: This is how it should look

Code: Select all

	'RULES_VOTE_CANNOT'			=> 'You <strong>cannot</strong> vote in polls in this forum',
	
//-- mod : Rules page ------------------------------------------------------------
//-- add
	'RULES_PAGE'				=> 'Board Rules',
	'RULES'						=> 'Rules',
//-- fin mod : Rules page --------------------------------------------------------
Thanx. I edited it and put in the spacing before adding the code, but I'm still having a blank screen....

User avatar
SAFFLEUR
Registered User
Posts: 323
Joined: Thu Nov 24, 2005 5:56 am
Location: Lenoir NC
Contact:

Re: Rules page

Post by SAFFLEUR » Sat May 17, 2008 5:47 pm

Look over your edits again for the whole install? No blank lines before <? or after ?> is there?

bluedolphin
Registered User
Posts: 11
Joined: Wed Jan 23, 2008 1:04 pm

Re: Rules page

Post by bluedolphin » Mon May 19, 2008 9:31 am

SAFFLEUR wrote:Look over your edits again for the whole install? No blank lines before <? or after ?> is there?
No, there wasn't any blank lines before or after ?>
I found the problem though. I noticed that there were Chinese characters appearing in my common.php scripts when I opened it with Windows NotePad or WordPad. So I did a search in phpbb forum and realized that there may be a problem with the Unicode thingy. Downloaded NotePad++ , opened the file with the program, edited the code and the MOD is working fine on my forum now.
Thanx alot for the help anyway. :)

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: Rules page

Post by MydnyteSyn » Sat Jun 21, 2008 11:56 pm

Do I need to change any file permissions in order to be able to edit the rules from the admin CP of the forum?

User avatar
SAFFLEUR
Registered User
Posts: 323
Joined: Thu Nov 24, 2005 5:56 am
Location: Lenoir NC
Contact:

Re: Rules page

Post by SAFFLEUR » Sun Jun 22, 2008 1:38 am

MydnyteSyn wrote:Do I need to change any file permissions in order to be able to edit the rules from the admin CP of the forum?
I suggest using the FAQ Editor MOD that ExReaction did, it allows you to modify the rules page as well.

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: Rules page

Post by MydnyteSyn » Mon Jun 23, 2008 1:53 pm

I have that one, also :) But, I figured out my dilemma. Thank you very much for your helpful suggestion :)

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: Rules page

Post by .:: Chico ::. » Thu Jul 10, 2008 7:36 pm

Is there a 3.0.1 update for this mod?

User avatar
SAFFLEUR
Registered User
Posts: 323
Joined: Thu Nov 24, 2005 5:56 am
Location: Lenoir NC
Contact:

Re: Rules page

Post by SAFFLEUR » Thu Jul 10, 2008 8:52 pm

.:: Chico ::. wrote:Is there a 3.0.1 update for this mod?
I don't believe a 3.0.1 update is required for this MOD

User avatar
Renodil
Registered User
Posts: 668
Joined: Mon Nov 14, 2005 8:48 am
Contact:

Re: Rules page

Post by Renodil » Sun Aug 03, 2008 12:59 pm

I had to redo my board, but I got a problem. The Rules link just refreshes the current page. Apparently it links to whatever page you're currently viewing instead of linking to the rules page. What gives?
Last edited by Renodil on Mon Aug 04, 2008 11:56 pm, edited 1 time in total.

Locked

Return to “[3.0.x] MOD Database Releases”