Auto Groups

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
wowfans
Registered User
Posts: 29
Joined: Sun Mar 22, 2009 12:23 pm

Re: Auto Groups

Post by wowfans » Sun Mar 07, 2010 3:35 am

same above, EDIT.
Last edited by wowfans on Sun Mar 14, 2010 1:47 pm, edited 1 time in total.
Sorry for my pool English.

Ezio_Auditore
Registered User
Posts: 23
Joined: Mon Feb 15, 2010 12:59 pm

Re: Auto Groups

Post by Ezio_Auditore » Sun Mar 14, 2010 2:24 am

I installed this on 3.0.7 without a hitch :D

However, all members, including: Admins; Global Mods and Mods are being demoted to the 'Registered user' group automatically if they log out and log back in.

Any ideas?

Deniph
Registered User
Posts: 11
Joined: Thu Mar 11, 2010 2:15 am

Re: Auto Groups

Post by Deniph » Sun Mar 14, 2010 7:21 am

i did install the current phpbb
i did install all languages
i did install porsilver and subsilver and two additional styles
i did instal automod
i did upload auto-group (nothing else until now)

in the install it did say that all works well but the additional files cant be installed
so i did install them manualy
then i did retry with the automod installer
it did say that all will work well but not the french translation
so i did copy the french translation to all frens language folder like FR or FR-oral and the other one
still it did say that the french file will not work
so i forced installation
it did say all success but not french

i did clean the cache

i whent to group settins and added some groups
and i also whent to ranks and added some ranks

but i still cant find anything that looks like auto-group
i did reload and clear cache and added groups and try and try and try
somehow it is not working

so i did uninstall with automod
it did say that it can find nothing
total not success on deinstalation

what can i do now?

shall i replace all files which are misted with the original ones which i still have?
will then everything be clean again?

shall i also clean up my sql db?

can someone tell me exactly which files all are affected by auto-group?
so i can replace them with original files from phpbb3x
and maybe which sql entries i have to kill?

would be a favor :D

and if all is clean again...

how can i install it so that it will work?
i realy think it is maybe what i need and would like to gife it a other try...
but maybe someone has a idea about what i did wrong and how i can do it better so that it will work :D

i have no idea about php and such things, maybe one can spend me some simple words on that problem ;)

thanks in advance :D

Deniph
Registered User
Posts: 11
Joined: Thu Mar 11, 2010 2:15 am

Re: Auto Groups

Post by Deniph » Mon Mar 15, 2010 4:08 am

OK now it works :D

i did reset the phpbb forum, this was no problem because i had no other mods installed
i did delete the mod in automod
then i did just upload the original files and overwrite the old modified files
so all was like new
in the SQL db i did nothing

then i uploaded auto group again through automod
in automod settings i had to set the direct mode ... what ever it means
then i did try to install auto group with automod again
now i told me again that all will be OK exept the FR language...
i did uload the FR language again to the correct folder where it allready was, so i did overwrite it
then i whent to automod and did press retry
still it said that all will be OK but not FR language
so i thoght "who on earth speaks FR just force the installation now" :)
so it did say that all is good exept the SQL thng because theese entries did allready exist (dublicate table blah) and the FR language file was also still red ;(
then i did go to group settings and ....

TaTaRaa ... there where the auto group fields :D

then i did also install the Ultimate Point mod... with no problem so i guess they are compatible now :D

i am now very happy :D
thank you for this cool mod :D

Samanthavv
Registered User
Posts: 36
Joined: Tue Mar 31, 2009 2:07 am
Location: Alaska
Contact:

Re: Auto Groups

Post by Samanthavv » Tue Mar 16, 2010 4:37 am

Does this work with 3.0.7-PL?
I am a BIRTH DOULA.
I use CLOTH DIAPERS.
My son is exclusively BREASTFED.
I have donated my MILK to 8 other babies in need.
I keep a BLOG at http://www.anotherteenmom.com

Himen
Registered User
Posts: 11
Joined: Sun Jun 01, 2008 8:46 pm

Re: Auto Groups

Post by Himen » Tue Mar 16, 2010 5:13 pm

SQL ERROR [ mysqli ]

Unknown column 'group_auto_default' in 'field list' [1054]

SQL

SELECT group_id, group_auto_default, group_min_posts, group_max_posts, group_min_days, group_max_days, group_min_warnings, group_max_warnings FROM phpbb_groups WHERE group_type <> 3 AND ( group_min_posts <> 0 OR group_max_posts <> 0 OR group_min_days <> 0 OR group_max_days <> 0 OR group_min_warnings <> 0 OR group_max_warnings <> 0 )

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_autogroup.php
LINE: 76
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_posting.php
LINE: 2375
CALL: auto_group()

FILE: posting.php
LINE: 1002
CALL: submit_post()

help this comming if sombody post

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Auto Groups

Post by RMcGirr83 » Tue Mar 16, 2010 5:20 pm

You didn't run the sql query on the database to update it.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Himen
Registered User
Posts: 11
Joined: Sun Jun 01, 2008 8:46 pm

Re: Auto Groups

Post by Himen » Tue Mar 16, 2010 5:52 pm

no how a this make

Samanthavv
Registered User
Posts: 36
Joined: Tue Mar 31, 2009 2:07 am
Location: Alaska
Contact:

Re: Auto Groups

Post by Samanthavv » Wed Mar 17, 2010 11:14 am

So, does this work on 3.0.7???
I am a BIRTH DOULA.
I use CLOTH DIAPERS.
My son is exclusively BREASTFED.
I have donated my MILK to 8 other babies in need.
I keep a BLOG at http://www.anotherteenmom.com

User avatar
Lisbon
Registered User
Posts: 825
Joined: Wed Jan 30, 2008 12:28 pm
Location: Zermatt

Re: Auto Groups

Post by Lisbon » Wed Mar 17, 2010 11:36 am

Samanthavv wrote:So, does this work on 3.0.7???
Yes!

Himen
Registered User
Posts: 11
Joined: Sun Jun 01, 2008 8:46 pm

Re: Auto Groups

Post by Himen » Wed Mar 17, 2010 4:40 pm

hello all

a instal mod all is ok in sol to

bat if a in acp make some change

minimum post or somthing other and go to save nothin hapening

a go back and all is 0

please help what is this for problem

sorry for bad english

Samanthavv
Registered User
Posts: 36
Joined: Tue Mar 31, 2009 2:07 am
Location: Alaska
Contact:

Re: Auto Groups

Post by Samanthavv » Thu Mar 18, 2010 1:17 am

Installed, and it works well! :D
I am a BIRTH DOULA.
I use CLOTH DIAPERS.
My son is exclusively BREASTFED.
I have donated my MILK to 8 other babies in need.
I keep a BLOG at http://www.anotherteenmom.com

Himen
Registered User
Posts: 11
Joined: Sun Jun 01, 2008 8:46 pm

Re: Auto Groups

Post by Himen » Thu Mar 18, 2010 3:22 pm

Himen wrote:hello all

a instal mod all is ok in sol to

bat if a in acp make some change

minimum post or somthing other and go to save nothin hapening

a go back and all is 0

please help what is this for problem

sorry for bad english
pl help me thanks

zmigavac
Registered User
Posts: 1
Joined: Thu Mar 18, 2010 6:05 pm

Re: Auto Groups

Post by zmigavac » Thu Mar 18, 2010 6:14 pm

Hello,

I have problem with mod.
I have succesfully instaled everything (sql too) and I can see everything is OK in ACP, in meneger groups settings everything is OK too.
But when I put ''minimum posts required'' to 10 and when I save it and go back again there - there is 0 (zero).

Whatever I write and when I put that catch - the problem is same.

Please tell me what to do?

CoeyCoey
Registered User
Posts: 14
Joined: Mon Oct 02, 2006 7:16 pm

Re: Auto Groups

Post by CoeyCoey » Sat Mar 20, 2010 5:57 pm

I would like to have my usergroups in Joomla be automatically applied to my usergroups in PHPBB. Is there anyway to modify this Mod to do that. I am using Jfusion to link them, but the usergroups don't spill over. If there is no current way to do this, I am willing to pay to have it done.

Thanks

Locked

Return to “[3.0.x] MOD Database Releases”