Auto Groups

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Truendo
Registered User
Posts: 53
Joined: Sat Apr 18, 2009 7:42 pm

Re: Auto Groups

Post by Truendo » Sat Dec 05, 2009 2:03 am

NathanFtw wrote:
A_Jelly_Doughnut wrote:
DoYouSpeakWak wrote:If i write this in a group description. "When you reach 250 posts you will automatically be transfered to this group" But when the user hits 250 post and nothing happends i can imagine that the leader of that group getting a few pms about it.
Users should be automatically moved between groups after they post their 250th post. (With the asterisk that it won't work if that 250th post is on the moderation queue)
NathanFtw wrote:Hm this mod seems to be going nuts.

Ive got a group which the registered users will be changed to if 5 posts are made, they do that, but my staff who have like 30 posts and what not keep getting moved into the group also, so our defaults are reset same with our colors? What could the issue be?
This is the intended behavior. All users are added to the auto groups. It is a common feature request to have some sort of ignore list, but that feature has not yet been written.

Ok thanks.
Well, actually, although not officially endorsed by the mod author, I did find a fix for this. I haven't tested it with the 3.0.6 version, yet, though.

If you want to take a look at it, go here.

This prevents the mod from changing the admin and mod groups. If you want to prevent it from changing certain other groups, just add the group id.

NathanFtw
Registered User
Posts: 247
Joined: Mon Jun 15, 2009 7:59 am

Re: Auto Groups

Post by NathanFtw » Sat Dec 05, 2009 5:22 am

Truendo wrote:
NathanFtw wrote:
A_Jelly_Doughnut wrote:
DoYouSpeakWak wrote:If i write this in a group description. "When you reach 250 posts you will automatically be transfered to this group" But when the user hits 250 post and nothing happends i can imagine that the leader of that group getting a few pms about it.
Users should be automatically moved between groups after they post their 250th post. (With the asterisk that it won't work if that 250th post is on the moderation queue)
NathanFtw wrote:Hm this mod seems to be going nuts.

Ive got a group which the registered users will be changed to if 5 posts are made, they do that, but my staff who have like 30 posts and what not keep getting moved into the group also, so our defaults are reset same with our colors? What could the issue be?
This is the intended behavior. All users are added to the auto groups. It is a common feature request to have some sort of ignore list, but that feature has not yet been written.

Ok thanks.
Well, actually, although not officially endorsed by the mod author, I did find a fix for this. I haven't tested it with the 3.0.6 version, yet, though.

If you want to take a look at it, go here.

This prevents the mod from changing the admin and mod groups. If you want to prevent it from changing certain other groups, just add the group id.
Oh ok, thanks it looks good, the board im trying to install it on is a 3.0.5 one anyway :)

User avatar
hejowicz
Registered User
Posts: 442
Joined: Sun Dec 23, 2007 4:03 pm

Re: Auto Groups

Post by hejowicz » Sat Dec 05, 2009 9:58 am

Lisbon wrote:
hejowicz wrote:How set up auto grups mod ? .. I mean where is this options .. i can't find that :|
Tab "user and groups" -> menage groups -> config gruop
I don't see "config gruop" :?

User avatar
Lisbon
Registered User
Posts: 825
Joined: Wed Jan 30, 2008 12:28 pm
Location: Zermatt

Re: Auto Groups

Post by Lisbon » Sat Dec 05, 2009 10:08 am

hejowicz wrote:
Lisbon wrote:
hejowicz wrote:How set up auto grups mod ? .. I mean where is this options .. i can't find that :|
Tab "user and groups" -> menage groups -> config gruop
I don't see "config gruop" :?
Image

User avatar
Lisbon
Registered User
Posts: 825
Joined: Wed Jan 30, 2008 12:28 pm
Location: Zermatt

Re: Auto Groups

Post by Lisbon » Sat Dec 05, 2009 1:11 pm

what happens whit this mod whem config is like this:
Image

But config of Newly registered users is like this:
Image

:?: :?: :?: :?:

richey
Registered User
Posts: 612
Joined: Mon Feb 18, 2002 4:26 pm
Location: now@Cyberspace
Contact:

Re: Auto Groups

Post by richey » Sat Dec 05, 2009 2:37 pm

Is anyone in contact with the MOD author or knows how to make this work with 3.0.6 ?

function_group_create() (in functions_user.php) is totally different from 3.0.5 .... :shock:


thanks,
r.
.

Peter77sx
Registered User
Posts: 3253
Joined: Wed Nov 09, 2005 2:51 pm

Re: Auto Groups

Post by Peter77sx » Sat Dec 05, 2009 2:57 pm


richey
Registered User
Posts: 612
Joined: Mon Feb 18, 2002 4:26 pm
Location: now@Cyberspace
Contact:

Re: Auto Groups

Post by richey » Sat Dec 05, 2009 5:25 pm

thanks very much!! :)
.

User avatar
Lisbon
Registered User
Posts: 825
Joined: Wed Jan 30, 2008 12:28 pm
Location: Zermatt

Re: Auto Groups

Post by Lisbon » Sat Dec 05, 2009 6:02 pm

Today i have go to -> ACP -> Users and Groups -> Manage groups -> Newly registered users (settings) -> "i have change something in "Group description"" -> Submit (but whem i click Submit becomes this error) ->
[phpBB Debug] PHP Notice: in file /includes/functions_autogroup.php on line 232: Missing argument 3 for auto_groups_create(), called in /includes/functions_user.php on line 2508 and defined

Warning: Cannot modify header information - headers already sent by (output started at /home/cetosinf/public_html/forum/includes/functions.php:3506) in /home/cetosinf/public_html/forum/adm/index.php on line 150

Warning: Cannot modify header information - headers already sent by (output started at /home/cetosinf/public_html/forum/includes/functions.php:3506) in /home/cetosinf/public_html/forum/adm/index.php on line 152

Warning: Cannot modify header information - headers already sent by (output started at /home/cetosinf/public_html/forum/includes/functions.php:3506) in /home/cetosinf/public_html/forum/adm/index.php on line 153

Warning: Cannot modify header information - headers already sent by (output started at /home/cetosinf/public_html/forum/includes/functions.php:3506) in /home/cetosinf/public_html/forum/adm/index.php on line 154
Tks for help

User avatar
Hippie459MN
Registered User
Posts: 917
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Auto Groups

Post by Hippie459MN » Sat Dec 05, 2009 9:52 pm

Updated to work with 3.0.6 Hope it works. :D

EDIT: It works!!!! :D Thanks for the update for 3.0.6
Last edited by Hippie459MN on Sat Dec 05, 2009 10:10 pm, edited 1 time in total.

User avatar
hejowicz
Registered User
Posts: 442
Joined: Sun Dec 23, 2007 4:03 pm

Re: Auto Groups

Post by hejowicz » Sat Dec 05, 2009 9:54 pm

Lisbon wrote:
hejowicz wrote:
Lisbon wrote:
hejowicz wrote:How set up auto grups mod ? .. I mean where is this options .. i can't find that :|
Tab "user and groups" -> menage groups -> config gruop
I don't see "config gruop" :?
Image

It only working in Pre-defined groups ? not in User defined groups ?

libuda
Registered User
Posts: 25
Joined: Wed Oct 07, 2009 10:30 am

Re: Auto Groups

Post by libuda » Sun Dec 06, 2009 10:24 am

A_Jelly_Doughnut wrote:Version 1.0.2 has been submitted to the MOD Validation Queue.
The function doesn't recognise posts made by the new Quick Reply function in 3.0.6

User avatar
Hippie459MN
Registered User
Posts: 917
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Auto Groups

Post by Hippie459MN » Sun Dec 06, 2009 2:54 pm

libuda wrote:
A_Jelly_Doughnut wrote:Version 1.0.2 has been submitted to the MOD Validation Queue.
The function doesn't recognise posts made by the new Quick Reply function in 3.0.6
I made a test account and made my required 20 posts using the QR on every post and it worked just fine. :)

libuda
Registered User
Posts: 25
Joined: Wed Oct 07, 2009 10:30 am

Re: Auto Groups

Post by libuda » Sun Dec 06, 2009 5:56 pm

Hippie459MN wrote:
libuda wrote:
A_Jelly_Doughnut wrote:Version 1.0.2 has been submitted to the MOD Validation Queue.
The function doesn't recognise posts made by the new Quick Reply function in 3.0.6
I made a test account and made my required 20 posts using the QR on every post and it worked just fine. :)
Okay, i tested some more. It works, but not instantly after submitting the message.

genius128
Registered User
Posts: 10
Joined: Fri Nov 13, 2009 2:58 pm
Location: España
Contact:

Re: Auto Groups

Post by genius128 » Sun Dec 06, 2009 6:43 pm

richey wrote:Is anyone in contact with the MOD author or knows how to make this work with 3.0.6 ?

function_group_create() (in functions_user.php) is totally different from 3.0.5 .... :shock:


thanks,
r.
I've the same problem, but I haven't found the solution.

Anyone can help me ?
phpBB3 3.06
web: http://www.clubfordmondeo.es and http://www.clubfordmondeo.com
template: Blue-Morph

Locked

Return to “[3.0.x] MOD Database Releases”