Email on Birthday

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
User avatar
Spaldo
Registered User
Posts: 53
Joined: Sun Nov 07, 2004 9:28 pm

Re: Email on Birthday

Post by Spaldo »

I just deleted all the changes and now I still can't get into the ACP!

What did this crazy mod do to my install?
Image
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

if you edit language files, make sure you keep the format as utf8 without BOM.

what file editor do you use?
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
Spaldo
Registered User
Posts: 53
Joined: Sun Nov 07, 2004 9:28 pm

Re: Email on Birthday

Post by Spaldo »

lefty74 wrote:if you edit language files, make sure you keep the format as utf8 without BOM.

what file editor do you use?
windows notepad... it shouldn't change the format?

Any suggestions how I can restore this, I really need the ACP for my forums.
Image
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

sorry to say but windows notepad sucks.

download notepad++

and save as utf8 without BOM.

that should hopefully do the trick
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
Spaldo
Registered User
Posts: 53
Joined: Sun Nov 07, 2004 9:28 pm

Re: Email on Birthday

Post by Spaldo »

lefty74 wrote:sorry to say but windows notepad sucks.

download notepad++

and save as utf8 without BOM.

that should hopefully do the trick
Which file do you think I broke?

Do you have a spare copy in case I can't recover it?
Image
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

/language/en/acp/common.php

i dont think you will need a spare copy but you can take the one from the phpbb3 download file.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
Spaldo
Registered User
Posts: 53
Joined: Sun Nov 07, 2004 9:28 pm

Re: Email on Birthday

Post by Spaldo »

lefty74 wrote:/language/en/acp/common.php

i dont think you will need a spare copy but you can take the one from the phpbb3 download file.
Thanks for the posts... The original file fixed the problem.

I might give it another go another time :)
Image
Tazmanian
Registered User
Posts: 218
Joined: Wed Jan 25, 2006 7:02 pm
Location: Belgium
Contact:

Re: Email on Birthday

Post by Tazmanian »

Since I updated to the latest version I'm experiencing a bug. (maybe it was on the previous version also but then the sending of emails were not logged in the ACP)

For example.
Yesterday it was the birthday of 2 users. The mails were send like it should be.
Today there are no birthdays. However the script ran again and in the ACP I saw that it was send again to the 2 same users as yesterday!
So it seems to me that it is working fine when there is every day a birthday, but not when there is a day without birthdays.
Or is it just a bug in the logging script and not in the sending of emails?
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

hm, will have a look.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

Tazmanian,
you were right, update has been submitted

updated to 1.0.1b. - submitted
bugfix - it was possible that the script was called (again) if a user was on different time settings than the board settings

you can find the submitted update here
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Email on Birthday

Post by DavidIQ »

MOD Updated to version 1.0.1b
See first post for Download Link
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
FooKaa
Registered User
Posts: 57
Joined: Sun Jul 26, 2009 10:23 am
Location: London

Re: Email on Birthday

Post by FooKaa »

Just wanted to say thanks for this mod, something a decent community board should have in the first place really..

1 thing thou when i first completed the install i was getting sql errors..

I discovered that the edit on the index.php
Find

Tip: This may be a partial find and not the whole line.
Code:Select all

$sql = 'SELECT u.user_id, u.username, u.user_colour, u.user_birthday

In-line Find

Tip: This is a partial match of a line for in-line operations.
Code:Select all

u.user_birthday

In-line Add after

Code:Select all

, u.user_email, u.user_lang,u.user_notify_type, u.user_jabber


Were causing the errors.. On my index.php there was no u.user_ it was just user_ << So i changed the added bit and that fixed my problem :D

Thought i would mention this in-case anyone else had this trouble too :D
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: Email on Birthday

Post by lefty74 »

hi, you must be on 3.0.5. because in 3.0.6 that is the correct find ;)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
FooKaa
Registered User
Posts: 57
Joined: Sun Jul 26, 2009 10:23 am
Location: London

Re: Email on Birthday

Post by FooKaa »

Yes i am :D
T-Flash
Registered User
Posts: 2
Joined: Sat Jan 23, 2010 2:41 pm

Re: Email on Birthday

Post by T-Flash »

Hey guys,
after I edited my files and uploaded .txt file.
My board says that after I try to proceed to ACP or join inside mcp panel!

[code}
Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4209

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4211

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4212

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4213

[/code}

Can anyone say or help me with that problem ?
I tried to remove my changes to look if problem will gone.

But same problem.
Dunno what happened.
Havent that problem before I edited the files ... Can anyone say what it means !


Thanks
T-Flash
Locked

Return to “[3.0.x] MOD Database Releases”