Page 15 of 16

Re: Email on Birthday

Posted: Tue Dec 22, 2009 10:39 pm
by Spaldo
I just deleted all the changes and now I still can't get into the ACP!

What did this crazy mod do to my install?

Re: Email on Birthday

Posted: Wed Dec 23, 2009 12:21 am
by lefty74
if you edit language files, make sure you keep the format as utf8 without BOM.

what file editor do you use?

Re: Email on Birthday

Posted: Wed Dec 23, 2009 1:54 am
by Spaldo
lefty74 wrote:if you edit language files, make sure you keep the format as utf8 without BOM.

what file editor do you use?
windows notepad... it shouldn't change the format?

Any suggestions how I can restore this, I really need the ACP for my forums.

Re: Email on Birthday

Posted: Wed Dec 23, 2009 2:56 pm
by lefty74
sorry to say but windows notepad sucks.

download notepad++

and save as utf8 without BOM.

that should hopefully do the trick

Re: Email on Birthday

Posted: Wed Dec 23, 2009 5:40 pm
by Spaldo
lefty74 wrote:sorry to say but windows notepad sucks.

download notepad++

and save as utf8 without BOM.

that should hopefully do the trick
Which file do you think I broke?

Do you have a spare copy in case I can't recover it?

Re: Email on Birthday

Posted: Wed Dec 23, 2009 8:34 pm
by lefty74
/language/en/acp/common.php

i dont think you will need a spare copy but you can take the one from the phpbb3 download file.

Re: Email on Birthday

Posted: Thu Dec 24, 2009 12:02 am
by Spaldo
lefty74 wrote:/language/en/acp/common.php

i dont think you will need a spare copy but you can take the one from the phpbb3 download file.
Thanks for the posts... The original file fixed the problem.

I might give it another go another time :)

Re: Email on Birthday

Posted: Fri Dec 25, 2009 2:34 pm
by Tazmanian
Since I updated to the latest version I'm experiencing a bug. (maybe it was on the previous version also but then the sending of emails were not logged in the ACP)

For example.
Yesterday it was the birthday of 2 users. The mails were send like it should be.
Today there are no birthdays. However the script ran again and in the ACP I saw that it was send again to the 2 same users as yesterday!
So it seems to me that it is working fine when there is every day a birthday, but not when there is a day without birthdays.
Or is it just a bug in the logging script and not in the sending of emails?

Re: Email on Birthday

Posted: Sat Dec 26, 2009 4:09 pm
by lefty74
hm, will have a look.

Re: Email on Birthday

Posted: Sun Dec 27, 2009 11:05 am
by lefty74
Tazmanian,
you were right, update has been submitted

updated to 1.0.1b. - submitted
bugfix - it was possible that the script was called (again) if a user was on different time settings than the board settings

you can find the submitted update here

Email on Birthday

Posted: Thu Dec 31, 2009 1:13 pm
by DavidIQ
MOD Updated to version 1.0.1b
See first post for Download Link

Re: Email on Birthday

Posted: Sat Jan 16, 2010 12:00 pm
by FooKaa
Just wanted to say thanks for this mod, something a decent community board should have in the first place really..

1 thing thou when i first completed the install i was getting sql errors..

I discovered that the edit on the index.php
Find

Tip: This may be a partial find and not the whole line.
Code:Select all

$sql = 'SELECT u.user_id, u.username, u.user_colour, u.user_birthday

In-line Find

Tip: This is a partial match of a line for in-line operations.
Code:Select all

u.user_birthday

In-line Add after

Code:Select all

, u.user_email, u.user_lang,u.user_notify_type, u.user_jabber


Were causing the errors.. On my index.php there was no u.user_ it was just user_ << So i changed the added bit and that fixed my problem :D

Thought i would mention this in-case anyone else had this trouble too :D

Re: Email on Birthday

Posted: Sat Jan 16, 2010 12:35 pm
by lefty74
hi, you must be on 3.0.5. because in 3.0.6 that is the correct find ;)

Re: Email on Birthday

Posted: Sat Jan 16, 2010 2:08 pm
by FooKaa
Yes i am :D

Re: Email on Birthday

Posted: Tue Jan 26, 2010 5:14 pm
by T-Flash
Hey guys,
after I edited my files and uploaded .txt file.
My board says that after I try to proceed to ACP or join inside mcp panel!

[code}
Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4209

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4211

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4212

Warning: Cannot modify header information - headers already sent by (output started at /home/**/public_html/forum/language/en/acp/common.php:1) in /home/**/public_html/forum/includes/functions.php on line 4213

[/code}

Can anyone say or help me with that problem ?
I tried to remove my changes to look if problem will gone.

But same problem.
Dunno what happened.
Havent that problem before I edited the files ... Can anyone say what it means !


Thanks
T-Flash