Quick reply for phpBB3

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
rxu
Extensions Development Team
Posts: 3186
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu »

These entries aren't related to any ACP problems regrettably. Could you check the last log record right after you got the blank page?

Jeroen B
Registered User
Posts: 1222
Joined: Wed Jul 02, 2008 6:23 pm
Location: The Netherlands
Name: Jeroen

Re: Quick reply for phpBB3

Post by Jeroen B »

rxu wrote:These entries aren't related to any ACP problems regrettably. Could you check the last log record right after you got the blank page?
No I'm sorry it's already gone (it only saves the last 300 logs)...
What should I do now?

In the support forum they say it's an MOD related problem..... :(
Jeroen • My modifications

rxu
Extensions Development Team
Posts: 3186
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu »

Actually this MOD doesn't touch any ACP files, it just installs QR ACP module. How did you uninstall it? Did you run uninstall.php script?
Try do enable debug mode in config.php file and look if some error messages will happen when you enter ACP.

User avatar
vellatechie
Registered User
Posts: 185
Joined: Fri Feb 01, 2008 7:33 pm

Re: Quick reply for phpBB3

Post by vellatechie »

rxu wrote: vellatechie wrote:I want to remove the color palette from the quick reply..

viewtopic.php?p=7367275#p7367275
Thanks for this :)


I also have a wap (sort of ;)) theme in my forum as well (using prime multi theme mod). For that i need quick reply to only have a text area and preview and submit button. Can you tell me how to do this??
I guess if i keep diff quick_reply.html file in diff theme itl still work with any error even if quick_reply.html is diffrent

Dondon2d
Registered User
Posts: 7
Joined: Sun Feb 11, 2007 6:29 am

Re: Quick reply for phpBB3

Post by Dondon2d »

Hi, how do I remove 'Re:' made from replies via the Quick Reply Box?

http://www.phpbb.com/kb/article/remove-re-from-replies/

Thanks.

rxu
Extensions Development Team
Posts: 3186
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu »

vellatechie wrote:i need quick reply to only have a text area and preview and submit button. Can you tell me how to do this?
Try to find in includes/quick_reply.php

Code: Select all

      'S_BBCODE_ALLOWED'         => $bbcode_status,
and replace it with the following code

Code: Select all

      'S_BBCODE_ALLOWED'         => false,
Dondon2d wrote:how do I remove 'Re:' made from replies via the Quick Reply Box?
Try to find in includes/quick_reply.php

Code: Select all

	if ($mode == 'reply')
	{
		$subject = ((strpos($main_data['topic_title'], 'Re: ') !== 0) ? 'Re: ' : '') . censor_text($main_data['topic_title']);
	}
and replace it with the following code

Code: Select all

	if ($mode == 'reply')
	{
		$subject = ((strpos($main_data['topic_title'], 'Re: ') !== 0) ? '' : '') . censor_text($main_data['topic_title']);
	}

Wx4PPT
Registered User
Posts: 6
Joined: Fri Jan 25, 2008 12:55 am

Re: Quick reply for phpBB3

Post by Wx4PPT »

all edits made and uploaded
Install.php run and successfull
everything purged
No Quick Reply box
I also get this error when I try to access Quick Reply in the ACP
template->_tpl_load_file(): File ./style/acp_quick_reply.html does not exist or is empty
There was no acp_quick_reply.html in the package that I downloaded from here?

Also adding this mod to black_pearl was challenging.

Any help is appreciated
http://www.xtremehonorbrigade.com/forums

Wx4PPT
Registered User
Posts: 6
Joined: Fri Jan 25, 2008 12:55 am

Re: Quick reply for phpBB3

Post by Wx4PPT »

Ok I got it to show up but
I have NO Quick Reply in the ACP??? I see the link but I when clicked I get a message saying that the file is missing? I didn't find it in the download from this thread??

rxu
Extensions Development Team
Posts: 3186
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu »

Wx4PPT
It looks like you've missed copying of some files. All files for QR to be workable are in the MOD package. Please, check the installation once again in according to the QR MOD installation instruction.

Wx4PPT
Registered User
Posts: 6
Joined: Fri Jan 25, 2008 12:55 am

Re: Quick reply for phpBB3

Post by Wx4PPT »

Fixed... missed the root/admin/style folder...thanks :oops:

W00tbeer1
Registered User
Posts: 30
Joined: Wed Aug 27, 2008 4:33 pm

Re: Quick reply for phpBB3

Post by W00tbeer1 »

I don't get it, I tried everything and it still doesn't work :(
It appears in the ACP but just doesn't show up in the topics.

User avatar
Sunka
Registered User
Posts: 566
Joined: Wed Mar 26, 2008 2:48 pm
Location: Croatia, Zvoneca

Re: Quick reply for phpBB3

Post by Sunka »

Every member which register BEFORE installation of this MOD, MUST enable it in UCP :mrgreen:

Prophet_DNA
Registered User
Posts: 119
Joined: Thu Oct 23, 2008 7:01 pm

Re: Quick reply for phpBB3

Post by Prophet_DNA »

I am getting the following errors...
Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/******/public_html/forums/contrib/install/install.php on line 17

Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/******/public_html/forums/contrib/install/install.php on line 17

Warning: include() [function.include]: Failed opening './common.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/******/public_html/forums/contrib/install/install.php on line 17

Fatal error: Call to a member function session_begin() on a non-object in /home/******/public_html/forums/contrib/install/install.php on line 20
I am at the part where I try to install.php. Please help!

Prophet_DNA
Registered User
Posts: 119
Joined: Thu Oct 23, 2008 7:01 pm

Re: Quick reply for phpBB3

Post by Prophet_DNA »

Prophet_DNA wrote:I am getting the following errors...
Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/******/public_html/forums/contrib/install/install.php on line 17

Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/******/public_html/forums/contrib/install/install.php on line 17

Warning: include() [function.include]: Failed opening './common.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/******/public_html/forums/contrib/install/install.php on line 17

Fatal error: Call to a member function session_begin() on a non-object in /home/******/public_html/forums/contrib/install/install.php on line 20
I am at the part where I try to install.php. Please help!
I am also getting this error in the admin panel but that maybe because I haven't properly installed this mod...
[phpBB Debug] PHP Notice: in file /adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at /language/en/acp/common.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /language/en/acp/common.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /language/en/acp/common.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at /language/en/acp/common.php:1)

rxu
Extensions Development Team
Posts: 3186
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu »

Prophet_DNA wrote:I am getting the following errors...Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/******/public_html/forums/contrib/install/install.php on line 17
Once again: upload install.php to the root of the board and run it.
Prophet_DNA wrote:output started at /language/en/acp/common.php:1
Language files have to be saved in UTF-8 without BOM encoding and there shouldn't be any spaces/lines before the PHP opening tag <?php and after PHP closing tag ?>.

Locked

Return to “[3.0.x] MOD Database Releases”