Page 79 of 140

Re: Quick reply for phpBB3

Posted: Wed Jan 28, 2009 5:18 pm
by spoda-b.com
rxu wrote:
spoda-b.com wrote:Heres the error I get when I click on Quick Reply under Board Config in the ACP.
Maybe wrong includes/acp/acp_quick_reply.php file encoding... what phpBB3 version?
3.0.4. I guess I somehow forgot to upload the correct acp/acp_quick_reply. So this is fixed now.
rxu wrote:
spoda-b.com wrote:Lastly, since when I installed the mod, I only did the changes to the prosilver template... when I go into a thread to ready it... I get this error.
Thhere's nothing to do with template.php, such errors are usually related to mistakes commited in viewtopic_body.html edits. Please, recheck it.
Found what I was looking for and now I have this...

Image

Re: Quick reply for phpBB3

Posted: Thu Jan 29, 2009 4:32 am
by Abominae
have you find any solution rxu?
pleaaaase =)

Re: Quick reply for phpBB3

Posted: Thu Jan 29, 2009 1:35 pm
by rxu
spoda-b.com wrote:Found what I was looking for and now I have this...
I didn't get the point, sorry... :) What does work wrong? Quote link, etc.?
Abominae wrote:have you find any solution rxu?
Not yet, just don't have spare time enough for this at the moment, sorry. I'll try when I'll be able to. :)

Re: Quick reply for phpBB3

Posted: Thu Jan 29, 2009 6:25 pm
by spoda-b.com
rxu wrote:
spoda-b.com wrote:Found what I was looking for and now I have this...
I didn't get the point, sorry... :) What does work wrong? Quote link, etc.?
Abominae wrote:have you find any solution rxu?
Not yet, just don't have spare time enough for this at the moment, sorry. I'll try when I'll be able to. :)
Well the quick reply box was there, however it screwed the entire lay out of my site.

Re: Quick reply for phpBB3

Posted: Thu Jan 29, 2009 9:13 pm
by Abominae
It's OK! thanks a lot rxu.
I'll be waiting cos' I don't have a clue about coding.

Re: Quick reply for phpBB3

Posted: Wed Feb 11, 2009 6:03 pm
by spoda-b.com
I finally got this mod to work w/a couple issues.

Now some of my users complain that with QR enabled, when the viewtopic page loads it automatically jumps to the quick reply box, which is at the bottom of the page. How do I go about fixing that.

I've noticed this... under the username there's a "quote" button (if you will). You can click on both the quote text as well as the username. Clicking on the quote text doesn't do anything... however clicking the username will; in the QR box put that username in bold bbcode... why? how do i fix that?

Image

how do I go about resizing the reply box, I literally want it a 3rd of the size.

Image

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 3:08 am
by spoda-b.com
no clues?

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 2:24 pm
by rxu
spoda-b.com
You can find the answers here ;)

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 4:06 pm
by spoda-b.com
rxu wrote:spoda-b.com
You can find the answers here ;)
79 pages of crap to sift through sweet.

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 4:49 pm
by rxu
spoda-b.com wrote:79 pages of crap to sift through sweet.
Did you find what you need? :)

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 5:18 pm
by spoda-b.com
I went through the first 5 pages and all I found that pertained to me was this

I just noticed that the cursor jumps the page down to quick reply.

Fix for this:
comment this out in editor.js:
textarea.focus();
like //textarea.focus();

however it doesnt help, because there are 5 "textarea.focus();" in the editor.js file. Which one do I change?

I ended up changing them all. Now one member says it happens all the time, another member says it happens like on every other thread he goes to... I dont get it.

Re: Quick reply for phpBB3

Posted: Fri Feb 13, 2009 8:23 pm
by Phant0m``
Hi,

I'm using the patched v1.6.7 version, .. the install didn't complain, but when I attempted to configure the settings in ACP panel, I receive;

General Error
SQL ERROR [ mysql4 ]

Column 'config_value' cannot be null [1048]

SQL

INSERT INTO phpbb3_config (config_name, config_value, is_dynamic) VALUES ('allow_quick_post_options', NULL, 0)

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal_mysql->sql_error()

FILE: includes/functions.php
LINE: 156
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_quick_reply.php
LINE: 136
CALL: set_config()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_quick_reply->main()

FILE: adm/index.php
LINE: 80
CALL: p_master->load_active()


I guess the problematic line 136 seen in acp_quick_reply.php is;
set_config('allow_quick_post_options', $this->new_config['allow_quick_post_options']);
Any ideas on how to correct this?

Re: Quick reply for phpBB3

Posted: Sat Feb 14, 2009 1:07 pm
by rxu
spoda-b.com wrote:I went through the first 5 pages and all I found that pertained to me was this

I just noticed that the cursor jumps the page down to quick reply.

Fix for this:
comment this out in editor.js:
textarea.focus();
like //textarea.focus();

however it doesnt help, because there are 5 "textarea.focus();" in the editor.js file. Which one do I change?

I ended up changing them all. Now one member says it happens all the time, another member says it happens like on every other thread he goes to... I dont get it.
OK. It happens in IE I guess. Try this trick.
About text box resizing: http://www.phpbb.com/community/viewtopi ... 5#p4796045
About quote link and something more: http://www.phpbb.com/community/viewtopi ... 5#p4951895

Re: Quick reply for phpBB3

Posted: Sun Feb 15, 2009 11:13 am
by ashdaw
I would LOVE to add this MOD but as I am VERY new to this I have NO clue what to do :(

I downloaded the file and got the updated install...php and now, WHAT do I do with it? Do I upload the whole zip to my phpBB folder on the server and run the install?

Sorry if I appear a little dumb but I have been spoiled by SMF. :roll:

Re: Quick reply for phpBB3

Posted: Sun Feb 15, 2009 12:15 pm
by rxu
ashdaw wrote:WHAT do I do with it?
Try to read [Tutorial] How to install a MODX modification and some related to MODs installation articles in Knowledge Base.