Page 12 of 140

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 3:36 pm
by wwe9112
This didn't work on my version of ProSilver. I have it installed on my forum and ts not showing up. any ideas why. I went though everything and checked.

Posted: Thu Mar 27, 2008 3:57 pm
by prothought
This mod is great! Thanks!


One question: When I click on the Quote underneath the user's av, it jumps down to the Quick Reply, but I see no quotes. Did I miss something? How is this supposed to work?

Thanks again!

UPDATE: I also notice that when I click on the user name beneath the avatar, that it adds the following into the Quick Reply box at the bottom:

Code: Select all

[b]prothought[/b]

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 4:17 pm
by rxu
prothought wrote:When I click on the Quote underneath the user's av, it jumps down to the Quick Reply, but I see no quotes. Did I miss something? How is this supposed to work?
It quotes a selected text in post. If no text selected, it just jumps to the qr form. Thinking about implement an appropriate popup message in the next versions.
prothought wrote:I also notice that when I click on the user name beneath the avatar, that it adds the following into the Quick Reply box at the bottom:
Yes, this is intended MOD behaviour :)

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 5:27 pm
by wwe9112
OK i forgot to run the install.php thing, i did that and i get this...see the screan shots i need this fixed like...TODAY!

Image
Image
If you can't tell whats wrong, its in another language, and on the page of where you reply, the quick reply is all over the place.

Thanks so much to who ever help me.

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 5:49 pm
by rxu
I guess the first thing happened because you've uploaded the wrong language file to your board. Use MOD package/Olympus_QR/root/language/en/mods/quick_reply.php one.
The secong thing might be regarding to your style modifications. Regrettably, I'm not aware of them :)

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 5:56 pm
by wwe9112
AAA ok i know what i did wrong. I uploaded the wrong files...thanks man lol. Sorry to be a noob.

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 6:15 pm
by wwe9112
WOW this mod rocks, thanks!!! Please keep it up-to-date as phpbb moves it. It's the best looking one I've ever seen. I like it better then the one for VBulletin and I really like that one.

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 6:38 pm
by prothought
rxu wrote:
xxxgamer wrote:I have the same problem! installed this fine on acidtech red theme
xxxgamer wrote:I also did what it said on the first page with the //textarea stuff in editor.js with no success.
perhaps this is up to the style (by the way, did you purge the cache?), I'll try to check it as soon as possible.
Using prosilver and clearing the cache, I've found that this occurs on IE7, but not on FF 2.0.

I'm also concerned that removing the first occurance of "textarea.focus();" from the editor.js may have unwanted side effects.

Re: Quick reply for phpBB3

Posted: Thu Mar 27, 2008 9:08 pm
by shadow_coder
I get this error when i run contrib/install/install.php

Code: Select all

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main() [function.include]: Failed opening './common.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mysite/public_html/contrib/install/install.php on line 17

Fatal error: Call to a member function on a non-object in /home/mysite/public_html/contrib/install/install.php on line 20
I need to upload edited files before runing this file or after that ??

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 2:59 am
by prothought
shadow_coder wrote:I get this error when i run contrib/install/install.php

Code: Select all

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main(./common.php) [function.main]: failed to open stream: No such file or directory in /home/mysite/public_html/contrib/install/install.php on line 17

Warning: main() [function.include]: Failed opening './common.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mysite/public_html/contrib/install/install.php on line 17

Fatal error: Call to a member function on a non-object in /home/mysite/public_html/contrib/install/install.php on line 20
I need to upload edited files before runing this file or after that ??
Make sure that install.php is in your root directory. In your case, it looks like it should be in /home/mysite/public_html.

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 5:34 am
by rxu
shadow_coder wrote:I need to upload edited files before runing this file or after that ??
Just follow the MOD installation instruction. Running of install.php is the last thing you need to do to install QR.
And, as prothought said already, install.php should be uploaded to the board root to run it.

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 9:01 am
by PrattP
rxu wrote:PrattP
Try this:

Code: Select all

OPEN
styles/prosilver/template/viewtopic_body.html

FIND
<!-- IF postrow.RANK_TITLE or postrow.RANK_IMG --><dd>{postrow.RANK_TITLE}<!-- IF QUICK_REPLY --><br /><a href="#postform" onclick="addquote({postrow.POST_ID},'{postrow.POSTER_QUOTE}'); insert_text('\r\n'); return false;" title="{L_QUOTE_TEXT}">{L_QUOTE}</a><!-- ENDIF --><!-- IF postrow.RANK_TITLE and postrow.RANK_IMG --><br /><!-- ENDIF -->{postrow.RANK_IMG}</dd><!-- ENDIF -->

REPLACE WITH
<!-- IF postrow.RANK_TITLE or postrow.RANK_IMG --><dd>{postrow.RANK_TITLE}<!-- IF postrow.RANK_TITLE and postrow.RANK_IMG --><br /><!-- ENDIF -->{postrow.RANK_IMG}<!-- IF QUICK_REPLY --><br /><a href="#postform" onclick="addquote({postrow.POST_ID},'{postrow.POSTER_QUOTE}'); insert_text('\r\n'); return false;" title="{L_QUOTE_TEXT}">{L_QUOTE}</a><!-- ENDIF --></dd><!-- ENDIF -->
For subsilver2 just move

Code: Select all

			<!-- IF QUICK_REPLY -->
				<tr>
					<td class="postdetails"><a href="#postform" onclick="addquote({postrow.POST_ID},'{postrow.POSTER_QUOTE}'); insert_text('\r\n'); return false;" title="{L_QUOTE_TEXT}">{L_QUOTE}</a></td>
				</tr>
			<!-- ENDIF -->
to the place after

Code: Select all

			<!-- IF postrow.RANK_IMG -->
				<tr>
					<td>{postrow.RANK_IMG}</td>
				</tr>
			<!-- ENDIF -->
Worked perfectly. Thanks so so much, rxu. Top mod, top support. I moved to this from Evil Quick Reply, and can I say it is a huge improvement, in all aspects. It's really a credit to you.

Thanks again, and my best for future modding!

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 9:27 am
by shadow_coder
rxu wrote:
shadow_coder wrote:I need to upload edited files before runing this file or after that ??
Just follow the MOD installation instruction. Running of install.php is the last thing you need to do to install QR.
And, as prothought said already, install.php should be uploaded to the board root to run it.
now all works fine , i have runned install.php directly from my forum root , not from forum root/contrib/install/install.php .

so you need to change your first post or your install file , b'coz other members too will have the same problem.
besides that all work fine , just need to follow all steps and u will done with this great & useful MOD .

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 3:46 pm
by ellisz
Should there be any issues if I have Rokbridge RC3 installed? I added the files listed and modified the files listed and then did the install.php and got a few header errors. I don't remember exactly what the were. Seemed to reference /adm/index.php. It could not edit the header file I believe?

My actually phpbb3 files are in joomla/distribution/ per the bridge. My phpbb3 server info has it pointed to joomla/forum/. I had issues with the protos phpbb3 latest topics module as well. It supposedly needed to point to the phpbb3 root directory as well?

Would the bridge cause this issue?

Thanks

Re: Quick reply for phpBB3

Posted: Fri Mar 28, 2008 4:03 pm
by rxu
ellisz wrote:install.php and got a few header errors. I don't remember exactly what the were.
it's importatnt I guess. Please try to get exact error text.