Activity Stats MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
catwalkchaos
Registered User
Posts: 34
Joined: Fri Jan 02, 2009 2:51 am

Re: Activity Stats MOD

Post by catwalkchaos » Sat Jan 03, 2009 8:56 am

Thanks, looks like its working now, still 52 users but the right amount of posts :D i'm surprised i have managed to install 2 mods now :lol:

TEF
Registered User
Posts: 298
Joined: Sat Jul 05, 2008 2:15 pm

Re: Activity Stats MOD

Post by TEF » Mon Jan 05, 2009 10:57 pm

So is there a addon to count guests now ?

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: Activity Stats MOD

Post by Highway of Life » Mon Jan 05, 2009 11:46 pm

TEF wrote:So is there a addon to count guests now ?
No, but see the development topic. ;)
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

User avatar
clava
Registered User
Posts: 23
Joined: Sun Oct 07, 2007 3:25 pm

Re: Activity Stats MOD

Post by clava » Fri Jan 09, 2009 8:02 am

Hello,

I am using this mod since a year now on 2 diferent PHPBB forums, on 2 different hosting.
Unfortunately I must agree with some of posters here: The last 24 hours users are not conform to reality. In fact there are in that list a lot of users that had not login since 3-6 months.

I don't know what are the problems (some cron job does not run?!? , a matter of OR / AND ?!?) but since I am not the only one who has that kind of trouble I consider this a BUG.

Thanks in advance for helping me.
By the way, I have tried the solution above but it was not working.
Highway of Life wrote: The reason any users are showing past 24 hours is due to the session time exceeding 24 hours, this is not normal, but it appears to be the case on all boards that have this issue. That, or their GC (Garbage Collection) is not working, some have the cron disabled, which has caused this.

The solution is to ensure your sessions do not last longer than a few hours, -- the shorter, the better --. Secondly, ensure that {CRON} can run in your footer.
If you cannot do either, or if the problem persists, you can change the OR session_user_id <> ANONYMOUS to be

Code: Select all

OR (s.session_user_id <> ' . ANONYMOUS . ' AND s.session_time > ' . (time() - 86400))

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: Activity Stats MOD

Post by Highway of Life » Fri Jan 09, 2009 7:30 pm

Let me repeat. If there are rows stuck in the sessions table, then you’ll encounter this bug. It’s not a bug specifically with this MOD, but it can certainly be an issue. If garbage collection is not working, that is where the problem is. The only way to find out is to look at the sessions table yourself. If the fix I posted does not work, then you have a different problem than everybody else.
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

TEF
Registered User
Posts: 298
Joined: Sat Jul 05, 2008 2:15 pm

Re: Activity Stats MOD

Post by TEF » Fri Jan 09, 2009 8:43 pm

Highway of Life wrote:
TEF wrote:So is there a addon to count guests now ?
No, but see the development topic. ;)
Thanks

naive
Registered User
Posts: 43
Joined: Sun Apr 15, 2007 3:32 pm

Re: Activity Stats MOD

Post by naive » Sat Jan 10, 2009 3:01 am

DoYouSpeakWak wrote:Hey there

Iwe done the install of this mod many times. But today i encountered a board were the finds in subilver2 xml wern`that logical.

When lookin for this

Code: Select all

<td class="row1" rowspan="{%:1}" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
I got a error in notepad++ didnt exits. But the only thing that came close what this

Code: Select all

<td class="row1" rowspan="2" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
The instructions said 1 increment so i left it at two without "%:" in front of it. And the mod works fine in prosilver and subsilver2. Exept from the form were the usernames are suppose to go. It looks like this.

Image

Any ideas on what is wrong and how i can run this mod without this design flaw ?

DYSW
I have similar conditions.

For prosilver, it is OK.

Image

The screenshot for subsilver2

Image

How can I fix it?
Any help appreciated. :)

momentum
Registered User
Posts: 1505
Joined: Thu Sep 20, 2007 4:07 am
Location: Melbourne, Australia

Re: Activity Stats MOD

Post by momentum » Sat Jan 10, 2009 4:40 am

naive wrote:I have similar conditions.

The screenshot for subsilver2

Image

How can I fix it?
Any help appreciated. :)
In the subsilver2 instructions is this find....

Code: Select all

<td class="row1" rowspan="{%:1}".......
Whatever the "rowspan", Incremiment by one. (add one digit)

Craig.
QOTY: phpBB is free, good hosting is not. - robert (Lumpy Burgertushie)

naive
Registered User
Posts: 43
Joined: Sun Apr 15, 2007 3:32 pm

Re: Activity Stats MOD

Post by naive » Sat Jan 10, 2009 7:02 am

momentum wrote:
naive wrote:I have similar conditions.

The screenshot for subsilver2

Image

How can I fix it?
Any help appreciated. :)
In the subsilver2 instructions is this find....

Code: Select all

<td class="row1" rowspan="{%:1}".......
Whatever the "rowspan", Incremiment by one. (add one digit)

Craig.
Thank you, momentum.

I have increased the rowspan from 2 to 3. :(

Code: Select all

<td class="row1" rowspan="3" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>

User avatar
daGrevis
Registered User
Posts: 146
Joined: Sat Jan 10, 2009 7:41 am
Location: Latvia

Re: Activity Stats MOD

Post by daGrevis » Sat Jan 10, 2009 8:42 am

Thanks, great mod! :) I use it on my board (3.0.4) and all works just fine! :)

User avatar
clava
Registered User
Posts: 23
Joined: Sun Oct 07, 2007 3:25 pm

Re: Activity Stats MOD

Post by clava » Sat Jan 10, 2009 2:40 pm

Highway of Life wrote:Let me repeat. If there are rows stuck in the sessions table, then you’ll encounter this bug. It’s not a bug specifically with this MOD, but it can certainly be an issue. If garbage collection is not working, that is where the problem is. The only way to find out is to look at the sessions table yourself. If the fix I posted does not work, then you have a different problem than everybody else.
I`ve browsed my phpbb_sessions and I have over 470 entries. How can I make the garbage collection work?
Thanks in advance.

net83it
Registered User
Posts: 500
Joined: Sun Jan 15, 2006 2:42 pm
Location: Sicily
Contact:

Re: Activity Stats MOD

Post by net83it » Sat Jan 10, 2009 5:35 pm

according to google cache search engine bots don't see the last 24 hours stats. how to enable these stats also for bots?

User avatar
wang5555
Translator
Posts: 592
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Activity Stats MOD

Post by wang5555 » Sun Jan 11, 2009 4:02 am

naive wrote:Thank you, momentum.

I have increased the rowspan from 2 to 3. :(

Code: Select all

<td class="row1" rowspan="3" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
Because your forum does not display group in legend,
So you must modify it following:
#
#-----[ FIND ]-----
# P.S. this is source code in index_body.html on subsilver2 style.
#

Code: Select all

	<!-- IF LEGEND -->
		<td class="row1" rowspan="2" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ELSE -->
		<td class="row1" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ENDIF -->
#
#-----[ REPLACE WITH ]-----
#

Code: Select all

	<!-- IF LEGEND -->
		<td class="row1" rowspan="3" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ELSE -->
		<td class="row1" rowspan="2" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ENDIF -->
May be this is a bug on subsilver2 style for the mod.
Compare good amend is:
<!-- IF LEGEND -->
rowspan="2" -> rowspan="3"
<!-- ELSE -->
(no this attribute) -> rowspan="2"
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!

User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: Activity Stats MOD

Post by thejdm » Sun Jan 11, 2009 6:04 am

just installed this on the latest version of phpbb3 works great. thanks for this!
www.thejdm.com ...turn it on, y0

naive
Registered User
Posts: 43
Joined: Sun Apr 15, 2007 3:32 pm

Re: Activity Stats MOD

Post by naive » Sun Jan 11, 2009 6:52 am

Thank you wang5555 for helping me out.

I installed this mod according to the instructions. Everything went smoothly on prosilver style.
But on subsilver2, I got this:

Image

I fixed this situation by advice from wang5555.
Admin index -- users and groups -- manage groups -- group wide settings -- display group in legend must be checked for at least one group.

After that, this mod displays correctly.

Image

Locked

Return to “[3.0.x] MOD Database Releases”