Annual Stars for 3.0

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
User avatar
Dan27
I've Been Banned!
Posts: 352
Joined: Mon Apr 06, 2009 1:07 pm
Location: United Kingdom
Contact:

Re: Annual Stars for 3.0

Post by Dan27 »

Hi Evil, I have put on your MOD and I have changed it to '2628000' which I believe is one star
per month, however, I have made all the edits but the stars have not showed up, what's gone wrong?
Dan - Registered user.
Click here to visit my forum.
Khamosh-Saya
Registered User
Posts: 871
Joined: Fri Nov 23, 2007 6:46 am
Location: UAE
Name: Jamshed Ansari
Contact:

Re: Annual Stars for 3.0

Post by Khamosh-Saya »

nothing showing

purge the cache and refresh the template
iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Annual Stars for 3.0

Post by iftitaj »

evil<3! I've a strange problem NOW. I'm saying now because it was working properly before, 3/4 months back.

Now the problem is that its showing only one star in viewtopic page while showing properly all stars in memberlist page.

Scenario: I've set it to one star for every month of membership. And I was registered on the forum in the March last year. So its around 15 months.

Its showing 15 stars in memberlist page but only one star in viewtopic page. As far as I remember, it happened after a year of my registration. I also wanna tell you that I'm owner of forum so the registration of mine is the start date of the forum. If thats of any relevance.

Also its happening to all users on my forum, not only with me.

Is it something with "not-enough-space" to show these many stars on viewtopic page? Why its only happening on viewtopic page when its working fine on memberlist page?
lovelysummer
Registered User
Posts: 437
Joined: Fri Mar 20, 2009 1:49 pm

Re: Annual Stars for 3.0

Post by lovelysummer »

dethis wrote:Hi. I would like to kown if its possible to use this mod to work with User Online Time getting the user online time variable, and replacing it for 'user_regdate' used on mod and use it to give stars ? :roll:
if ($reg_years = (int) ((time() - (int) $row['user_regdate']) / 31536000))
Thks in advance.
I like this mod , but dethis or anyone else had tried to use the Online Time to award the star. Please share your coding.

Tks.
iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Annual Stars for 3.0

Post by iftitaj »

iftitaj wrote:evil<3! I've a strange problem NOW. I'm saying now because it was working properly before, 3/4 months back.

Now the problem is that its showing only one star in viewtopic page while showing properly all stars in memberlist page.

Scenario: I've set it to one star for every month of membership. And I was registered on the forum in the March last year. So its around 15 months.

Its showing 15 stars in memberlist page but only one star in viewtopic page. As far as I remember, it happened after a year of my registration. I also wanna tell you that I'm owner of forum so the registration of mine is the start date of the forum. If thats of any relevance.

Also its happening to all users on my forum, not only with me.

Is it something with "not-enough-space" to show these many stars on viewtopic page? Why its only happening on viewtopic page when its working fine on memberlist page?
Bumping my problem. :(
iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Annual Stars for 3.0

Post by iftitaj »

Seems like the developer is no more supporting this MOD. :cry:
User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Annual Stars for 3.0

Post by igorw »

It's kind of strange, I've never had any problems with exactly the same code. :?
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three
User avatar
dethis
Registered User
Posts: 34
Joined: Fri Oct 17, 2008 8:14 pm
Location: Lisboa, Portugal

Re: Annual Stars for 3.0

Post by dethis »

lovelysummer wrote:I like this mod , but dethis or anyone else had tried to use the Online Time to award the star. Please share your coding.
Tks.
Sorry, but i didnt get that working either.
User avatar
noth
Registered User
Posts: 2487
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Annual Stars for 3.0

Post by noth »

I love this mod 8-)

one really superb element of the mod is, that if you have various STYLES available to your members

..... you can use different "graphics" for the actual 'annual stars' depending on the style, which is great :D
iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Annual Stars for 3.0

Post by iftitaj »

eviL<3 wrote:It's kind of strange, I've never had any problems with exactly the same code. :?
May I give you temporary Admin account & FTP account so will you please look at my problem? :|
User avatar
rstynls9
Registered User
Posts: 21
Joined: Thu Sep 25, 2008 3:51 pm

Re: Annual Stars for 3.0

Post by rstynls9 »

noth wrote:thanks whoisit :mrgreen: but TerraFrost has coded a working solution in viewtopic.php

so .... to STOP annual stars for members who have not visited in 1 year or more do TerraFrost's code

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
         // annual stars
         $user_cache[$poster_id]['reg_stars'] = '';
         if ($reg_years = (int) ((time() - (int) $row['user_regdate']) / 31536000))
         {
            $user_cache[$poster_id]['reg_stars'] = str_repeat($user->img('icon_annual_star', 'YEARS_OF_MEMBERSHIP'), $reg_years);
         }
#
#-----[ REPLACE WITH ]----------------------------------
#
         // annual stars
         $user_cache[$poster_id]['reg_stars'] = '';
         if ($reg_years = (int) (((int) $row['user_lastvisit'] - (int) $row['user_regdate']) / 31536000))
         {
            $user_cache[$poster_id]['reg_stars'] = str_repeat($user->img('icon_annual_star', 'YEARS_OF_MEMBERSHIP'), $reg_years);
         }
he has enstalled this on my board (the above change) and it works great :D

thank you TerraFrost!!
I have tried this and it does not work for me. It just eliminates the stars from showing up on everyone's profile, even those who are active within the last 24 hours. What might be the problem?
Mircea007
Registered User
Posts: 74
Joined: Mon Jun 15, 2009 9:24 pm

Re: Annual Stars for 3.0

Post by Mircea007 »

anyone tried it on 3.0.5
Flash Games like you never seen before
momentum
Registered User
Posts: 1505
Joined: Thu Sep 20, 2007 4:07 am
Location: Melbourne, Australia

Re: Annual Stars for 3.0

Post by momentum »

Mircea007 wrote:anyone tried it on 3.0.5
Yup!

Craig.
QOTY: phpBB is free, good hosting is not. - robert (Lumpy Burgertushie)
User avatar
kam009
Registered User
Posts: 76
Joined: Wed Dec 19, 2007 3:37 am

Re: Annual Stars for 3.0

Post by kam009 »

I tried it on 3.0.5 and the star doesn't show up on the topic view... it does show up in member's profile view.


Please someone help..!
User avatar
kam009
Registered User
Posts: 76
Joined: Wed Dec 19, 2007 3:37 am

Re: Annual Stars for 3.0

Post by kam009 »

Can someone please help... someone who has got it working in 3.0.5... I know php so i promise i won't act stupid! :P
Locked

Return to “[3.0.x] MOD Database Releases”