ACP Announcement Centre

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: ACP Announcement Centre

Post by lefty74 » Sat Mar 27, 2010 10:22 pm

Hardcore_Shad wrote:Thanks Lefty for a great great mod! I installed this successfully on a 3.0.7 PL1.
thanks :)
Pit$Bull wrote:I've noticed a minor issue after installing AC via automod.
AC installs with no errors and works great with one exception that I can find (so far), AC seems to be causing issues for the 'style inheritance' that is used by Prosilver_se.
When sending a PM to myself no issues, but when sending a PM to another user I get this error.
Fatal error: The file ./styles/prosilver_se/template/bbcode.html is missing. in C:\phpBB\xampp\htdocs\PSA\includes\bbcode.php on line 150
This affects live and local installs. I can clear this error by adding the Prosilver bbcode.html file to the Prosilver_se template but it is not suppose to be there.
3.0.5 updated to 3.0.7-PL1 using complete file replacement. MODs=automod and announcement center.
Looks like I'm not the only user that has experienced this issue. See Bug Tracker
Just thought you would like to know.
thanks, i use prosilver_se on my own board. I have announcement centre installed (but not automod) and have no issues sending pm's to any user. Will take a look though.
is no good wrote:Hi i updated my forum to 3.07 and the mod disappeared somehow, i haven't deleted any part or something, its there in the acp but its not viewable on the board.
Any help?
pse doublecheck that the mod edits are still place, i would start with the overall_header.html file.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
daveht
Registered User
Posts: 195
Joined: Mon Jan 05, 2009 9:57 pm
Location: NH USA
Contact:

Re: ACP Announcement Centre

Post by daveht » Sun Mar 28, 2010 4:41 am

is no good wrote:Hi i updated my forum to 3.07 and the mod disappeared somehow, i haven't deleted any part or something, its there in the acp but its not viewable on the board.
Any help?
Clear your cache in the acp main screen and your browser cache.

Dave

Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: ACP Announcement Centre

Post by Pit$Bull » Sun Mar 28, 2010 11:28 am

lefty74 wrote:I have announcement centre installed (but not automod) and have no issues sending pm's to any user.
Sorry, I didn't mention that all PM's send correctly. I just get the error message.

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: ACP Announcement Centre

Post by modernist » Tue Mar 30, 2010 12:08 am

Hello!

I hope this hasn't been answered before, but I really haven't found an answer using the search function for this thread.

Is it possible to make the image of the avatar clickable so that it links to the profile just like {bdannounce.ANNOUNCEMENT_USERNAME} does? Actually I just need what to put in for the href:

<a href="?">{bdannounce.ANNOUNCEMENT_AVATAR}</a>

Any ideas?
"It ain't a fit night out for man or beast."

Frank Hatfull
Registered User
Posts: 25
Joined: Fri Jun 12, 2009 10:54 am

Re: ACP Announcement Centre

Post by Frank Hatfull » Tue Mar 30, 2010 2:13 pm

Since upgrading to 3.0.7 & intalling the ACP anouncement MOD the new user registration Code Image screen has dissapeared.

Any ideas?

many thanks

Frank
Frank Hatfull

Frank Hatfull
Registered User
Posts: 25
Joined: Fri Jun 12, 2009 10:54 am

Re: ACP Announcement Centre

Post by Frank Hatfull » Tue Mar 30, 2010 2:40 pm

Since upgrading to 3.0.7 & intalling the ACP anouncement MOD the new user registration Code Image screen has dissapeared.

Any ideas?

many thanks

Frank
Last edited by Frank Hatfull on Fri Apr 02, 2010 5:12 am, edited 1 time in total.
Frank Hatfull

wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: ACP Announcement Centre

Post by wolfman24 » Tue Mar 30, 2010 2:59 pm

This has nothing to do with this mod, you need to update your style to 3.0.7 too.

Frank Hatfull
Registered User
Posts: 25
Joined: Fri Jun 12, 2009 10:54 am

Re: ACP Announcement Centre

Post by Frank Hatfull » Tue Mar 30, 2010 3:21 pm

Could it be something I did in the code mods?

thanks Frank
Frank Hatfull

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: ACP Announcement Centre

Post by lefty74 » Tue Mar 30, 2010 8:30 pm

Pit$Bull wrote:
lefty74 wrote:I have announcement centre installed (but not automod) and have no issues sending pm's to any user.
Sorry, I didn't mention that all PM's send correctly. I just get the error message.
Hi, just wanted to let you know that on a fresh local install I am getting the same error.
On my upgraded up to date board I don't.
So far, I believe my mod discovered this as an issue rather than causing it if you know what i mean.
Will see if I can get to the bottom of it...
modernist wrote:Hello!

I hope this hasn't been answered before, but I really haven't found an answer using the search function for this thread.

Is it possible to make the image of the avatar clickable so that it links to the profile just like {bdannounce.ANNOUNCEMENT_USERNAME} does? Actually I just need what to put in for the href:

<a href="?">{bdannounce.ANNOUNCEMENT_AVATAR}</a>

Any ideas?
in includes/functions_announcements.php
find

Code: Select all

			'ANNOUNCEMENT_AVATAR'	=> ($row['user_avatar']) ? get_user_avatar($row['user_avatar'], $row['user_avatar_type'], $bdavatar_width, $bdavatar_height, $row['username']) : '<img src="' . $phpbb_root_path . 'styles/' . $user->theme['imageset_path'] . '/theme/images/no_avatar.gif" height="' . $config['announcement_ava_max_size'] . '" width="' . $config['announcement_ava_max_size'] . '" title="" alt=""  />',
replace with

Code: Select all

			'ANNOUNCEMENT_AVATAR'	=> ($row['user_avatar']) ? '<a href="' . get_username_string('profile', $row['user_id'], $row['username'], $row['user_colour']) . '">' . get_user_avatar($row['user_avatar'], $row['user_avatar_type'], $bdavatar_width, $bdavatar_height, $row['username']) .'</a>' : '<a href="' . get_username_string('profile', $row['user_id'], $row['username'], $row['user_colour']) . '"><img src="' . $phpbb_root_path . 'styles/' . $user->theme['imageset_path'] . '/theme/images/no_avatar.gif" height="' . $config['announcement_ava_max_size'] . '" width="' . $config['announcement_ava_max_size'] . '" title="" alt=""  /></a>',
Frank Hatfull wrote:Could it be something I did in the code mods?
thanks Frank
i dont know, easiest to check is to uninstall the announcement centre and see if you still have the problem.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: ACP Announcement Centre

Post by lefty74 » Tue Mar 30, 2010 10:22 pm

Pit$Bull wrote:I've noticed a minor issue after installing AC via automod.
AC installs with no errors and works great with one exception that I can find (so far), AC seems to be causing issues for the 'style inheritance' that is used by Prosilver_se.
When sending a PM to myself no issues, but when sending a PM to another user I get this error.
Fatal error: The file ./styles/prosilver_se/template/bbcode.html is missing. in C:\phpBB\xampp\htdocs\PSA\includes\bbcode.php on line 150
This affects live and local installs. I can clear this error by adding the Prosilver bbcode.html file to the Prosilver_se template but it is not suppose to be there.
3.0.5 updated to 3.0.7-PL1 using complete file replacement. MODs=automod and announcement center.
Looks like I'm not the only user that has experienced this issue. See Bug Tracker
Just thought you would like to know.
hi, phpbb seems to drop the $user->theme['template_inherits_id']; value when sending a pm to another user.
how and why i dont know. since i cant reply on the bug tracker, i post it here. :P
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: ACP Announcement Centre

Post by modernist » Wed Mar 31, 2010 11:56 am

Hi Lefty74!

Thank you very much for the code for linking the avatar. It works fine.

I changed the announcement_centre.html for prosilver quite a bit to replace the table(s) with divs and to have the avatars/usernames in one row in case more than one person has his birthday. If you like I can send you the changed files/edits I made, so you maybe could include it as alternative for an update.
"It ain't a fit night out for man or beast."

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: ACP Announcement Centre

Post by lefty74 » Wed Mar 31, 2010 5:33 pm

multiple birthdays should work fine as is to be honest.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: ACP Announcement Centre

Post by wolfman24 » Wed Mar 31, 2010 10:02 pm

Yes, they do. No need for this code ;)

runesword1987
Registered User
Posts: 7
Joined: Fri Apr 02, 2010 4:32 am

Re: ACP Announcement Centre

Post by runesword1987 » Fri Apr 02, 2010 4:39 am

I'm running phpBB 3.0.6 and AC is the first mod I've installed. I can add the module in the ACP but it doesn't show up after I add it to one of the existing tabs. I've cleared the phpBB cache and my browser cache but still nothing. I've made sure that it is enabled. I'm not sure if I'm just missing a setting or a particular configuration somewhere. I created a new category 'module' for mods.

Any help is appreciated.

runesword1987

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: ACP Announcement Centre

Post by lefty74 » Fri Apr 02, 2010 8:48 am

did you run the install/index.php file?

you should have a category called .MODs. That is where the install script sets up the modules.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

Locked

Return to “[3.0.x] MOD Database Releases”