Page 3 of 7

Re: [RC] Support of SQLite 3.0+

Posted: Sun Sep 12, 2010 2:30 pm
by Sierron
Boris Berdichevski wrote:Ok. I mean if you need attach files, you can to do on Private message only.
I mean, I'll trying it again and then posting here if it work. If not, I'll send you the files per PM.
Boris Berdichevski wrote:So. If you use non-English installation, you need in addition translation changes into language/<your-lang-code>/install.php
I've done that. ^^ I also translated the things.

Re: [RC] Support of SQLite 3.0+

Posted: Sun Sep 12, 2010 5:54 pm
by Meis2M
can i use this for phpBB 3.0.7 ?

Re: [RC] Support of SQLite 3.0+

Posted: Sun Sep 12, 2010 6:03 pm
by Sierron
Meis2M wrote:can i use this for phpBB 3.0.7 ?
I'm trying this with 3.0.7. You need just to try it.

Re: [RC] Support of SQLite 3.0+

Posted: Sun Sep 12, 2010 8:19 pm
by Boris Berdichevski
Meis2M wrote:can i use this for phpBB 3.0.7 ?
3.0.7-PL1 only.

Re: [RC] Support of SQLite 3.0+

Posted: Sun Sep 12, 2010 8:25 pm
by Erik Frèrejean
Boris Berdichevski wrote:
Meis2M wrote:can i use this for phpBB 3.0.7 ?
3.0.7-PL1 only.
If it works on 3.0.7-PL1 it works on 3.0.7, as the only change between those two was the fix of a security issue within the feeds.

Re: [RC] Support of SQLite 3.0+

Posted: Tue Oct 05, 2010 2:18 pm
by Boris Berdichevski
Sierron,
did you success final with the MOD?

Re: [RC] Support of SQLite 3.0+

Posted: Wed Oct 06, 2010 6:00 am
by Sierron
Did all the changes again. Got a white page while installing. It is asking me in the installation after I add "Datenbaseserver-Hostname or DSN:" PATH/test.sqlite3 to choose a name for my database. But that wasn't needed in sqlite and also not needed in sqlite3. Something is missing in install_mod.xml

I think you have missed that one for not checking the dbname also.

In functions_install.php

Code: Select all

	// Check that we actually have a database name before going any further.....
	if ($dbms_details['DRIVER'] != 'sqlite' && $dbms_details['DRIVER'] != 'oracle' && $dbname === '')
	{
		$error[] = $lang['INST_ERR_DB_NO_NAME'];
		return false;
	}

Re: [RC] Support of SQLite 3.0+

Posted: Sun Oct 17, 2010 6:44 pm
by Boris Berdichevski
Hi!

Deleted -- BB

Re: [RC] Support of SQLite 3.0+

Posted: Sun Oct 17, 2010 6:59 pm
by Sierron
I already had changed it to sqlite_3 and nowto sqlite3, but that didn't change much. It still throws me out, that the database is missing. If i add a database name and hit next, I get a white page.

Re: [RC] Support of SQLite 3.0+

Posted: Sun Oct 17, 2010 9:06 pm
by Boris Berdichevski
Yes, I mean sqlite_3.
Question:
Do you have php with installed sqlite 3.0, and without sqlite (2.0)?

Re: [RC] Support of SQLite 3.0+

Posted: Sun Oct 17, 2010 9:26 pm
by Boris Berdichevski
Here is an example of answers:

Database configuration
Database type: SQLite 3.0
Database server hostname or DSN: c:/Inetpub/TestDB/testDB.db
DSN stands for Data Source Name and is relevant only for ODBC installs.
Database server port:
Leave this blank unless you know the server operates on a non-standard port.
Database name: testDB.db
Database username:
Database password:
Prefix for tables in database: phpbb_

And All is ok.

Re: [RC] Support of SQLite 3.0+

Posted: Mon Oct 18, 2010 9:59 am
by Sierron
Database configuration
Database type: SQLite 3.0
Database server hostname or DSN: D:/www/www/test.sqlite3
DSN stands for Data Source Name and is relevant only for ODBC installs.
Database server port:
Leave this blank unless you know the server operates on a non-standard port.
Database name: test.sqlite3
Database username:
Database password:
Prefix for tables in database: phpbb_

And I got a white page. I still think something is missing. I'll try to exclude sqlite(2) from php start, but why shouldn't this change something?

Re: [RC] Support of SQLite 3.0+

Posted: Mon Oct 18, 2010 4:06 pm
by Boris Berdichevski
Ok, which Operation System on Web Server?
Version of PHP? Which php_sqlite3.dll do you use? From me or another one?
* I asked about sqlite 2.0 to know if without sqlite 2.0 there are any problem. In my system sqlite 2.0 + sqlite 3.0, and all's Ok.

Re: [RC] Support of SQLite 3.0+

Posted: Mon Oct 18, 2010 4:09 pm
by Boris Berdichevski
In all, I want to know, if you have properly works sqlite3.0 on PHP...

Re: [RC] Support of SQLite 3.0+

Posted: Mon Oct 18, 2010 4:43 pm
by Sierron
I'm using Xampp. That's an development environment which is prepacked with

PHP Version 5.3.1
Apache/2.2.14

PDO support enabled
PDO drivers mysql, sqlite, sqlite2

PDO Driver for SQLite 3.x enabled
SQLite Library 3.6.20

SQLite support enabled
PECL Module version 2.0-dev $Id: sqlite.c 289598 2009-10-12 22:37:52Z pajoye $
SQLite Library 2.8.17
SQLite Encoding iso8859

SQLite3 support enabled
SQLite3 module version 0.7-dev
SQLite Library 3.6.20

I'm using Windows XP SP3. The sqlite3 driver files are comes with the xampp package. I think they are special builds for xampp, but i'm not sure through.

I would test it on my webspace online, but my hoster doesn't support SQLite3 so far.

edit:

I checked my dll and they are bigger than your ones. Both the exe file and the dll have over 1 mb.