Page 6 of 7

[RC] Support of SQLite 3.0+

Posted: Tue Aug 02, 2011 8:50 pm
by Boris Berdichevski
Sorry, MOD was corrupted. Please download it again!

Re: [RC] Support of SQLite 3.0+

Posted: Thu Dec 29, 2011 9:03 pm
by Boris Berdichevski
Fixed BUG: SQLite queries fail many times with error: DB locked.
If you installed the MOD already, please replace file includes/db/sqlite_3.php from directory root.

Re: [RC] Support of SQLite 3.0+

Posted: Sun Jan 08, 2012 8:49 pm
by Boris Berdichevski
Please use correction packet to upgrade from 3.0.9 to 3.0.10: SQLite3.0_MOD_update_to_310.zip
You must replace some files into standard upgrade packet before use it.

Re: [RC] Support of SQLite 3.0+

Posted: Tue Aug 21, 2012 2:40 pm
by Lspreee
Hello,
honestly although you did a great job implementing sqlite3 to phpBB it is hard to follow all the find -> paste steps in your manual. I found after like 30 - 40 changes the further strings unavailable in the given files (e.g. "install/database_update.php" there is no string like 'sqlite' => array( ... ). Seems that the version the manual was made for is 3.0.8 or so.

What if I start from version 3.0.10 at all. You only provided "updates" from 3.0.9 to 3.0.10. Isn't there a complete version with already changed php files?

Thanks for your work anyways.

Re: [RC] Support of SQLite 3.0+

Posted: Thu Sep 06, 2012 9:04 pm
by Boris Berdichevski
Sorry, it's written 'SQLite3.0_MOD_5.3.x_for_309'; need take 3.0.9 -> set MOD -> upgrade to 3.0.10.
But it isn't actually, I must prepare MOD for 3.0.11...

Re: [RC] Support of SQLite 3.0+

Posted: Mon Sep 24, 2012 11:19 pm
by Boris Berdichevski
Yes, added update to 3.0.11:
SQLite3.0_MOD_update_to_311.zip

Re: [RC] Support of SQLite 3.0+

Posted: Sun Nov 04, 2012 9:08 pm
by Boris Berdichevski
If somebody don't know, my MOD will be included into Ascraeus 3.1.

Re: [RC] Support of SQLite 3.0+

Posted: Thu Mar 28, 2013 8:09 am
by Massimiliano Mancini
Starting from excellent Boris' work, I hacked the 3.0.11 in order to have an installable version of phpbb 3.0.11 with SQLite 3.0+ support.

Some other changes are done, in particular on data type that are now the SQLite3 native (INTEGER, TEXT, REAL, BLOB and nothing else)

Please consider this work as ALHPA RELEASE and so any comment is apprecieted.

The testing environment is:

PHP 5.4.13
OS WIndows 7 Professional

Here is the link to the download
http://dl.dropbox.com/u/22594893/phpbb_ ... qlite3.zip

MD5 6a6a0cf592712a1b8846a1631f13b66d

Re: [RC] Support of SQLite 3.0+

Posted: Mon Apr 01, 2013 10:20 pm
by Boris Berdichevski
Massimiliano Mancini,
in includes\db\db_tools.php missing some

Code: Select all

case 'sqlite_3':

Re: [RC] Support of SQLite 3.0+

Posted: Tue Apr 02, 2013 7:36 am
by Massimiliano Mancini
Boris Berdichevski wrote:Massimiliano Mancini,
in includes\db\db_tools.php missing some

Code: Select all

case 'sqlite_3':
where?

Re: [RC] Support of SQLite 3.0+

Posted: Fri Apr 05, 2013 3:26 pm
by Boris Berdichevski
Please download properly latest file from link Update to 3.0.11 -- see my started post!
(Take from zip: install\update\new\includes\db\db_tools.php)

Re: [RC] Support of SQLite 3.0+

Posted: Fri Apr 05, 2013 8:23 pm
by Massimiliano Mancini
Updated with correct file coming from last update of Boris.
Please download from same link.

Re: [RC] Support of SQLite 3.0+

Posted: Fri Oct 04, 2013 12:23 pm
by Boris Berdichevski
Update to 3.0.12:
Use phpBB-3.0.11_to_3.0.12-SQLite3.zip instead phpBB-3.0.11_to_3.0.12.zip

Re: [RC] Support of SQLite 3.0+

Posted: Mon Mar 03, 2014 8:14 am
by pfarber
Can you clarify the instructions for a new installation of phpbb3?

sqlite3 is working on my system, php sees it :

Array ( [versionString] => 3.7.7.1 [versionNumber] => 3007007 ) ?>

So I try and install php-3.0.11 yet the install does not show SQLite as available.

I then copy over the install/ and docs/ directory from phpbb-3.0.11_to_3.0.12-SQlite3 and rerun the install and it still shows SQLite as unavailable.

Can you please give better installation instructions??

Re: [RC] Support of SQLite 3.0+

Posted: Wed Apr 23, 2014 1:38 pm
by Boris Berdichevski
You need this MOD for phpBB 3.0.12.
I'll try to prepare this...
You used package for upgrade phpBB 3.0.11 -> 3.0.12 while package 3.0.11 includes MOD already!