[DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
Locked
User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Fri Nov 28, 2008 6:16 pm

Odd....

Ok, if I click on the 'thank post' button, I get:

Code: Select all

SQL ERROR [ mysql4 ]

Unknown column 'user_thanks_post' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_thanked = user_thanked + 1, user_thanks_post = user_thanks_post + 1 WHERE user_id = 118

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: thanks.php
LINE: 90
CALL: dbal_mysql->sql_query()
But if I cut and paste the SQL statement and put it into phpMyAdmin it works fine........

NguyTieuNhan
Registered User
Posts: 96
Joined: Fri Nov 21, 2008 12:31 am

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by NguyTieuNhan » Sun Nov 30, 2008 7:23 am


User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Sun Nov 30, 2008 4:22 pm

Anyone have any ideas on the SQL issue??? Why it works if I run it manually, but won't work if the MOD uses it??

User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by 1234homie » Sun Nov 30, 2008 5:07 pm

I have suggest to add "who thanked?" in profiles, I think it great idea

User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Sun Nov 30, 2008 5:50 pm

1234homie wrote:I have suggest to add "who thanked?" in profiles, I think it great idea
Eh..... :roll:

User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by 1234homie » Sun Nov 30, 2008 5:57 pm

wingnut144 you update your database? just add a sql to your database

btw. I thinks my suggest is very great future for this mod

User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Sun Nov 30, 2008 6:02 pm

Yes, the database has been modified

User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Sun Nov 30, 2008 7:23 pm

Is anyone using this on phpBB 3.0.3???

wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wolfman24 » Sun Nov 30, 2008 10:34 pm

Yes I am and what you are saying can't be ture. You're either using different databases or the outcome of the SQLs have to be the same. NO other solution to this.

User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Sun Nov 30, 2008 10:39 pm

Sorry, you don't know enough about this situation to be helpful. It CAN be true, and is true.

I'm not using different databases. So there must be another solution for this.....
wolfman24 wrote:Yes I am and what you are saying can't be ture. You're either using different databases or the outcome of the SQLs have to be the same. NO other solution to this.

wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wolfman24 » Mon Dec 01, 2008 10:02 am

Then give me any reason, why any SQL statement should work in one way but not on another way with the same database? This cannot be, or the statements are not the same. Maybe a semicolon is missing or something else.

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by danswano » Mon Dec 01, 2008 12:49 pm

I have a problem help me please, the thanks block is very wide, when i was using the old thank mod it was normal and fitting the text, how i will reduce it ?

Image

User avatar
wingnut144
Registered User
Posts: 595
Joined: Thu Jan 20, 2005 4:52 pm
Location: Boise, ID
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by wingnut144 » Mon Dec 01, 2008 1:53 pm

wolfman24 wrote:Then give me any reason, why any SQL statement should work in one way but not on another way with the same database? This cannot be, or the statements are not the same. Maybe a semicolon is missing or something else.
I wish I knew the reason. If you have the modified files for ProSilver and would like to send them to me, please let me know and I'll send you a email address.

You can see what happens when I upload the modified files to the server, where I'm having an issue, at www.salleboise.com/forums2

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by danswano » Mon Dec 01, 2008 2:11 pm

I Told you that the problem of the hide mode problem is from your mod, you said itr's from the hide mode

see what is happening

after thanking the button take you to
viewtopic.php?p=*post number*

phpbb forum view show this link when you want to enter the topic
viewtopic.php?f=*forumnumber*&t=*topicnumber*

when i enter the topic using this viewtopic.php?p=*post number* i see the hidden code after thanking

when i enter the topic using this code viewtopic.php?f=*forumnumber*&t=*topicnumber* i see it hidden

so the thank mod refering to post number not the topic number
i can see the hidden code only in this mode viewtopic.php?p=*post number*
videwtopic.php > post (not topic) number

Heeeeeeeeeeeeeeeeeelp me please!!!!!!!!!!!

I think we need to insert in the db somthing called topic_thanked and putting a new rule in viewtopic for topic_thanked

User avatar
zenrei
Registered User
Posts: 172
Joined: Fri Oct 06, 2006 1:34 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by zenrei » Mon Dec 01, 2008 9:37 pm

wingnut, do you have both of your forum installs pointing to the same db?

check both of your config.php's to make sure... they should match if you are

Locked

Return to “[3.0.x] MODs in Development”