Page 23 of 51

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Sun Dec 21, 2008 5:53 pm
by Madmax77
System: phpBB 3.0.4, Thank Post Mod 0.2.0

hi all,

i had no problems installing the MOD and purged all cache related items. But after the installation i can't find the option to activate the Mod in the Admin Panel. It is not listed in the ".MOD" section and User can't use the THANKS function either (there is no button).

i tried different styles (subsilver2 and prosilver) and different languages but it didn't help.
any idea?

thanks a lot,
mm

Image

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Sun Dec 21, 2008 9:51 pm
by Madmax77
Solution:
:arrow: http://www.phpbb.com/community/viewtopi ... 5#p6787025

But now i do have another problem. One user of my board can thank his own postings. I suppose it is because his long user name. His name is very long and has a space between two words (eg "quitealong nameforthisboard").

any idea how to solve this problem?

thanks for this great mod, best regards, mm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Tue Dec 23, 2008 9:53 pm
by AllCity
Image
BUGS!
I can thank himself and I have not worked very much a button and does not show how much.
Although the section thanks to accept it.
phpBB 3.0.4 without mods!

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Wed Dec 24, 2008 11:46 am
by AllCity
lukasch007 wrote:Hi, i've found a terrible problem after installation this mod.

My template or css crashed. I checked 3 times all files and everything is same as could be.
Look at this.
Image
Any idea?
Refresh prosilver tample!
in acp (style)

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Wed Dec 24, 2008 5:24 pm
by lukasch007
AllCity: I did, but no effect.

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Thu Dec 25, 2008 11:58 am
by AllCity
I, too, so I was just refresh theme, template, imageset and all its ok for me.

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Sun Dec 28, 2008 4:11 pm
by DownMaker
Nice release keep it up...i test it and works good on phpbb 3.0.4 (Prosilver style)

but i am using the "black_pearl" templates and the template have not the "buttons.css" and the "colours.css"
so i searched all file to find something like the same but nothing found...wihtout these files my buttons
are on top of the site lol and after clicking on a other place.

Can some tell me how to do the last step with the "buttons.css and "colours.css" on the Black Pearl Template?

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Mon Dec 29, 2008 12:47 am
by lumiz
I have this problem when they thank my forum see this error:
Error General
SQL ERROR [ mysqli ]

Unknown column 'user_thanked' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_thanked = user_thanked + 1, user_thanks_post = user_thanks_post + 1 WHERE user_id = 230

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: thanks.php
LINE: 90
CALL: dbal_mysqli->sql_query()

And the tables user_thanked, user_thanks, user_thanks_post

I do not think the aber implemented after consulting the install.xml and sql file db_update.php ...

What: S

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Mon Dec 29, 2008 6:19 am
by DownMaker
ok i solved my problem alone ;)
i will tell ya peoples...if you using the "Black Pearl" Template, then just open
the "contrib" folder witch is in the mod packed then use the "subsilver2.xml" for the viewtopic stuff.

to lumiz ,
i got the same errors and i droped all thanks mod tables via mysqladmin
then i just runned the "db_update.php" file and all stuff was ok.
After that, i was in the admin panel and piced up the forum witch i would the thanks mod in and
have set them to showing. (you must make it manuel for your forums)
dont forget to "Purge Cache" on the main admin panel and refresh your style stuff in your admin style area

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Tue Dec 30, 2008 7:32 am
by takadante
I installed the SEO Mod, and am getting the error bellow. I am not sure how to fix it.

Code: Select all

SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb_123posts p phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 164
CALL: dbal_mysql->sql_query()

FILE: viewtopic.php
LINE: 58
CALL: moved_topic()

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Fri Jan 02, 2009 4:38 pm
by ValorSolo
Any chance of getting a top 5 (or 10) thanked users add-on.
This would display on the index page.
Maybe modeled after this Mod.
http://www.phpbb.com/community/viewtopi ... s+on+Index

If I could code well enough, I'd do it.
But the mysql stuff is out of my realm of knowledge.

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Sat Jan 03, 2009 1:06 am
by lukasch007
AllCity wrote:I, too, so I was just refresh theme, template, imageset and all its ok for me.
I did it, but no effect. I've tried install this MOD to other two instances (on my localhost and one freehosting) and the same result. 4 times step-by-step instalations, i am desperade of this

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Sun Jan 04, 2009 6:35 pm
by lukasch007
Definition of my problem.
http://www.phpbb.com/community/viewtopi ... 5#p8079665

Maybe I'm on the right way.

When I edit the bad page in Firebug
Image
I replace text for (original forum)

Code: Select all

./style.php?sid=04dc3d6ac6b670c6ad0986c6c6a46b6a&id=1&lang=en
styles were loaded and page was ok.

Do you have any idea, how to fix this?

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Mon Jan 05, 2009 2:16 am
by ValorSolo
ValorSolo wrote:Any chance of getting a top 5 (or 10) thanked users add-on.
This would display on the index page.
Maybe modeled after this Mod.
http://www.phpbb.com/community/viewtopi ... s+on+Index

If I could code well enough, I'd do it.
But the mysql stuff is out of my realm of knowledge.
Any thoughts on this?

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Posted: Tue Jan 06, 2009 5:19 pm
by koronas
I have a problem!

I install de Thanks Mod, all ok, i install the hide mod, all ok. But when I install the Thank Hide addon, dont work correctly, i have modified it with:

Code: Select all

// Check if the topic viewer has posted in a topic
$unhide = false;
if ($user->data['user_id'] != ANONYMOUS)
{
	$sql = "SELECT post_id, thanks_from
      FROM " . THANKS_TABLE . "
      WHERE post_id = $post_id
      AND thanks_from = " . $user->data['user_id'];

   $result = $db->sql_query($sql);
   $unhide = $db->sql_affectedrows($result) ? true : false;
   $db->sql_freeresult($result);
}
$user->add_lang('mods/simple_hide_bbcode');
But i think that this code only execute one time for topic, and not one time for post, but when I thanks one post, i can view ALL posts with HIDE, and I need that with one thanks only can view one post hide, not all.

How can i execute this code one time for post and no one time for topic?

phpBB 3.0.4 - prosilver theme

Thanks :)