[DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
Waluigifan
Registered User
Posts: 9
Joined: Wed Dec 19, 2012 10:54 pm
Location: Germany
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by Waluigifan » Wed Dec 19, 2012 11:08 pm

Hi! I've been using this MOD for almost a year on my forum. I just created another forum where I want to include this Thank Post Mod. I've installed it with AUTOMod. There were a few errors but I was able to fix them manually (there were just small in-line errors). However, there's something strange going on. If I want to activate this MOD, I just go to the forum settings and activate it in the respective forum. So far, so good:

http://www.abload.de/img/activethatmoddlj4v.png

Then I click on "Submit" and the changes are accepted ("Forum information updated successfully.")... or at least I think so. When I want to change the settings again, the radio button is still on "no" even though I just enabled it... it is as if I never activated the MOD!

http://www.abload.de/img/activethatmod23mjom.png

No matter what I do, I can't enable this MOD! What went wrong?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by Oyabun1 » Sun Dec 23, 2012 3:45 am

This instruction in the install.xml file would, no doubt, have cause an error in AutoMOD:
install.xml wrote:File Copy
  1. Copy: root/db_update.php
    To: phpbb root and run this with your browser or they use the sql command from the manual. After using this file, please delete it to avoid errors.
Did you copy the db_update.php file to the root of your board installation, and did you then run it?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Waluigifan
Registered User
Posts: 9
Joined: Wed Dec 19, 2012 10:54 pm
Location: Germany
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by Waluigifan » Sun Dec 23, 2012 5:32 pm

Did you copy the db_update.php file to the root of your board installation, and did you then run it?
Yes, I did and the MOD was properly installed. But I still can't enable the MOD in the forums via the ACP.

However, I found a way to force enable the MOD! :D I just go to "phpMyAdmin" -> "Database" -> "phpbb_forums" and then change the "enable_thanks" value to 1 (enabled) in the forums I want the MOD to be active:
http://www.abload.de/img/databasemnjk6.png

Atfer doing this, the "Thanks" button shows up and everything works fine.

User avatar
pilot35
Registered User
Posts: 48
Joined: Sat Jan 19, 2013 1:21 pm
Location: In the cockpit

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by pilot35 » Fri Jan 25, 2013 3:52 pm

Why can't I download? I copied the text exactly and I still can't download! :x

cadetes
Registered User
Posts: 13
Joined: Fri Apr 12, 2013 4:10 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by cadetes » Mon Apr 15, 2013 10:54 am

The download link is death someone have this mod to share? Or another mod to hide before thanks?

Br

User avatar
nextgen
Jr. Style Validator
Posts: 2334
Joined: Mon Jul 26, 2010 10:58 pm
Location: Guatemala
Name: Melvin García
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by nextgen » Mon Apr 15, 2013 4:27 pm

cadetes wrote:The download link is death someone have this mod to share? Or another mod to hide before thanks?
The link not dead, fill in the form of spam question so you can download the mod.
メルビン・ガルシア • Xtrato SolutionsMy active styles for phpBBphpBB Argentina - Soporte en español🇦🇷

Please do NOT contact for support via PM or email.

ferryfrans
Registered User
Posts: 1
Joined: Sat Oct 22, 2011 11:20 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by ferryfrans » Mon May 06, 2013 3:16 pm

it says "Schreiben Sie alle Buchstaben, außer dem letzten, aus diesem Text heraus: 784gZJ8Jt&s,8i9pGS:
Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern"

I write 784gZJ8Jt&s, or 8i9pGS or the letters only, or the numbers only. I can't download it, can you help me please.

Thanks in advance.

User avatar
tbackoff
Former Team Member
Posts: 7022
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by tbackoff » Mon May 06, 2013 7:56 pm

Google translate says this is the question:
Write all the letters, except the last, from this text out: 784gZJ8Jt & s, 8i9pGS:
This question is to prevent automated form submissions by spam bots
That means the answer should be gZJJtsipG but that's just a guess.
Flying is the second best thrill to cheerleaders; being caught is the first.

User avatar
masterbiz
Registered User
Posts: 52
Joined: Thu Dec 20, 2012 8:31 am

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by masterbiz » Thu Jun 06, 2013 5:34 pm

Hi I installed this change in 3.0.11 but I get errors when I go to open the post to ringrazziare (the key and 'visible) the error back to viewtopic.php precisely in these lines :

Code: Select all

//Begin Thank Post MOD		
		'POSTER_THANKS'			=> $user_cache[$poster_id]['thanks'],
		'POSTER_THANKED'		=> ($user_cache[$poster_id]['thanked'] <= 1) ? $user_cache[$poster_id]['thanked'] . $user->lang['THANKS_TIME'] : $user_cache[$poster_id]['thanked'] . $user->lang['THANKS_TIMES'],
		'POSTER_THANKS_POST'	=> ($user_cache[$poster_id]['thanks_post'] <= 1) ? $user_cache[$poster_id]['thanks_post'] . $user->lang['THANKS_POST'] : $user_cache[$poster_id]['thanks_post'] . $user->lang['THANKS_POSTS'],
        //End Thank Post MOD

Sivasli_14
Registered User
Posts: 22
Joined: Sat Dec 20, 2008 12:22 pm

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by Sivasli_14 » Wed Jul 24, 2013 12:15 pm

Problem !!

Code: Select all

SQL ERROR [ mysqli ]

Unknown column 'user_thanks_post' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_thanked = user_thanked + 1, user_thanks_post = user_thanks_post + 1 WHERE user_id = 65

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/thanks.php
LINE: 90
CALL: dbal_mysqli->sql_query()

User avatar
Leinad4Mind
Translator
Posts: 851
Joined: Sun Jun 01, 2008 11:08 pm
Contact:

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by Leinad4Mind » Tue Feb 04, 2014 12:32 am

I've made an 0.3.0 version of it compatible with 3.0.12. It needed very edits. So be aware of install this 0.2.0 on a live forum with 3.0.7+ phpBB

If anyone is interested just PM me.

best regards
Want to access all my portuguese MOD and Extension translations?
Become my Patreon!
phpBB Portugal Translator and Moderator

User avatar
gussie
Registered User
Posts: 92
Joined: Wed Nov 27, 2002 1:26 am

Re: [DEV] Thank Post Mod (hide MOD compatible ) 0.2.0

Post by gussie » Fri Feb 21, 2014 10:18 am

Mahoney wrote:Hello
In my mod, there is no toplist.php
Thank you for confirming this.

Is there a simple way this feature can be added? Or a way to extract this in a separate page in the forum?
Res tantum valet quantum vendi potest
Do not hire Christian Bullock - he will not finish the job and he will not return your money.

Locked

Return to “[3.0.x] MODs in Development”