[MODDB] ACP Announcement Centre 1.2.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
Locked
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

occasionally that error occurs, i have not figured out why yet but have provided a fix here:
http://www.phpbb.com/community/viewtopi ... 5#p8118645

the new version that will come out one of these days should no longer have that error.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
antagonia
Registered User
Posts: 12
Joined: Thu Dec 25, 2008 8:43 am

Re: [Beta] ACP Announcement Centre 1.1.2

Post by antagonia »

I actually just pulled the cached versions of those files and recreated them before I checked back here, so that worked. So I've gone through the entire install, uploaded all the new files, and made the edits to bring it up to 1.1.2, and I am still having the same problem where the entire board goes blank as soon as I add the include tag to overall_header.html

EDIT. NEVER MIND. It worked when I refreshed it a couple times! Thank you very much for your patience and help!
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

That's great. I am glad it's working now ... and you upgraded too :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
Paul_B3
Registered User
Posts: 41
Joined: Sat Dec 13, 2008 3:58 pm

Re: [Beta] ACP Announcement Centre 1.1.2

Post by Paul_B3 »

It all appears to work, the only one problem I have is that I cannot get the emoticons to show on the Guest Announcements which is on my index page but they show ok on Site Announcements.
I have check all my setting and all seam to be ok.

Paul_B3
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

hi, could you give me a link to ur board and maybe a temp admin and temp ftp account.

i have never had that problem so cannot replicate it.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
Paul_B3
Registered User
Posts: 41
Joined: Sat Dec 13, 2008 3:58 pm

Re: [Beta] ACP Announcement Centre 1.1.2

Post by Paul_B3 »

Opps my error I has turn off the [Edit display options] [Display smilies as images] Anonymous user. Sorry.

Paul_B3
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

no worries, it is sorted now which is what matters :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
eman80
Registered User
Posts: 327
Joined: Tue Aug 19, 2008 1:49 pm

Re: [Beta] ACP Announcement Centre 1.1.2

Post by eman80 »

eman80 wrote:Hi lefty

I found another big problem in language file (announcement_centre) in these lines:

Code: Select all

	'YES'			=> 'Yes',
	'NO'			=> 'No',
YES and NO already exist in another language file (common.php)
and that is causing a big problem when we want to stick or delete or move ..etc the topics.

I don't now if there is another issue in the language file .. hope to fix this ..

good luck

Regards
Eman.

Hi lefty

I want to let you know that this problem has been solved after I translated these lines to my language.

Thank u :)

Regards
Eman
welcome to my forum:
http://www.elibrary4arab.com
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

cheers, i was going to change the language variables in the next version to ensure they are unique.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
DoYouSpeakWak
Registered User
Posts: 2310
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by DoYouSpeakWak »

Hey lefty.

I was wondering if it was posible to do a manual install instead of the install folder ? What queries to run etc. Adding the modules manually is no prob. More the mysql i hope you can help with. :)

DYSW
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid services. 10+ years of experience with phpBB3 and as System Administrator.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

DoYouSpeakWak wrote:Hey lefty.

I was wondering if it was posible to do a manual install instead of the install folder ? What queries to run etc. Adding the modules manually is no prob. More the mysql i hope you can help with. :)

DYSW
not sure why you would want to do it manually but this should do the trick

Code: Select all

CREATE TABLE IF NOT EXISTS phpbb_announcement_centre (
  announcement_forum_id mediumint(8) unsigned NOT NULL default '0',
  announcement_topic_id mediumint(8) unsigned NOT NULL default '0',
  announcement_post_id mediumint(8) unsigned NOT NULL default '0',
  announcement_gopost tinyint(1) unsigned NOT NULL default '0',
  announcement_first_last_post varchar(4) collate utf8_bin NOT NULL default '0',
  announcement_draft text collate utf8_bin NOT NULL,
  announcement_draft_bbcode_uid varchar(8) collate utf8_bin NOT NULL default '',
  announcement_draft_bbcode_bitfield varchar(255) collate utf8_bin NOT NULL default '',
  announcement_draft_bbcode_options int(11) unsigned NOT NULL default '7',
  announcement_text text collate utf8_bin NOT NULL,
  announcement_text_bbcode_uid varchar(8) collate utf8_bin NOT NULL default '',
  announcement_text_bbcode_bitfield varchar(255) collate utf8_bin NOT NULL default '',
  announcement_text_bbcode_options int(11) unsigned NOT NULL default '7',
  announcement_text_guests text collate utf8_bin NOT NULL,
  announcement_text_guests_bbcode_uid varchar(8) collate utf8_bin NOT NULL default '',
  announcement_text_guests_bbcode_bitfield varchar(255) collate utf8_bin NOT NULL default '',
  announcement_text_guests_bbcode_options int(11) unsigned NOT NULL default '7',
  announcement_title varchar(255) collate utf8_bin NOT NULL default '',
  announcement_title_guests varchar(255) collate utf8_bin NOT NULL default ''
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

-- 
-- Dumping data for table phpbb_announcement_centre
-- 

INSERT INTO phpbb_announcement_centre (announcement_forum_id, announcement_topic_id, announcement_post_id, announcement_gopost, announcement_first_last_post, announcement_draft, announcement_draft_bbcode_uid, announcement_draft_bbcode_bitfield, announcement_draft_bbcode_options, announcement_text, announcement_text_bbcode_uid, announcement_text_bbcode_bitfield, announcement_text_bbcode_options, announcement_text_guests, announcement_text_guests_bbcode_uid, announcement_text_guests_bbcode_bitfield, announcement_text_guests_bbcode_options, announcement_title, announcement_title_guests) VALUES 
(0, 0, 0, 1, 'DESC', '[color=red:3lj1pvpr][b:3lj1pvpr]Draft Announcements[/b:3lj1pvpr][/color:3lj1pvpr] can be seen here!! <!-- s:mrgreen: --><img src="{SMILIES_PATH}/icon_mrgreen.gif" alt=":mrgreen:" title="Mr. Green" /><!-- s:mrgreen: -->', '3lj1pvpr', 'Qg==', 7, '[color=red:1nwjfl7g][b:1nwjfl7g]Site Announcements[/b:1nwjfl7g][/color:1nwjfl7g] can be seen here!! <!-- s:mrgreen: --><img src="{SMILIES_PATH}/icon_mrgreen.gif" alt=":mrgreen:" title="Mr. Green" /><!-- s:mrgreen: -->', '1nwjfl7g', 'Qg==', 7, '[color=green:28097r8r][b:28097r8r]Guest Announcements[/b:28097r8r][/color:28097r8r] can be seen here!! <!-- s:wink: --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt=":wink:" title="Wink" /><!-- s:wink: -->', '28097r8r', 'Qg==', 7, 'Site Announcements', 'Guest Announcements');


INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES 
('announcement_enable', '1', 0),
('announcement_show_index', '0', 0),
('announcement_enable_guests', '1', 0),
('announcement_show', '1', 0),
('announcement_show_birthdays', '1', 0),
('announcement_birthday_avatar', '1', 0),
('announcement_ava_max_size', '40', 0),
('announcement_show_birthdays_always', '1', 0),
('announcement_show_birthdays_and_announce', '1', 0),
('announcement_show_group', '', 0),
('announcement_align', 'center', 0),
('announcement_guests_align', 'center', 0),
('acmod_version', '1.1.2', 0);
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
User avatar
DoYouSpeakWak
Registered User
Posts: 2310
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by DoYouSpeakWak »

Thx so much. Ill test it out tonight.

The reason is that your installer is using the /install/ folder, and the board cant run if that is there. if its a easy fix to just change that folder name ill do that instead. But its always nice to have the sql for this for any premod that might come up.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid services. 10+ years of experience with phpBB3 and as System Administrator.
DaveGreen
Registered User
Posts: 6
Joined: Sat Jan 03, 2009 12:17 pm

Re: [Beta] ACP Announcement Centre 1.1.2

Post by DaveGreen »

Hello there, I'm having some problems installing this on my server. I have edited all files and added the included files at the right place, but when I add the install folder and go to www. and I press Continue installation, I get this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'coldfusion-wow_com_1.phpbb_announcement_centre' doesn't exist [1146]

SQL

SELECT * FROM phpbb_announcement_centre

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal_mysql->sql_error()

FILE: install/index.php
LINE: 147
CALL: dbal_mysql->sql_query()
When I remove the Install folder the forum works again. What to do?

I apologize if this is a silly question but I have only just started with these stuff, I know very little php and basically nothing of SQL.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [Beta] ACP Announcement Centre 1.1.2

Post by lefty74 »

did you have the announcement centre installed previously?
also, what is it you are seeing exactly when you run the install/index.php file?

New Installation or Upgrade to x?
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.
DaveGreen
Registered User
Posts: 6
Joined: Sat Jan 03, 2009 12:17 pm

Re: [Beta] ACP Announcement Centre 1.1.2

Post by DaveGreen »

lefty74 wrote:did you have the announcement centre installed previously?
also, what is it you are seeing exactly when you run the install/index.php file?
I tried installing the other version, but we got loads of errors in the SQL thing so I decided to try this, which had an installer included in the release.
New Installation or Upgrade to x?
Hmm I am not sure about this atm...I know that there was an option to Uninstall, below the other option. But I can upload the install folder again to check if you would like me to.
Locked

Return to “[3.0.x] MODs in Development”