[MODDB] Custom Header Logo 1.2.7 (with bg and custom pages)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by Balint »

Balint wrote:I knew I should not have offered an update :D erm... I'm working on it (file changes are done, but I have to teach UMIL how to extract and insert values from one table to another :shock: ).
@tekknodevil: I wrote update instructions and placed them in the "contrib" folder of the following ZIP file. Please make a backup of your files and database before making any changes - I can not guarantee if it is working!

http://phpbb.krizsan.de/custom_header_l ... update.zip

Please report any errors or even if it worked... :|


Regards,
Bálint
tekknodevil
Registered User
Posts: 69
Joined: Mon Feb 08, 2010 6:53 pm
Location: Dresden, Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by tekknodevil »

Balint wrote:
Balint wrote:I knew I should not have offered an update :D erm... I'm working on it (file changes are done, but I have to teach UMIL how to extract and insert values from one table to another :shock: ).
@tekknodevil: I wrote update instructions and placed them in the "contrib" folder of the following ZIP file. Please make a backup of your files and database before making any changes - I can not guarantee if it is working!

http://phpbb.krizsan.de/custom_header_l ... update.zip

Please report any errors or even if it worked... :|


Regards,
Bálint
Thanks. I´ll test it out.
tekknodevil
Registered User
Posts: 69
Joined: Mon Feb 08, 2010 6:53 pm
Location: Dresden, Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by tekknodevil »

Balint wrote:
Balint wrote:I knew I should not have offered an update :D erm... I'm working on it (file changes are done, but I have to teach UMIL how to extract and insert values from one table to another :shock: ).
@tekknodevil: I wrote update instructions and placed them in the "contrib" folder of the following ZIP file. Please make a backup of your files and database before making any changes - I can not guarantee if it is working!

http://phpbb.krizsan.de/custom_header_l ... update.zip

Please report any errors or even if it worked... :|


Regards,
Bálint
Ok, the update instructions doesnt work for me. i get the following error if i open the mod in acp:

General Error
No Mode Specified.
User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by Balint »

Hi,

did you remove and re-add the modules? The structure of the module part changed in the new version.


Regards,
Bálint
tekknodevil
Registered User
Posts: 69
Joined: Mon Feb 08, 2010 6:53 pm
Location: Dresden, Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by tekknodevil »

Balint wrote:Hi,

did you remove and re-add the modules? The structure of the module part changed in the new version.


Regards,
Bálint
Oh my god - i´m soo stupid. now ist works. thank you.
direet
Registered User
Posts: 1
Joined: Sun Aug 28, 2011 10:20 am

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by direet »

other structure in http://demo.phpbb3styles.net/1thank
does not work :(
mentioned offitype
Registered User
Posts: 19
Joined: Thu Jun 02, 2011 7:42 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by mentioned offitype »

Trying this mod out now, Love it! It's exactly what I've been looking for! The custom background headers for custom pages (as best as I can tell makes a custom background for a specific url) was just icing on the cake! No, not just icing, chocolate, and candy, and a cherry on top. Bravo, good sir, for this wonderful mod!

Took me a while to figure out where it wanted me to store the background images, but I figured it out. ( it's images/backgrounds and images/logos if you didn't know)
sleevedbiker
Registered User
Posts: 789
Joined: Mon Oct 12, 2009 4:33 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by sleevedbiker »

will this change the banner for sections like.... arcade, garage, etc.?
You ride with an outlaw, You die with an outlaw
User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by Balint »

Hi,

from your PM (everyone should profit from the answer to your question):
I installed your custom header logo 1.2.6 on my site, but the background banner isnt changing.... my forum root is http://www.sonsofanarchyforever.com/forum

and my gallery is http://www.sonsofanarchyforever.com/for ... /index.php

Are these settings I used correct....
page name = Gallery
path name = gallery
page query = *
and i chose a background image... thebackground image was uploaded to from/images/backgrounds and selected from the dropdown

also I am using prosilver special edition, i dont know if that makes a difference
The path to your gallery is http://www.sonsofanarchyforever.com/forum/gallery/index.php

so page-name = index
path-name = gallery
page-query = *

Unforunately you have to repeat this for all gallery-pages, e.g. "album", "image_page", etc.

A hint for getting it working with prosilver SE is here: change

Code: Select all

.headerbar {background:url("{SITE_BG_IMG}") repeat;}
in your overall_header.html to

Code: Select all

.header-bar {background:url("{SITE_BG_IMG}") repeat;}

Regards,
Bálint
sleevedbiker
Registered User
Posts: 789
Joined: Mon Oct 12, 2009 4:33 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by sleevedbiker »

that worked. thanks.

the only thing I am having a trouble changing now is the banner for Ultimate Points which is located @ /forum/points.php is there any way to get that to work?
You ride with an outlaw, You die with an outlaw
User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by Balint »

Hi,

it should be

page-name = points
path-name = <empty>
page-query = *

(path name must be left empty).

Regards,
Bálint
rxB975D432pV
Registered User
Posts: 183
Joined: Thu Aug 04, 2011 1:54 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by rxB975D432pV »

Balint wrote:A Hungarian living in Germany
You live in Germany? Accordingly, there is also a German translation of mod?
User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by Balint »

TheMathematics wrote:You live in Germany? Accordingly, there is also a German translation of mod?
There wasn't ;) There is now: custom_header_logo_1.2.6_de.zip

However, the language strings are strictly in the ACP, so it shouldn't matter much.


Regards,
Bálint
rxB975D432pV
Registered User
Posts: 183
Joined: Thu Aug 04, 2011 1:54 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by rxB975D432pV »

Thanks for translating. :mrgreen:
mentioned offitype
Registered User
Posts: 19
Joined: Thu Jun 02, 2011 7:42 pm

Re: [RC] Custom Header Logo 1.2.6 (logos, bg and custom page

Post by mentioned offitype »

Hey, I've been using your mod for a while now; I really enjoyed using it too! But just recently I made some minor modifications to my Prosilver theme, and now your mod doesn't work at all. I can choose which background I want to use in the acp, but the results don't show up on the actual forum, and restoring an old version of prosilver doesn't help either.

Code: Select all

.headerbar {
	background-color: #faa71a;
	background-image: url("{T_THEME_PATH}/images/bg_header.gif"); no-repeat;
	color: #FFFFFF;
}

.navbar {
	background-color: #cadceb;
}

.forabg {
	background-color: #a77500;
	background-image: url("{T_THEME_PATH}/images/bg_list.gif");
}

.forumbg {
	background-color: #faa71a;
	background-image: url("{T_THEME_PATH}/images/bg_list2.gif");
}
These are the only changes I made, and they're for prosilver's colours.css, which shouldn't have anything to do with your mod, but once I made these changes your mod stopped working, and I can't get it to work again.
It could be that I haven't refreshed the prosilver theme in weeks meaning some mysterious conflict in the code is causing this, but even after uninstalling and reinstalling the mod it won't work. Other than that it's a really great mod and I enjoyed using it. I just wish I could continue using it a little longer...
Locked

Return to “[3.0.x] MODs in Development”