Page 2 of 19

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Thu Oct 23, 2008 4:26 pm
by wolverd
Balint wrote:And the error message pops up when you go to the forums bit in ACP? Strange... I'll install it on a fresh 3.0.2 tonight (that's in 3 or four hours from now) and see what I can find out.
I forgot to mention that the problem was coming up in the ACP + forums section so that's pretty darned impressive diagnostic skills you've got there!!!

I assume you figured this out because this has happened before?

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Thu Oct 23, 2008 6:07 pm
by Balint
I figured this out because the only language strings I'm adding are in the ACP :-)

EDIT: Did a fresh install, nothing wrong here...

Could you re-download my archive, delete the lang file and re-upload the file again?

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Thu Oct 23, 2008 10:30 pm
by wolverd
Okay, I'm stumped...

Here's what I've done to try and get this working:

(1) Uninstall test board. (URL in signature - below) using Cpanel.
(2) Re-install test board (Also using Cpanel)
(3) Confirm every part of test board working before modifying by logging in and clicking everything as Admin.
(4) Delete existing Mod .zip file and download fresh copy - using following link:
MOD Download: http://phpbb.krizsan.de/custom_header_logo_1.2.0.zip
(Updated on 2008-10-11)
(5) Unzip files to desktop
(6) Modify php database with PhpMyAdmin as per Mod install instructions
(7) Backup files to be modified to seperate folder
(8) Download - in seperate folder - all files to be modified
(9) Carefully mod files as instructed paying strict attention to 'replace,' 'add before' and 'add after'
(10) Go to ACP front page (General Tab) and click "Purge the cache" button
(11) Attempt to go to "Forums" tab (also in ACP) and here is the message:
General Error
Language file custom_header.php couldn't be opened.
Some more info that might assist you diagnose:

(A) Board version: Phpbb 3.0.2
(B) Database server: MySQL 4.1.22-standard

Further notes:

AFTER installation, restoring backed up version - but leaving SQL changes and leaving "Language file custom_header.php" installed doesn't affect the board working - so I don't think that the sql changes or the aditional file are the problem - it seems to me to be something in my editing of the files -OR- a problem in the SQL database version?

This is all the info I can think of to supply... Is there other info you need to help me diagnose this?

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 7:47 am
by Balint
Hi!

Since it is a testboard and you provided so much information without me having a clue what's going wrong: could you PM (!) me FTP-login details and generate a full admin account? I'd really like to fix that for you!


Greets,
Bálint

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 10:02 am
by wolverd
Balint wrote:Hi!

Since it is a testboard and you provided so much information without me having a clue what's going wrong: could you PM (!) me FTP-login details and generate a full admin account? I'd really like to fix that for you!
Thanks Balint,

I've created an Admin account for you and have PM'd the login details for you - as well as the FTP details.

Cheers for your help!

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 10:31 am
by Balint
Hi!

Problem solved. The default language for my testaccount (and probably yours) is set to "English (United States)", so after uploading to the corresponding "en_us/mods" language folder everything works like advertised.

However the answer "No, [...] only English" to my question "Do you have multiple languages?" was wrong then. There are 47 languages installed on the board... :oops:

The bottom line is: install the language file in the "en/mods" if you have english only - install it to "de/mods" if you have set german for your admin user. And so on...


Greets,
Bálint

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 11:17 am
by wolverd
Oh my goodness!!! :o

It actually works BETTER then I thought it would!!! :shock:

Before I can make post it live though, I need to edit banner dimensions (The dimensions aren't high enough - I want to make it higher) could you please tell me where I need to edit to do this?

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 11:21 am
by wolverd
Last - but not least - how do I make the custom logo and custom background come up on the first page of the forum?

Eg: http://www.mydomain.com.au/forum

Thanks in advance!

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Oct 24, 2008 11:24 am
by Balint
Hi!

Since changing the "default" logo in the ACP is not the purpose of this MOD (however, it could be in later versions), this has to be done manually:

Knowledge Base - Changing your board logo

and

http://www.phpbb.com/community/viewtopi ... &t=1167195



Greets,
Bálint

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Sat Nov 01, 2008 1:54 pm
by danswano
Balint can you answer my question here please about your mod ?
http://www.phpbb.com/community/viewtopi ... 5#p7562325

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Sat Nov 01, 2008 2:02 pm
by 1234homie
hi can author add a update mod from old version or list of changes but i dont know what i must update to version 1.2.0...

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Dec 05, 2008 8:51 am
by Balint
Hi!

I will add update instructions this weekend and also update the instructions for phpBB 3.0.3.


Greets,
Bálint

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Dec 05, 2008 11:13 am
by darkonia
how about a subsilver2 template

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Dec 05, 2008 11:32 am
by Balint
You mean instructions on how to change the background on subsilver? I try to add this instructions, too.


Greets,
Bálint

Re: [RC] Custom Header Logo 1.2.0 (w/ custom header backgrounds)

Posted: Fri Dec 05, 2008 11:33 am
by darkonia
@balint: no more need for a subsilver2 template fix.

your code is enough, runs smooth and perfect by me.

Thx a lot for this fantastic addon :D