[MODDB] Custom Header Logo 1.2.7 (with bg and custom pages)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
win_xp_devilsown
Registered User
Posts: 30
Joined: Sun Oct 14, 2007 4:34 am
Location: Kiwi Land
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by win_xp_devilsown » Sat Jan 03, 2009 7:45 am

Ok... have sort out previous issues from other day .......... all except 1 .

Have not used automod and restored board from backup...... all system go. Have copied and pasted mod code changes, upload, purged cache etc but get this error.....

Code: Select all

Parse error: syntax error, unexpected ',', expecting ')' in /home/racechat/public_html/forum/includes/acp/acp_forums.php on line 141
this is my code on line 141

Code: Select all

'forum_background_logo'         => request_var('forum_background_logo', ''),

To me.... the code on line 141 is correct.... any clues ? thank you

If wish wish to look at the full file you can download it here http://www.racechat.co.nz/acp_forums.rar

User avatar
knmt
Registered User
Posts: 110
Joined: Fri Aug 29, 2008 10:13 am
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by knmt » Sat Jan 03, 2009 10:22 am

Code: Select all

'forum_background_logo'         => request_var('forum_background_logo', ''),                                ,
                                                'forum_style'                   => request_var('forum_style', 0),
This is from line 141 to line 142, you can obviously see what's causing the syntax error ;). What you have to do is to place your mouse pointer after "request_var('forum_background_logo', '')," then press END, you will get that unnecessary comma.

jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Tue Jan 06, 2009 8:37 pm

I also want to use this beautiful tool but it getting error inside ACP :(

Using following stuff on my site http://www.modelltag.se
Fresh installation phpBB 3.0.4 with MySQL 5.0.32
prosilver Special Edition 1.0.1
Language Swedish
Buttons menu for prosilver 1.0.2
MSSTI RSS Feed 2.0 with ACP 1.0.4

When I try to select change forum settings this showing up in the top of the page
[phpBB Debug] PHP Notice: in file /adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at /includes/acp/acp_board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /includes/acp/acp_board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/acp/acp_board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at /includes/acp/acp_board.php:1)

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Tue Jan 06, 2009 9:15 pm

Hi,

could you please upload the includes/acp/acp_board.php you are using to http://pastebin.ca/ ?

Thanks,
Bálint

jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Tue Jan 06, 2009 9:25 pm


jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Fri Jan 09, 2009 6:04 pm

? :cry:

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Fri Jan 09, 2009 6:19 pm

Hm, i don't see an error in the file you pasted. Did you upload the files (also the language file) correctly? Please recheck that.
Last edited by Balint on Fri Jan 09, 2009 6:49 pm, edited 1 time in total.

jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Fri Jan 09, 2009 6:34 pm

I inclode this in both

root/language/en/mods/custom_header.php
root/language/sv/mods/custom_header.php

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Fri Jan 09, 2009 6:53 pm

could you please also check that you have (successfully) cleared the cache in the acp?

If that does not help, I'm willing to take a direct look, if you send me FTP and admin-account details in a PM.

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Fri Jan 09, 2009 8:18 pm

Thanks for sending me the FTP information. Do you use frontpage to edit and upload the files by any chance? The edited files have a weird formatting with a blank line between each line.

Could you please provide an admin-account, too - the FTP is just one side of the story...

jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Fri Jan 09, 2009 9:26 pm

yes sometimes i am using SharePoint Designer

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Fri Jan 09, 2009 9:42 pm

Hi,

IMHO you should edit phpBB core files only with a capable Text-Only-Editor like Notepad++ (free). The program you used messed up the files, I corrected the errors with fresh copies from the latest phpBB 3.0.4 and added the edits with the mentioned editor. The ACP works now.


Greets,
Bálint

jonasj
Registered User
Posts: 101
Joined: Tue Jan 06, 2009 8:06 pm
Location: Stockholm, Sweden
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by jonasj » Fri Jan 09, 2009 10:00 pm

THANKS! :D I promise never to use anything else the Notepad from now on :oops:

Only two question ;) is it possible to get head background picture on the front page and also change the height.

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Balint » Fri Jan 09, 2009 10:30 pm

Hi,

there are a plenty threads about that, just search for "change header background" - it involves making changes in the css-files.

Greets,
Bálint

Blizzie
Registered User
Posts: 27
Joined: Tue Aug 05, 2008 8:07 pm

Re: [RC] Custom Header Logo 1.2.1 (w/ custom header backgrounds)

Post by Blizzie » Wed Jan 14, 2009 3:30 pm

some thing gone wrong can you please help me

SQL ERROR [ mysqli ]

Unknown column 'forum_logo' in 'field list' [1054]

SQL

UPDATE phpbb_English_1forums SET parent_id = 1, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = 'Under 18 år - Der vil ansøge om optagelse i The Nordic Legion', forum_link = '', forum_desc = 'Ansøgninger til TNL bliver vil blive behandlet af vores officerer i dette forum.', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = '', forum_image = '', forum_logo = '', forum_background_logo = '', forum_style = 0, display_subforum_list = 1, display_on_index = 0, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 0, enable_prune = 0, prune_days = 0, prune_viewed = 0, prune_freq = 0, forum_flags = 32 WHERE forum_id = 4

BACKTRACE


FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/acp/acp_forums.php
LINE: 1274
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_forums.php
LINE: 182
CALL: acp_forums->update_forum_data()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_forums->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

Locked

Return to “[3.0.x] MODs in Development”