[RC] Add Page MOD

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
momentum
Registered User
Posts: 1505
Joined: Thu Sep 20, 2007 4:07 am
Location: Melbourne, Australia

Re: [BETA] Add Page MOD

Post by momentum » Sat Feb 28, 2009 6:05 pm

Solved both the logout and style problem. It was indeed a cookie problem. (mea culpa :oops: )

I've added the style="font-size: 1.25em" specification to both page_body.html files but the smaller font with custom BBCodes problem remains. :|

I also noticed the page_list.html file that arrived with the latest version. It offers quite a few possibilities. 8-)

Craig.
QOTY: phpBB is free, good hosting is not. - robert (Lumpy Burgertushie)

Artack
Registered User
Posts: 312
Joined: Thu Feb 07, 2008 11:26 pm

Re: [BETA] Add Page MOD

Post by Artack » Sat Feb 28, 2009 7:42 pm

Fresh install 0.1.2 version
When click add page, give error

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/acp/acp_pages.php on line 210: Undefined index: page_display

cisco007
Translator
Posts: 129
Joined: Mon Jul 14, 2008 1:49 am
Contact:

Re: [BETA] Add Page MOD

Post by cisco007 » Sat Feb 28, 2009 8:26 pm

seems like there are some edits missing or some fields missing in the language file for this mod i get alot of {page_display}, { PAGE_ORDER_EXPLAIN }, { PAGE_DISPLAY }:, { PAGE_DISPLAY_EXPLAIN } in the ACP part of this mod, and on mysite/page.php I get this { PAGES }. Other than than that this works great! :D
Image

User avatar
ameeck
Former Team Member
Posts: 6559
Joined: Mon Mar 21, 2005 6:57 pm

Re: [BETA] Add Page MOD

Post by ameeck » Sat Feb 28, 2009 8:34 pm

cisco007: I forgot to pack the update language file, re-download the package and overwrite the page.php file in the languages. Sorry for that.

Artack: Will fix that in the next version, it shouldn't affect functionallity.

cisco007
Translator
Posts: 129
Joined: Mon Jul 14, 2008 1:49 am
Contact:

Re: [BETA] Add Page MOD

Post by cisco007 » Sat Feb 28, 2009 10:32 pm

that still didn't work I am getting the same thing, I tried to add them myself but I come up with a blank page!
Image

ghost123456789
Registered User
Posts: 11
Joined: Sat Sep 06, 2008 7:34 pm

Re: [BETA] Add Page MOD

Post by ghost123456789 » Sat Feb 28, 2009 10:53 pm

I think this mod is very good, but I somehow still lacks the name not the id

Example:
http://allphpbb.al.ohost.de/page.php?id=1
http://allphpbb.al.ohost.de/page.php?id=rules

Humanrag3
Registered User
Posts: 157
Joined: Thu Oct 30, 2008 3:58 am

Re: [BETA] Add Page MOD

Post by Humanrag3 » Sun Mar 01, 2009 2:36 am

Hey, I know it supports custom bbcodes, but how about raw htmls?

EDIT: I'm pretty sure your language file edits are wrong. I haven't got the time to correct it yet but i'll do so ASAP.

User avatar
ameeck
Former Team Member
Posts: 6559
Joined: Mon Mar 21, 2005 6:57 pm

Re: [BETA] Add Page MOD

Post by ameeck » Sun Mar 01, 2009 10:12 am

Tried re-uploading once more, the 0.1.2 definetely should have those language strings.

ghost123456789: just one page back i was talking about the format of the URLs, any suggestions appreciated.

I answered HTML two pages back.

ghost123456789
Registered User
Posts: 11
Joined: Sat Sep 06, 2008 7:34 pm

Re: [BETA] Add Page MOD

Post by ghost123456789 » Sun Mar 01, 2009 10:22 am

also in new version you make it?!?!

Sorry for my english i'm german and i'm 12 :(

Jan

cisco007
Translator
Posts: 129
Joined: Mon Jul 14, 2008 1:49 am
Contact:

Re: [BETA] Add Page MOD

Post by cisco007 » Sun Mar 01, 2009 3:35 pm

It's all working like it should now, I could swear I uploaded the right one yesterday, but no problem it's working now! :)
Image

User avatar
Blackmore
Registered User
Posts: 18
Joined: Thu Dec 25, 2008 10:03 am

Re: [BETA] Add Page MOD

Post by Blackmore » Sun Mar 01, 2009 4:41 pm

Hi ameeck,

a big thanks for this mod. I've searched a long time for anything like that and you made it.
The mod works perfect. If i find bugs, i will report them to you. ;)
Cheers,
Blackmore

Kharon
Registered User
Posts: 235
Joined: Thu Oct 26, 2006 5:27 pm

Re: [BETA] Add Page MOD

Post by Kharon » Sun Mar 01, 2009 5:06 pm

I have tested this mod (0.1.2)

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/acp/acp_pages.php on line 210: Undefined index: page_display

User avatar
ameeck
Former Team Member
Posts: 6559
Joined: Mon Mar 21, 2005 6:57 pm

Re: [BETA] Add Page MOD

Post by ameeck » Sun Mar 01, 2009 5:10 pm

Kharon wrote:I have tested this mod (1.0.2)

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/acp/acp_pages.php on line 210: Undefined index: page_display
Look at the middle of page 4, I know about it and it doesn't affect functionallity, I'll fix it in the next version.

When reporting errors please at least list where it occurs.

Kharon
Registered User
Posts: 235
Joined: Thu Oct 26, 2006 5:27 pm

Re: [BETA] Add Page MOD

Post by Kharon » Sun Mar 01, 2009 5:17 pm

thank you

I am not coder .. I don't konow .. it is working now (localhost)

//'S_PAGE_DISPLAY' => ($pages['page_display']) ? true : false,

User avatar
ameeck
Former Team Member
Posts: 6559
Joined: Mon Mar 21, 2005 6:57 pm

Re: [BETA] Add Page MOD

Post by ameeck » Sun Mar 01, 2009 5:19 pm

This is Beta, that means it doesn't have to work 100% correctly, I said that nothing won't happen if you'll leave the error there.

The fix is:

Code: Select all

'S_PAGE_DISPLAY'        => (!empty($pages['page_display'])) ? true : false, 
By saying where the error appears I mean to say that it was during adding of a page.

Locked

Return to “[3.0.x] MODs in Development”