[RC] Locked Post Indicator Button (LPIB)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

[RC] Locked Post Indicator Button (LPIB)

Post by lugsciath » Mon Apr 20, 2009 8:06 pm

Modification Name: Locked Post Indicator Button (LPIB)
Author: Author Lugsciath

Modification Description:: Shows a "Locked" Button to All in viewtopic, when the (single) post is locked, with ability to report this from guests or users by pushing this button (or get a message back, that this might the reason :) ...), Admins and Mods are shown the same button instead the "edit" button for information, but without restrictions. If the posts would unlocked, the edit button will shown as always.
Modification Version:: 1.00
Requirements: only available in the moment for prosilver skin
Features:
  • Post Locked Button in locked Posts, with different Handling between Admins/Mods and Users
  • changed automaticly to the normal edit button when post is unlocked
  • tested in 3.04 in prosilver skin
  • easy adaptable to subsilver and other skins (in future or through contributions)
  • english and german instructions
  • about 15 minutes Installation time plus 5 min for german installation
  • edits to 4 php files, 1 template, 2 cssfiles, 1 themefile
  • 2 img files (buttons) included.


Screenshots: Screenshots for the MOD:

(Viewtopic / Posting)

Image

Demo URL:http://www.clochsliaph.de/neuesforum/vi ... 104&t=6017
Demo Username: testuser
Demo Password: testuser

Modification Download:http://www.clochsliaph.de/neuesforum/do ... hp?id=1220


Edit: Demourl refreshed, Newer upload edited. If you want to try the older version, please read the posting at ooc board.

This i my first complete little own mod, so please be patient with me ;) and: I dont try it with automod.
Testing comments are welcome!
Last edited by lugsciath on Thu Oct 21, 2010 9:32 pm, edited 8 times in total.

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Tue Apr 21, 2009 10:02 pm

It´s finished for now, but if you like someting special let´s talk about adds :) . I will give up to 2 weeks for alphatesting, because there is a little mod without special requirements or database changes. The code is my own, but a little inspired for install intructions and debugging by "quote2topic", the idea is based on the Mod "Lock Post on Report". In accordance with this mod both mods are a good working team, but LPIB will work as a standalonemod, too ;).



further Idea´s and Updates:

The buttons might be prettier, other Skins (Subsilver), a separate acp? page which contain something editable content and hints from admin/mod to the author of this locked post. Help and coauthoring is very welcome, if you like this idea.

Greetings and have fun

Uwe

User avatar
pascal24
Registered User
Posts: 60
Joined: Mon Apr 06, 2009 7:12 am
Location: Netherlands
Contact:

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by pascal24 » Wed Apr 22, 2009 10:19 am

Could you please use another langauge? (on the test board)(like english) I don't understand german, or whatever it is ;)

Thanks
-Pascal

Support will not be given via PM, MSN or e-mail

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Wed Apr 22, 2009 10:53 am

Just login with username & passwort (Username & Passwort). This Board uses as preferred language german, its a pure german board, but we have english guests, too. Edit: I made this Mod bilingual, but i cant change the board language for visitors from other countries - i´m sorry. Some parts may in german, i beg your pardon.

Solution:

Just login with testuser/testuser and you have it in english (testuser preferred language is english) ;), that why we have made the testuser profile for testing (greetings goes to our neighbors, the netherlands :) ).

For testing the mod opened a new topic in the testarea and -after looking at the editbutton- report your topic (it will locked automaticly). The editbutton will changed in "locked".

If somethings went wrong, just feel free to ask :)

Greetings

Uwe

PS: Excuse my rather bad english, i´m a german ;)

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Thu Apr 30, 2009 9:10 am

No comments on Alphatesting or from Community? There is nothing happend with this mod til the moment, no known bugs / errors. If there is nothing going on until next Week, the´re in Betastatus.


Greetings

Uwe

giZZy-2
Registered User
Posts: 10
Joined: Thu Aug 07, 2008 10:32 pm
Contact:

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by giZZy-2 » Thu Apr 30, 2009 11:02 am

Have you noticed your little errors?

Code: Select all

Warning: strtr() [function.strtr]: The second argument is not an array in /mnt/web4/31/85/5712785/htdocs/clochsliaph/neuesforum/includes/session.php on line 2128

Warning: strtr() [function.strtr]: The second argument is not an array in /mnt/web4/31/85/5712785/htdocs/clochsliaph/neuesforum/includes/session.php on line 2128

Warning: strtr() [function.strtr]: The second argument is not an array in /mnt/web4/31/85/5712785/htdocs/clochsliaph/neuesforum/includes/session.php on line 2128

Fatal error: template->_tpl_load_file(): File /message_body.html does not exist or is empty in /mnt/web4/31/85/5712785/htdocs/clochsliaph/neuesforum/includes/functions_template.php on line 63
Seems you have a bit of a mistake somewhere. This happens when trying to access any thread.

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [ALPHA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Fri May 01, 2009 10:25 am

These errors aren´t displayed by me? When did you got these errors? (Please post the link or make an screenshot)

Code: Select all

File /message_body.html does not exist or is empty in /mnt/web4/31/85/5712785/htdocs/clochsliaph/neuesforum/includes/functions_template.php on line 63
These file isn´t part of LPIB Mod, it is missing. Additional i have to say, that no changes where made by this mod in functions_template.php and in sessions.php also. I think it maybe comes from a other mod...

Did you refresh ACP->System->templates, themes and imageset? Did you refresh the cache also?

Are all files uploaded at the correct folders?

Please check it twice, this errormessage is quite curious ;)

Greetings

Uwe

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Sun May 03, 2009 3:34 pm

I have decided to take this mod into betastatus. If you found some bugs or if you have some suggestions /contributions feel free to post them :)

Greetings

Uwe

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Fri May 15, 2009 11:11 am

Hm ... is someone out there, who tested this mod?

User avatar
Ashley.S.
Registered User
Posts: 468
Joined: Mon Aug 04, 2008 6:01 pm
Location: Falmouth, Cornwall, UK
Name: Ashley .S.
Contact:

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by Ashley.S. » Sun May 24, 2009 6:23 pm

this mod looks interesting, I shall have to test it
Regards,
-Ashley.S. [ ProphpBB Free Forum Hosting Moderator ]

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Sat May 30, 2009 7:29 am

If someone gets trouble with this mod, we will find a solution. At the moment there are no known problems.

Sorry for my late answer, i´m just moving our webspace, but i will have keep an eye of this mod weekly.
Some of the error messages on my testaccount are produced by low php memory_limit ;) or coding/testing other mods.If someone like to develop Buttons in other languages: Go on for that ;)!

Greetings

Uwe

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Wed Jun 03, 2009 12:38 pm

If all seams right and no errors / bugs reportet i will go on for Making this mod to release state. It´s just a little modification, i know :)

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB) 1.0

Post by lugsciath » Thu Jun 18, 2009 9:07 am

Okay Folks,

one more week and i rename this mod as [RC], any Ideas for more features ?

mickeyr
Registered User
Posts: 76
Joined: Wed Jun 03, 2009 8:55 pm

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by mickeyr » Sat Jul 11, 2009 3:47 pm

The 'Closed' image is not being displayed on locked posts to anyone.
Board: Prosilver. 3.0.5

lugsciath
Registered User
Posts: 316
Joined: Tue Oct 02, 2007 11:12 am

Re: [BETA] Locked Post Indicator Button (LPIB)

Post by lugsciath » Fri Jul 17, 2009 9:51 am

Hey Mickey,

i've tried to register on your board, but i'm inactive. The login you send me didn't work and your security level at your board seams very exorbitant high, which is hard for new members in registration process ;)

Anyway...

Just a few hints to look for:

a) Did you copy the english picture in the right language area you used? Sometimes ist need it in more areas.

b) did you refreshed the cache? It's importend refreshing the templates, images and boardcache. Otherwise you see an empty space (without any cross) with a "hidden" link

c) Did you have some more extensions/mods ? If so , check the positions in the related files. Place the code for this mod at beginning of the other mods code (or at end if any).

If this doesnt work send me the code or let me take a look on it - and i will have a look after i' m activate ;).
For the late answer i beg your pardon, our own board/websites was moving this days to another provider.

Greetings

Uwe

Locked

Return to “[3.0.x] MODs in Development”