[RC][1.1.0-r2] FIND

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
Locked
User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] RSS Input

Post by Mess »

ravikum wrote:Hi,
Can we post youtube videos in our forum using this the youtube rss feed?
Thanks.
Also interested in this feature. ;)
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

Note2: This will be the last [DEV] version, after 30 days of release, updates with features freezed will be in [RC].
The next update will be focus on the parser code, to offer more for ATOM feed support.
Mess & ravikum

Some Atom feed provides media links in xmlns:media attribute, but current code isn't support yet.

My plan is to get this mod to the mod DB first, then add custom BBcode support if the demands is high. Let's get things done step by step. :)
ahuraeian
Registered User
Posts: 30
Joined: Sat Feb 16, 2008 2:26 am
Contact:

Re: [DEV] RSS Input

Post by ahuraeian »

great mod! tnx! ;)

but i have 2 problem:
1- this mod can't post images!(i think!)
2- when i wanna update a feed get a error about (curl cannot work when safemod is enable) and i cant edit server settings , is there another way for work this mod?!
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

When "safe mode" is ON, cURL can't be used!

According to php manual, fopen() may work if the UID of script and directory owner are the same.

I'll try to post test code later to check for safe_mode settings, it may not work for you but will show the related error in case.
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

php safe_mode fix

Open includes/rss_parser.php

Find

Code: Select all

		if (function_exists('curl_init'))
Changed to

Code: Select all

		if (function_exists('curl_init') && !ini_get('safe_mode'))
After the changes, cURL won't be used if safe_mode is ON.
I don't see any entry about file_get_contents in the safe_mode page above, so assumed this works in safe_mode.
ahuraeian
Registered User
Posts: 30
Joined: Sat Feb 16, 2008 2:26 am
Contact:

Re: [DEV] RSS Input

Post by ahuraeian »

ty ;)
and what about image problem?! :(
u can use this mod :http://www.phpbb.com/community/viewtopi ... &t=1965465
if u have problem with parse image!

w8 4 new update ! ;) ;)
EJFoundationadvocate
Registered User
Posts: 12
Joined: Wed Apr 07, 2010 11:58 pm

Re: [DEV] RSS Input

Post by EJFoundationadvocate »

I've got the newest version installed, got all my feeds added and verified, added the [RSS BOT] bots, and I've got all my feeds enabled from the RSS Import Settings in the ACP. How come the bots won't post?
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

ahuraeian wrote:ty ;)
and what about image problem?! :(
u can use this mod :http://www.phpbb.com/community/viewtopi ... &t=1965465
if u have problem with parse image!

w8 4 new update ! ;) ;)
Seems nobody like to read document... this mod supports embed html of <item> tags in RSS, but not support Atom <contents> tags which use xmlns:xxx attribute yet.
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

EJFoundationadvocate wrote:I've got the newest version installed, got all my feeds added and verified, added the [RSS BOT] bots, and I've got all my feeds enabled from the RSS Import Settings in the ACP. How come the bots won't post?
How can I know what's wrong with your installation while you don't provides any useful info?
EJFoundationadvocate
Registered User
Posts: 12
Joined: Wed Apr 07, 2010 11:58 pm

Re: [DEV] RSS Input

Post by EJFoundationadvocate »

well, I'm trying to get a bot to post from the BBC RSS feed. Could you be more specific and tell me what you need to hear?

edit: shit, I was just looking through my php settings and I see that allow_url_fopen has been disabled. I guess this solves why the bots weren't posting. thanks for your time
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

Document in post #2, please read before you post for support.
mutank
Registered User
Posts: 158
Joined: Mon Jan 05, 2009 4:47 pm
Location: Toronto, ON
Name: Dominic Struczynski
Contact:

Re: [DEV] RSS Input

Post by mutank »

Anyone know if it works with 3.0.5?
mutank
Registered User
Posts: 158
Joined: Mon Jan 05, 2009 4:47 pm
Location: Toronto, ON
Name: Dominic Struczynski
Contact:

Re: [DEV] RSS Input

Post by mutank »

I am trying to import the following feed which passed validation:

When I try to import that feed, (or any feed in that matter), this shows up:

Code: Select all

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /forums/includes/functions_find.php on line 229

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /forums/includes/functions_find.php on line 230
[phpBB Debug] PHP Notice: in file /includes/functions_find.php on line 35: include(./../includes/rss_parser.php) [function.include]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions_find.php on line 35: include() [function.include]: Failed opening './../includes/rss_parser.php' for inclusion (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php')

Fatal error: Class 'rss_parser' not found in /forums/includes/functions_find.php on line 104
User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [DEV] RSS Input

Post by PoPoutdoor »

Oops!

I put the bad function_find.php in the zip!

Please goto post#1 and download v0.3r1
mutank
Registered User
Posts: 158
Joined: Mon Jan 05, 2009 4:47 pm
Location: Toronto, ON
Name: Dominic Struczynski
Contact:

Re: [DEV] RSS Input

Post by mutank »

PoPoutdoor wrote:Oops!

I put the bad function_find.php in the zip!

Please goto post#1 and download v0.3r1
So, redownloading the files, and just replacing them with the newer ones will fix my issue?
Locked

Return to “[3.0.x] MODs in Development”