[RC][1.1.0-r2] FIND

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
BernhardSiwek
Registered User
Posts: 5
Joined: Wed Nov 13, 2013 7:44 pm

Re: [RC][1.1.0-r2] FIND

Post by BernhardSiwek » Thu Nov 14, 2013 8:04 pm

Sorry didn't want you to offend in any way. ;)

I couldn't understand why a working code was "optimized" to a non working version.
I installed now the older version which works like a charm and I can live with that circumstance that the bot is posting as a guest but showing up as a regular user when I click his name.

Thnx anyway for your try to lend me a helping hand through this.
Good luck in further developments and hopefully to a version for "green handed Dummies". :lol:

User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [RC][1.1.0-r2] FIND

Post by PoPoutdoor » Fri Nov 15, 2013 7:00 am

BernhardSiwek wrote:Sorry didn't want you to offend in any way. ;)

I couldn't understand why a working code was "optimized" to a non working version.
Not offended.

In reality, most of my clients ask for support without reading their contracts... When I told them what they asked for will be charged 'cos their request is way far outside the duty boundaries as written in the contract.

Guess what? They go around and pushing all parties trying to get what they wanted...

Sometimes, they come back and agreed to pay me triple market price to get the job done. BUT I only get my hand dirty for the extra money if their request is technically right and can be considered as extensions of my original contract.

BTW, my personal site have over a hundred feed sources set and imported daily compared with thirty for the old version. In terms of system load, import speed and error rates, I'm sure current version is far more workable and better than the old version.

I'm sorry for only able to read English and Chinese, not Greek, German or French. I only know the encoding issues related to feed source of other languages if users of this mod give me sufficient details of their problem that I can traced with.

messiahcide
Registered User
Posts: 11
Joined: Sat Jun 15, 2013 2:48 am

Re: [RC][1.1.0-r2] FIND

Post by messiahcide » Tue Dec 31, 2013 3:24 pm

After installing this mod, the first few feeds are working fine. A few are giving me some SQL errors.

Code: Select all

SQL ERROR [ mysqli ]

Incorrect string value: '\x80\x9CYou ...' for column 'post_text' at row 1 [1366]
Here are some of the feeds providing this error on import.

Code: Select all

http://ghosttraingames.com/feed/
http://www.fantasyflightgames.com/edge_asp/edge_rss_minisite.asp?emid=93
http://nightvale.libsyn.com/rss
I currently have three other feeds providing flawless execution. After reading the posts in this thread, I'm suspecting there is some sort of encoding issue? It's not exactly clear to me, but any assistance or points in the right direction would be very much appreciated.

User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [RC][1.1.0-r2] FIND

Post by PoPoutdoor » Wed Jan 08, 2014 12:19 pm

@messiahcide, I got all 3 feeds imported without error.

Will you mind post phpinfo page of yours?

messiahcide
Registered User
Posts: 11
Joined: Sat Jun 15, 2013 2:48 am

Re: [RC][1.1.0-r2] FIND

Post by messiahcide » Wed Jan 08, 2014 2:25 pm

Not at all. I appreciate you taking the time to help me out.

Here is everything copied and pasted.

edit: removed phpinfo

In this file i've included

Code: Select all

if (extension_loaded('simplexml')) {
  echo "Yes";
} else {
  echo "Not installed";
}

print_r(get_loaded_extensions());
to check extensions and to ensure simplexml was enabled on my shared hosting with godaddy.
Last edited by messiahcide on Fri Jan 17, 2014 10:31 pm, edited 1 time in total.

User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [RC][1.1.0-r2] FIND

Post by PoPoutdoor » Thu Jan 09, 2014 9:07 am

Seems nothing wrong on the php settings... should be about mysql data encoding setup. Since you have mysql 5.5, try changing to utf8mb4 will solve server side issues.

messiahcide
Registered User
Posts: 11
Joined: Sat Jun 15, 2013 2:48 am

Re: [RC][1.1.0-r2] FIND

Post by messiahcide » Thu Jan 16, 2014 7:06 pm

Thanks for your response. I've tried to change the encoding via phpmyadmin and have had no luck in effecting the error message. This is due to my own inexperience, I believe, though. I'm going to keep reading on the subject to see if there something i'm missing and I'll report back once I get a successful result.

User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [RC][1.1.0-r2] FIND

Post by PoPoutdoor » Thu Jan 16, 2014 8:04 pm

@messiahcide

You better start reading post after 1.1.0 released, code been rewritten and old post do not worth the time.

BTW, php 5.3 seems a little old... I'm using this mod with 5.4/5.5, maybe there is something not working well in SimpleXML for older versions. Ask your hosting if they can update to at least 5.4, try some other feed sources to verify if this is a feed issue.

messiahcide
Registered User
Posts: 11
Joined: Sat Jun 15, 2013 2:48 am

Re: [RC][1.1.0-r2] FIND

Post by messiahcide » Fri Jan 17, 2014 10:30 pm

I think the link in the first post here is wrong. I went to the github directly and got the most recent version, ran the upgrade path and all the associated files in /contrib, and after manually checking the edits were all good starting up again.

Server side I did switch over to php 5.4 as well.

Everything is working perfectly now!

For reference to those with the same issues, I did in total:
- Changed UTF collation
- Reinstalled the mod after grabbing the correct version from Github
- Made sure I had only 1 Post Bot
- Changed Php version to 5.4+

After all that, all the feeds are working as intended.

User avatar
PoPoutdoor
Registered User
Posts: 217
Joined: Fri Oct 31, 2008 2:58 pm
Contact:

Re: [RC][1.1.0-r2] FIND

Post by PoPoutdoor » Sat Jan 18, 2014 4:31 am

messiahcide wrote:I think the link in the first post here is wrong. I went to the github directly and got the most recent version, ran the upgrade path and all the associated files in /contrib, and after manually checking the edits were all good starting up again.
Just check the download link, also compared branches from github... the code is identical for master-develop-1.1.0r2 as reported on compare page, so download from master branch and release 1.1.02-r2 tag should be identical. :?:

I'm glad you made it works, and thanks for posting your summary.
- Changed MySQL UTF collation to utf8mb4, if and only if the version >=5.5
- Changed Php version to 5.4+


Locked

Return to “[3.0.x] MODs in Development”