[RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [BETA] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Tue Jan 26, 2010 6:16 pm

4_seven this is a question about your mod "First Topic [pic] on Forum Index v.0.0.3", i like to know this will apply to all forums or we can apply to particular forum, where we like to show the image on forum index.

For ex - In 10 forums we like to show image attachment only in 3 forums and not in others.

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [BETA] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by sevenalive » Wed Jan 27, 2010 7:29 am

Maybe you should post that in the proper thread. BTW, I am not 4_seven

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [BETA] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by 4_seven » Thu Jan 28, 2010 7:55 pm

ashras99 wrote:4_seven this is a question about your mod "First Topic [pic] on Forum Index v.0.0.3"
ask here..
http://www.phpbb.com/community/viewtopi ... 15&start=0
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Sat Jan 30, 2010 10:07 am

I am using highslide_with_gallery,js and diming of background is not working and if clicking outside the image.. then not closing the image window in Google Chrome 4 and Firefox 3.6

but working fine in Internet Explorer 8. Following tweak is also applied... is this known bug?

Code: Select all

<script type="text/javascript"> 
	hs.graphicsDir = 'highslide/graphics/';
	hs.align = 'center';
	hs.transitions = ['expand', 'crossfade'];
	//hs.outlineType = 'rounded-white';
	hs.fadeInOut = true;
	hs.dimmingOpacity = 0.85;
	hs.wrapperClassName = 'borderless floating-caption dark';
	//hs.captionEval = 'this.thumb.alt';
	hs.marginLeft = 100; // make room for the thumbstrip
	hs.marginBottom = 0;
	hs.marginTop = 0;
	//hs.numberPosition = 'caption';
	hs.lang.number = '%1/%2';
 
 
	// Add the controlbar
	if (hs.addSlideshow) hs.addSlideshow({
		//slideshowGroup: 'group1',
		interval: 4000,
		repeat: false,
		useControls: false,
		fixedControls: false,
		overlayOptions: {
			opacity: .85,
			position: 'top center',
			hideOnMouseOut: true
		}
	});
</script>
</head>

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by sevenalive » Sun Jan 31, 2010 4:52 am

I am not having those issues, also your mod is out of date, telling by your overall_header code. update the mod and see if that solves your issues.

User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Sun Jan 31, 2010 11:50 am

mod 4.1.8, is installed and after suggestions from mod developer. Installed one week before and my mod is out of date. Very funny.

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by sevenalive » Sun Jan 31, 2010 12:40 pm

Yes your out of date:

I suggest you double check your edits, and btw i am a contributor/author to this mod.

This is what your overall_header should look like (watermark portion optional)

Code: Select all

<!-- IF SCRIPT_NAME == "viewtopic" or SCRIPT_NAME == "posting" or SCRIPT_NAME == "ucp" or SCRIPT_NAME == "search" -->
<script type="text/javascript" src="{ROOT_PATH}/highslide/highslide-with-gallery.js"></script>
<link rel="stylesheet" type="text/css" href="{ROOT_PATH}/highslide/highslide.css" />      
<script type="text/javascript">
	hs.graphicsDir = 'highslide/graphics/';
	hs.align = 'center';
	hs.transitions = ['expand', 'crossfade'];
	hs.fadeInOut = false;
	hs.dimmingOpacity = 0.75;
	hs.wrapperClassName = 'borderless';
	hs.captionOverlay.hideOnMouseOut = true;
	hs.marginLeft = 85;
	hs.marginBottom = 0;
	hs.marginTop = 0;
	hs.numberPosition = 'caption';

	// Adding the Watermark
	hs.registerOverlay({
	html: '<div class="watermark" onclick="return hs.close(this)" title="Close" style="width:120px; height: 120px; background: url(highslide/graphics/watermark.png)"></div>',
	hideOnMouseOut: true,
	opacity: 0.4,
	repeat: false,
	position: 'top right',
	fade: 2 // fading the semi-transparent overlay looks bad in IE
	})

	// Adding the controlbar
	if (hs.addSlideshow) hs.addSlideshow({
		//slideshowGroup: 'group1',
		interval: 3000,
		repeat: false,
		useControls: true,
		fixedControls: true,
		overlayOptions: {
			opacity: .6,
			position: 'top center',
			hideOnMouseOut: true
		},
		thumbstrip: {
			position: 'middle left',
			mode: 'vertical',
			relativeTo: 'viewport'
		}
	});
</script>
<!-- ENDIF -->
As i stated before, your edits may be incorrect/outdated, i am using FF 3.6 and it works on 2 phpBB installs in all browsers fine. Double check your edits, clear the phpBB cache and clear your browser cache. If your still having problems, then post back. Make sure you reupload the highslide folder too.
Last edited by sevenalive on Sun Jan 31, 2010 12:53 pm, edited 2 times in total.

User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Sun Jan 31, 2010 12:50 pm

yes, you are right. I installed the mod from scratch and now dimming starts working.

But my thumbnail, starts resizing to small size. In ACP i set "Maximum thumbnail width in pixel:" to 1100px

so i want that setting dont change... but its resizing to small thumbnail, please tell me what setting to change in CSS to move my thumbnails to again 1100 pixels wide and height as per aspect ratio.


secondly i am not using the controlbar and watermark, so i can remove the following code from overall_header.

Code: Select all

// Adding the Watermark
	hs.registerOverlay({
	html: '<div class="watermark" onclick="return hs.close(this)" title="Close" style="width:120px; height: 120px; background: url(highslide/graphics/watermark.png)"></div>',
	hideOnMouseOut: true,
	opacity: 0.4,
	repeat: false,
	position: 'top right',
	fade: 2 // fading the semi-transparent overlay looks bad in IE
	})

	// Adding the controlbar
	if (hs.addSlideshow) hs.addSlideshow({
		//slideshowGroup: 'group1',
		interval: 3000,
		repeat: false,
		useControls: true,
		fixedControls: true,
		overlayOptions: {
			opacity: .6,
			position: 'top center',
			hideOnMouseOut: true
		},

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by sevenalive » Sun Jan 31, 2010 12:57 pm

1100px is too big for a thumbnail, defeats the purpose of highslide and causes more load and bandwidth on your server and slower page loads. You should have the thumbnail to 320px. Also remember there are plenty of people still using 1024x768 or 1280x800 screen resolutions, so they can't even see the complete thumbnail without scrolling. A thumbnail over 400px simply isn't a thumbnail anymore. Also if a picture is less than the acp thumbnail size there will not be a highslide popup.

I believe the CSS edit you want is described in the FAQ post on the first page
.highslide img {
height: 180px; /*aprox height If ACP->Attachment-> thumbnail width=320px */
Can you provide a screenshot of your problem. Please note though, any attachments and their thumbnails will not change when you change the acp setting, it only affects new uploads.

ACP setting 320px for max thumbnail
upload image 1 - thumbnail 320px
change max thumbnail size to 1100px;
upload image 2 - thumbnail size 1100px;
image 1 thumbnail will still be 320 unless you reupload the image!

User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Sun Jan 31, 2010 1:16 pm

Actually this css setting, resize the thumbnail only for view...

.highslide img {
height: 170px;


As i said, in ACP i set the 1100px as width but this setting resize my image to 170px in height and width as per aspect ratio.

Is that possible that we remove such setting from CSS and fully controlled by the ACP thubnail size setting?

Through screenshot you cant understand, because this is not a problem which can understand through screenshot.

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Sun Jan 31, 2010 3:53 pm

.highslide img {
height: 170px;
This tweak is mainly if you also want small thumbnails side by side (see screenshots in second post)

height: 170px; is NOT supposed to be in 4.1.8 .css by default :shock:
I will remove at once. Its a tweak!

Thanks for reporting ;)

I have corrected in download

If you dont have thumbs side by side
!!!!:
Open highslide.css
find:

Code: Select all

.highslide img {   
    height: 170px;
    border: 2px solid silver;
}
REMOVE: height: 170px;

User avatar
ashras99
Registered User
Posts: 441
Joined: Mon Dec 19, 2005 9:09 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by ashras99 » Mon Feb 01, 2010 2:28 am

Thanks.

I think you must add a watermark feature which permanently embeds a watermark on the images, maybe text watermark.

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by sevenalive » Mon Feb 01, 2010 3:36 am

That would not be possible with this mod, in order to do that you would need another mod.

thelane
Registered User
Posts: 5
Joined: Tue Jun 22, 2010 5:57 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by thelane » Tue Jun 22, 2010 5:58 am

What if I am not using the Silver themes? Can this be installed with any theme?

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Tue Jun 22, 2010 11:43 pm

There should be no problem installing this mod with other themes ;)

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 22 guests

cron