[RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
Locked
thelane
Registered User
Posts: 5
Joined: Tue Jun 22, 2010 5:57 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by thelane » Wed Jun 23, 2010 12:30 am

Too late. I went with Lightbox2 because I needed something quick. Maybe implement this some other time. Good to know now anyway.

cleftangel
Registered User
Posts: 61
Joined: Sat Jun 12, 2010 2:38 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by cleftangel » Sat Jun 26, 2010 8:25 am

It's a great mod,

I have replaced my img bbcode with it so default img is being done by highslide now also,

But my question is....

How do I increase the thumbnail size of the picture as you see it in the post, before clicking it for the slideshow?
I want the thumbnail size to be original due to the fact we're mainly running SOTW But I like the effect of the hs.
right now it is distorting my thumbnails as you will see the floating image is correct size but the background images are distorted
See attached screenshot:

Image

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Sat Jun 26, 2010 3:46 pm

Thumbnails from remote img with bbcode, requires a thumbnail/resize mod....Maybe Look/try this mod:

http://4seven.kilu.de/forum/phpbb3/view ... ?f=8&t=387

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Sun Sep 26, 2010 6:13 pm

This mod is very cool - I like it very much. I'm testing it here:

http://www.mcweton.net/farmerforum/view ... p=202#p202

I have a couple of questions and comments, though...

1) I'm confused now about what ultimately decides the size of the thumbnail in the attachment box. Independent of what I set in ACP -> Attachments -> thumbnail size (currently set to 320px), it appears that the size of the thumbnail is 240px. What determines that? (It also seems to set the size of inline thumbnails.)

2) Related to this - I have a couple of "portrait" mode images in my gallery, but the thumbnail still occupies the same real estate as a "landscape" thumbnail. I applied your "thumbnail height tweak" (height: 180 px; (320/4)*3 - 25%), but it doesn't seem to take.

3) On the topic of inline - is there any way to get the gallery effect with thumbnails when they are set inline? What I like about inline is that it has a crisper look to it - they aren't segregated into a white box - and I can control their placement. If I want a certain order to my thumbnails, I must be careful to insert them in the exact reverse order, and I can't change my mind and insert or reorder (although, perhaps there's a mod for this).

4) Is there a way, when launching the Highslide viewer, to position the comment in an area under the image? Depending on what's in the image, the comment may be unreadable.

5) When I attach a .wmv video clip - playable by default with Windows Media Player in the absence of Highslide - the viewer skips over it. Is there a way to get it to recognize it, and play it?

Thanks for your hard efforts - this really is a nifty mod!

Dan

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Mon Sep 27, 2010 11:03 am

shortmort37 wrote:This mod is very cool - I like it very much. I'm testing it here:

http://www.mcweton.net/farmerforum/view ... p=202#p202

I have a couple of questions and comments, though...

1) I'm confused now about what ultimately decides the size of the thumbnail in the attachment box. Independent of what I set in ACP -> Attachments -> thumbnail size (currently set to 320px), it appears that the size of the thumbnail is 240px. What determines that? (It also seems to set the size of inline thumbnails.)

2) Related to this - I have a couple of "portrait" mode images in my gallery, but the thumbnail still occupies the same real estate as a "landscape" thumbnail. I applied your "thumbnail height tweak" (height: 180 px; (320/4)*3 - 25%), but it doesn't seem to take.

3) On the topic of inline - is there any way to get the gallery effect with thumbnails when they are set inline? What I like about inline is that it has a crisper look to it - they aren't segregated into a white box - and I can control their placement. If I want a certain order to my thumbnails, I must be careful to insert them in the exact reverse order, and I can't change my mind and insert or reorder (although, perhaps there's a mod for this).

4) Is there a way, when launching the Highslide viewer, to position the comment in an area under the image? Depending on what's in the image, the comment may be unreadable.

5) When I attach a .wmv video clip - playable by default with Windows Media Player in the absence of Highslide - the viewer skips over it. Is there a way to get it to recognize it, and play it?

Thanks for your hard efforts - this really is a nifty mod!

Dan
RoadRash from the Highslide support team helped me with (4) - and says that (5) will only work when launched within it's own page... If instead of wmv, I work with flv (native to hs) - I wonder if there's a way I can invoke Highslide with BBCode?

Dan

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Mon Sep 27, 2010 4:22 pm

This mod is very cool - I like it very much. I'm testing it here:
thanks! ;)
1)
depend on your choise of same height or not.If you altered .highslide img in highslide/highslide.css, this overrides size set in ACP.Inline pics will still be 320px wide.
2) Related to this - I have a couple of "portrait" mode images in my gallery, but the thumbnail still occupies the same real estate as a "landscape" thumbnail.
This is how it is now sadly (If you added a new ".highslide-comment" entry)... I have really tried to crack that one.I also like the comment under the thumb, but i cant figure out how to get the commentbox not to be bigger than the thumb. :mrgreen:
see here on my webpage, i have same issue, but living with it:
http://www.parafun.dk/paragliding/viewtopic.php?t=315
3) On the topic of inline - is there any way to get the gallery effect with thumbnails when they are set inline?
Gallery(highslide mod) also works with inline pics
If I want a certain order to my thumbnails, I must be careful to insert them in the exact reverse order, and I can't change my mind and insert or reorder
yep your right there.sadly

yours jonni

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Mon Sep 27, 2010 4:42 pm

jonnilaumann wrote:
shortmort37 wrote:3) On the topic of inline - is there any way to get the gallery effect with thumbnails when they are set inline?
Gallery(highslide mod) also works with inline pics
Sorry, my fault for not being clear. What I mean is, can you arrange the inline thumbs horizontally in a gallery, much as you do with thumbs within the attachment box? Here's another example:

http://www.mcweton.net/farmerforum/view ... p=201#p201

Highslide does indeed work - but it would be neater if I could launch it from a gallery like yours.

Thanks
Dan

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Mon Sep 27, 2010 4:47 pm

jonnilaumann wrote:
shortmort37 wrote:2) Related to this - I have a couple of "portrait" mode images in my gallery, but the thumbnail still occupies the same real estate as a "landscape" thumbnail.
This is how it is now sadly (If you added a new ".highslide-comment" entry)... I have really tried to crack that one.I also like the comment under the thumb, but i cant figure out how to get the commentbox not to be bigger than the thumb. :mrgreen:
see here on my webpage, i have same issue, but living with it:
http://www.parafun.dk/paragliding/viewtopic.php?t=315
Now I understand - I actually think it doesn't look that bad, given that you are able to arrange for all thumbs to have the same height. Perhaps it there were a way to center any thumb it might look better? i.e., centering an image 320 px wide in a region of 320 px wouldn't affect it, but an image 240 px wide would be affected. Dunno! Wish I could program!

Thanks much
Dan

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Mon Sep 27, 2010 7:56 pm

shortmort37 wrote:
jonnilaumann wrote:
shortmort37 wrote:3) On the topic of inline - is there any way to get the gallery effect with thumbnails when they are set inline?
Gallery(highslide mod) also works with inline pics
Sorry, my fault for not being clear. What I mean is, can you arrange the inline thumbs horizontally in a gallery, much as you do with thumbs within the attachment box? Here's another example:

http://www.mcweton.net/farmerforum/view ... p=201#p201

Highslide does indeed work - but it would be neater if I could launch it from a gallery like yours.

Thanks
Dan
BTW, in the absence of any possibility of achieving a gallery effect with inline placement of attachments - I posted a mod request for reordering capability within an attachment window:

http://www.phpbb.com/community/viewtopi ... #p12869839

Dan

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Tue Sep 28, 2010 1:50 am

There are several attributes in styles/.../theme/content.css that pertain to inline thumbnails, as opposed to within an attachbox:

Code: Select all

/* Inline image thumbnails */
div.inline-attachment dl.thumbnail, div.inline-attachment dl.file {
	display: block;
	margin-bottom: 4px;
}

div.inline-attachment p {
	font-size: 100%;
}

dl.file {
	font-family: Verdana, Arial, Helvetica, sans-serif;
	display: block;
}

dl.file dt {
	text-transform: none;
	margin: 0;
	padding: 0;
	font-weight: bold;
	font-family: Verdana, Arial, Helvetica, sans-serif;
}

dl.file dd {
	color: #666666;
	margin: 0;
	padding: 0;	
}

dl.thumbnail img {
	padding: 3px;
	border: 1px solid #666666;
	background-color: #FFF;
}

dl.thumbnail dd {
	color: #666666;
	font-style: italic;
	font-family: Verdana, Arial, Helvetica, sans-serif;
}

.attachbox dl.thumbnail dd {
	font-size: 100%;
}

dl.thumbnail dt a:hover {
	background-color: #EEEEEE;
}

dl.thumbnail dt a:hover img {
	border: 1px solid #d2d2d2;
}
I tried bombarding these with the changes previously noted for more pictures side-by-side in the .attachbox sections, to no avail.

Is there a way to get inline thumbnails to display horizontally, instead of inline? Even if I assumed, e.g., the display resolution could accomodate three thumbs per row?

Dan

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Tue Sep 28, 2010 9:14 pm

Why dont you just use the attachmentbox and remove the white background, and make a new post for each group off your pictures(instead of inline).?
Perhaps it there were a way to center any thumb it might look better?
Cool Idea, i will try to do that on my page
Is there a way to get inline thumbnails to display horizontally, instead of inline?
surely..i will try to see what can be done, but my php coding skills isnt that good, like you I mostly just try changing code. I know there is some BBcode Mod that lets you place inline picture anywhere, but thats another way to do it.
posted a mod request for reordering capability within an attachment window:
cool, that could help alot...Im still waiting for a multiple php upload Mod. I have tried them all but with a rented remote server with crappy "php_value memory_limit" no mod does it.....Even tried to develope myself but lack of skills stopped me..but my good supergeek freind 4seven is developing in this moment..
http://4seven.kilu.de/forum/phpbb3/view ... ?f=8&t=581

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Tue Sep 28, 2010 9:36 pm

jonnilaumann wrote:Why dont you just use the attachmentbox and remove the white background, and make a new post for each group off your pictures(instead of inline).?
Because inline allows you to control the placement, regardless of the order in which you upload. In the absence of a mod to rearrange placement within an attachment box, it's very cumbersome to prearrange a gallery (especially since you have to do it in reverse order).

Dan

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Tue Sep 28, 2010 9:43 pm

jonnilaumann wrote:... my good supergeek freind 4seven is developing in this moment..
http://4seven.kilu.de/forum/phpbb3/view ... ?f=8&t=581
OK. Well, I can see I've either got to improve my php skills, or improve my Deutsch! Was soll ich tun, was soll ich tun... :twisted:

Dan

User avatar
jonnilaumann
Registered User
Posts: 56
Joined: Mon Nov 30, 2009 12:32 am

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by jonnilaumann » Wed Sep 29, 2010 9:36 pm

multiple upload....maybe in 3-4 month to test.
http://www.phpbb.com/community/viewtopi ... &t=2101263

User avatar
shortmort37
Registered User
Posts: 347
Joined: Sat Aug 26, 2006 8:40 pm

Re: [RC] Highslide 4.1.8 Zoom/Slideshow/Watermark (Gallery)

Post by shortmort37 » Fri Oct 01, 2010 1:39 pm

OK - I've done a little spelunking, and here's what I've found. I posted two pix using Jonni's Mod, without placing them inline - and snagged the rendered html:

Code: Select all

<div class="content">this is some text</div> 
<dl class="attachbox"> 
<dt>Attachments</dt> 

<dd> 
<div class="highslide-gallery"> 
<a href=...(image 1 referenced here) </a> 
<div class="highslide-caption"></div> 
</div> 
<div class="highslide-comment"></div> 
</dd> 

<dd> 
<div class="highslide-gallery"> 
<a href=...(image 2 referenced here) </a> 
<div class="highslide-caption"></div> 
</div> 
<div class="highslide-comment"></div> 
</dd> 

</dl> 
</div> 
Then I went back and placed them inline:

Code: Select all

<div class="content">this is some text<br />
<div class="inline-attachment"> 
<div class="highslide-gallery"> 
<a href=...(image 1 referenced here) </a> 
<div class="highslide-caption"></div> 
</div> 
<div class="highslide-comment"></div> 
</div><br /><div class="inline-attachment"> 
<div class="highslide-gallery"> 
<a href=...(image 2 referenced here) </a> 
<div class="highslide-caption"></div> 
</div> 
<div class="highslide-comment"></div> 
</div></div> 
	
</div> 

And now I see - this is what is causing the inline attachments to break in separate rows:
...
</div><br /><div class="inline-attachment">

So I need to be able to 1) modify the style sheet (content.css?) to change this behavior; and 2) actually do insert a break, after 3 or 4 thumbnails.

Any takers?! :mrgreen:

Dan

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 16 guests