[DEV] Mobile phpBB 3

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
Locked
rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile Online phpBB 3/phpBB 2

Post by rickey29 » Sat Aug 10, 2013 12:02 pm

cossielee wrote:Looks like a nice mobile style but i think users should be made more aware of this:
From Bali Release Load 1.0, each web site will have 10 megabyte free traffic each day on Flx service; after that, I will ask for 0.01 U.S. dollar per megabyte for any additional traffic. The detail threshold and/or cost may change when I apply this plan.
From the coming release/load, each web site installed Mobile Online phpBB 3 / phpBB 2 will have 10 megabyte free traffic each day.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile Online phpBB 3/phpBB 2

Post by rickey29 » Sat Dec 21, 2013 9:38 am

Mobile Online phpBB3 Ducie release load 2.1: http://flexplat.com/?q=mobile-online-phpbb3 , and Mobile Online phpBB2 Capri release load 2.1: http://flexplat.com/?q=mobile-online-phpbb2

New feature/bug fix: theme updating

Highlight: The traffic limitation changes to one megabyte per day from this load.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: Mobile phpBB 3

Post by rickey29 » Fri Jan 16, 2015 2:43 am

I change this module into free and open source package. I hope this is what you want. For more information, please go to: http://flexplat.com/?q=mobile-phpbb-3

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Thu Feb 12, 2015 7:17 pm

Hi,

I've installed your your MOD on my forum.

I get this error:

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Image

Thanks for your help

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Fri Feb 13, 2015 12:39 am

fanmail wrote:Hi,

I've installed your your MOD on my forum.

I get this error:

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Image

Thanks for your help
Hi fanmail,

I am sorry for the inconvenience, I find the same error message in my environment. I will delivery an updating version in three days.

If there is any other issue, please let me know, I will try to help.

Rickey

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Fri Feb 13, 2015 11:59 pm

rickey29 wrote:
fanmail wrote:Hi,

I've installed your your MOD on my forum.

I get this error:

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Imageset misses “en” localisation
» jQuery-Mobile smartphone

Image

Thanks for your help
Hi fanmail,

I am sorry for the inconvenience, I find the same error message in my environment. I will delivery an updating version in three days.

If there is any other issue, please let me know, I will try to help.

Rickey
Hi fanmail,

I upload a bug fix version, you can download it from: https://github.com/rickey29/mobile-phpbb-3

For your current installation, you need not un-install and then re-install my module, you can do following simple updating:

COPY
$phpbb_root_path/styles/prosilver/imageset/en/*.*
TO
$phpbb_root_path/styles/feature_phone/imageset/en/*.*

COPY
$phpbb_root_path/styles/prosilver/imageset/en/*.*
TO
$phpbb_root_path/styles/jquery_mobile_smartphone/imageset/en/*.*

COPY
$phpbb_root_path/styles/prosilver/imageset/en/*.*
TO
$phpbb_root_path/styles/jquery_mobile_tablet/imageset/en/*.*

Then, de-active my mobile styles, and re-activate them.

The "imageset/en/*.*" are mandatory for new styles. I do not use these directories and/or files; while, without them, the error messages come.

Any progress and/or problem, please let me know.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Sat Feb 14, 2015 5:16 pm

Hi rickey29 :)

Thank you so much! It fixed the problem :D

I found another problem:

If you create a "Custom profile fields" (Users and Groups >> Custom profile fields ) and check "Display on registration screen" and "Required field"

Image

The field is not on the registration page and registration is not possible

Tablet:

Image

Desktop:

Image

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sat Feb 14, 2015 11:19 pm

fanmail wrote:Hi rickey29 :)

Thank you so much! It fixed the problem :D

I found another problem:

If you create a "Custom profile fields" (Users and Groups >> Custom profile fields ) and check "Display on registration screen" and "Required field"

Image

The field is not on the registration page and registration is not possible

Tablet:

Image

Desktop:

Image
Hi fanmail,

Sorry again for the inconvenience. Look like this is a complex problem, please wait one week for my improvement. If I can not make it in one week, I will reply here to let you know the new duration estimation.

Thanks for your patient,

Rickey

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Mon Feb 16, 2015 11:39 am

fanmail wrote:Hi rickey29 :)

Thank you so much! It fixed the problem :D

I found another problem:

If you create a "Custom profile fields" (Users and Groups >> Custom profile fields ) and check "Display on registration screen" and "Required field"

Image

The field is not on the registration page and registration is not possible

Tablet:

Image

Desktop:

Image
Hi fanmail,

We need some communication. I am not familiar with the usage of "Custom profile fields". (I never use it before.) I will describe my understanding, please correct me if I am wrong.

My understanding is, even the end user inputs wrong answer in the custom profile field, he/she can still register successfully, right? You, as web administer, will manually check his/she answer, and delete his/her account if the answer is wrong, right?

Thanks for your support.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Mon Feb 16, 2015 1:49 pm

My understanding is, even the end user inputs wrong answer in the custom profile field, he/she can still register successfully, right?
No. The user has to give the correct answer :|

You, as web administer, will manually check his/she answer, and delete his/her account if the answer is wrong, right?
No :|

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Tue Feb 17, 2015 1:47 am

fanmail wrote:
My understanding is, even the end user inputs wrong answer in the custom profile field, he/she can still register successfully, right?
No. The user has to give the correct answer :|

You, as web administer, will manually check his/she answer, and delete his/her account if the answer is wrong, right?
No :|
In your case/example, you set the "Lowest allowed number" as 5 in "Custom profile filed" "Profile type specific options", and "Highest allowed number" as 5, right? So, end user can not register successfully unless he/she inputs the right answer 5, right?

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Wed Feb 18, 2015 2:10 am

rickey29 wrote:
fanmail wrote:Hi rickey29 :)

Thank you so much! It fixed the problem :D

I found another problem:

If you create a "Custom profile fields" (Users and Groups >> Custom profile fields ) and check "Display on registration screen" and "Required field"

Image

The field is not on the registration page and registration is not possible

Tablet:

Image

Desktop:

Image
Hi fanmail,

Sorry again for the inconvenience. Look like this is a complex problem, please wait one week for my improvement. If I can not make it in one week, I will reply here to let you know the new duration estimation.

Thanks for your patient,

Rickey
Hi fanmail,

I submit a new version: https://github.com/rickey29/mobile-phpbb-3 , hope it solves your problem.

For your current installation, you need not un-install and then re-install my module. There is only three template files updated:
$phpbb_root_path/styles/feature_phone/template/ucp_register.html
$phpbb_root_path/styles/jquery_mobile_smartphone/template/ucp_register.html
$phpbb_root_path/styles/jquery_mobile_tablet/template/ucp_register.html

You can upload these three files to your web site, then de-activate my three styles, and re-active them, so the "Custom profile fields" will be displayed.

Good luck. Any progress and/or problem, please let me know.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Fri Feb 20, 2015 4:08 pm

Hi again :)

I downloaded the new version from here: https://github.com/rickey29/mobile-phpb ... master.zip

then uploaded the new ucp_register.html files & Deactivate/Activate each style but it does not work :|

Image

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sun Feb 22, 2015 1:53 am

fanmail wrote:Hi again :)

I downloaded the new version from here: https://github.com/rickey29/mobile-phpb ... master.zip

then uploaded the new ucp_register.html files & Deactivate/Activate each style but it does not work :|

Image
Hi fanmail,

Sorry for the later response.

I check my GitHub and the package you download, they have the right updating files.

Let's try another way to active the new change. Please go to your site "cache" directory, find following three file(s):
-- tpl_feature-phone_ucp_register.html.php
-- tpl_jquery-mobile-smartphone_ucp_register.html.php
-- tpl_jquery-mobile-tablet_ucp_register.html.php
delete them, and do testing again. There may be only two files in your system: "tpl_feature-phone_ucp_register.html.php" is missing if there is no feature phone accesses your web site. (Do NOT use this way in phpBB 3.1 system! It only works in phpBB 3.0 .)

Any problem and/or progress, please let me know.

Thanks for your support.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Sun Feb 22, 2015 11:28 pm

It does not work :|

With the tablet version i've got an "error loading page"
Last edited by fanmail on Tue Feb 24, 2015 4:07 pm, edited 2 times in total.

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 11 guests