[DEV] Mobile phpBB 3

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sun Mar 15, 2015 3:16 am

rickey29 wrote:Hi fanmail,

I am blocked by the hash issue. The solution: https://github.com/ToddThomson/jQuery-M ... age-Widget is not suitable for our problem. I will do more digging in jQuery user community.

Sorry for the delay.

Rickey
Hi fanmail,

Regarding the hash issue, I get inspiration from following post: http://stackoverflow.com/questions/1551 ... ot-loading. I improve my code and make a testing posting in my demo: http://mphpbb3.flexplat.com/viewtopic.php?f=2&t=18. Please let me know this is what you want.

Thanks,

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Mon Mar 16, 2015 10:47 pm

fanmail wrote:Hi :)

Your URL http://www.flexplat.com/mphpbb3/viewtopic.php?f=2&t=2 redirects to http://flexplat.com/mphpbb3/viewtopic.php?f=2&t=2 so it does not work to reproduce the problem.

I installed a fresh copy of phpBB3 with your MOD on http://net16.net/

and the problem is the same :|

http://2000.net16.net/phpBB3/viewtopic. ... =5&f=2&t=2
http://2000.net16.net/test.php

fanmnail
What about this problem? ;)

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Thu Mar 19, 2015 2:02 am

Hi fanmail,

Regarding the "Who is Donald Duck's Girlfriend? Minnie or Daisy Duck" during register issue, the root cause is I miss the "captcha_qa" template. I will do it, together with the "sendpassword" template.

Any progress, I will let you know. Thanks for your patient.

Rickey

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Thu Mar 19, 2015 2:11 am

fanmail wrote:
fanmail wrote:Hi :)

Your URL http://www.flexplat.com/mphpbb3/viewtopic.php?f=2&t=2 redirects to http://flexplat.com/mphpbb3/viewtopic.php?f=2&t=2 so it does not work to reproduce the problem.

I installed a fresh copy of phpBB3 with your MOD on http://net16.net/

and the problem is the same :|

http://2000.net16.net/phpBB3/viewtopic. ... =5&f=2&t=2
http://2000.net16.net/test.php

fanmnail
What about this problem? ;)
Hi fanmail,

I still think this is caused by some web server setting in your environment.

While, during my internal/external hash url improvement, I add an attribute to remove ajax function for each url within post message. I hope this hash improvement can solve our internal url not working issue we are talking about.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Thu Mar 19, 2015 8:20 pm

What about the "I forgot my password" page? :mrgreen:
ucp.php?mode=sendpassword

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sat Mar 21, 2015 12:04 am

fanmail wrote:What about the "I forgot my password" page? :mrgreen:
ucp.php?mode=sendpassword
I have completed the "forget password" template, I am testing. I will provide it to you in the coming version.

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Sat Mar 21, 2015 1:41 pm

Your MOD does not pass the Google Mobile-Friendly Test :geek:

https://www.google.com/webmasters/tools ... lat.com%2F

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sun Mar 22, 2015 7:28 am

Hi fanmail,

I upload the new package to GitHub . Hope this is what you are waiting for.

During updating, one thing you should take care:

Code: Select all

OPEN
----------------
viewtopic.php

FIND
----------------
		'L_IGNORE_POST'		=> ($row['hide_post']) ? sprintf($user->lang['POST_BY_FOE'], get_username_string('full', $poster_id, $row['username'], $row['user_colour'], $row['post_username']), '<a href="' . $viewtopic_url . "&p={$row['post_id']}&view=show#p{$row['post_id']}" . '">', '</a>') : '',
	);

ADD AFTER
----------------
	if ( defined('MPHPBB3') )
	{
		m_update_postrow($postrow);
	}
In previous version, it is:

Code: Select all

ADD AFTER
----------------
	if ( defined('MPHPBB3') )
	{
		m_update_post_row($post_row);
	}
It should be "m_update_postrow($postrow);", not "m_update_post_row($post_row);". It is a bug, it is my fault.

Any progress and/or problem, please let me know.

Rickey

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Sun Mar 22, 2015 7:29 am

fanmail wrote:Your MOD does not pass the Google Mobile-Friendly Test :geek:

https://www.google.com/webmasters/tools ... lat.com%2F
I did not do this test before. I will investigate.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Mon Mar 23, 2015 12:51 am

rickey29 wrote:
fanmail wrote:Your MOD does not pass the Google Mobile-Friendly Test :geek:

https://www.google.com/webmasters/tools ... lat.com%2F
I did not do this test before. I will investigate.
Hi fanmail,

I find the problem. Please do following updating:

Code: Select all

OPEN
http://yoursite.com/mobile/index.php

FIND
if ( $this->data['is_bot'] || defined('ADMIN_START') || defined('IN_ADMIN') )

REPLACE WITH
if ( defined('ADMIN_START') || defined('IN_ADMIN') )
Just remove the "$this->data['is_bot']" part, so Google Bot can get into our code. Any progress and/or problem, please let me know.

Good luck.

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Tue Mar 24, 2015 10:43 am

Problem with quote (color):

Desktop:
Image

Mobile:

Image

Tablet:

Image

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Wed Mar 25, 2015 2:33 am

fanmail wrote:Problem with quote (color):

Desktop:
Image

Mobile:

Image

Tablet:

Image
Hi fanmail,

Do you mean you want each quote have a different background color?

Thanks,

Rickey

fanmail
Registered User
Posts: 190
Joined: Fri Mar 18, 2005 2:33 pm

Re: [DEV] Mobile phpBB 3

Post by fanmail » Wed Mar 25, 2015 9:35 am

It would improve readability quite a bit ;)

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Wed Mar 25, 2015 12:14 pm

fanmail wrote:It would improve readability quite a bit ;)
OK, I will investigate and try to improve.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile phpBB 3

Post by rickey29 » Tue Mar 31, 2015 8:33 am

rickey29 wrote:
fanmail wrote:It would improve readability quite a bit ;)
OK, I will investigate and try to improve.
Hi fanmail,

Check if this is what you want: http://mphpbb3.flexplat.com/viewtopic.php?f=2&t=19 . If yes, you can download the code from https://github.com/rickey29/mobile-phpbb-3

Any problem, please let me know.

Rickey

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 19 guests