[BETA] Like button for Facebook

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
User avatar
Alien_Time
Registered User
Posts: 389
Joined: Fri Dec 31, 2010 7:08 am

Re: [ALPHA] Like button for Facebook

Post by Alien_Time » Fri Aug 12, 2011 12:53 am

Hi,

just an update...The mod is working correctly..

In order for it to work, I just need to make sure that I have the correct setting in my application in facebook.

Also, another thing, this wont work in locahost. Plainly because i think the localhost url would not match the url in facebook application and thats why it causes the error..

Nice mod..very useful indeed since a lot of people use facebook..its crazy out there! :D

Tim1969
Registered User
Posts: 243
Joined: Thu Apr 07, 2011 10:28 pm

Re: [ALPHA] Like button for Facebook

Post by Tim1969 » Thu Oct 20, 2011 9:29 am

I have got it working- sort of! It displays the button fine but when I like something it posts the who forum url to the wall, not the topic etc.....

What have I done wrong and what is this about a facebook application?

Cheers

knight.rider69
Registered User
Posts: 177
Joined: Fri Aug 08, 2008 5:44 am

Re: [ALPHA] Like button for Facebook

Post by knight.rider69 » Sat Dec 24, 2011 1:44 am

i wonder this mod will it be still developing ?? :?

packerstud
Registered User
Posts: 113
Joined: Fri Jul 08, 2011 5:29 am

Re: [ALPHA] Like button for Facebook

Post by packerstud » Sat Dec 24, 2011 3:21 am

Just installed on upgraded 3.0.9. I up graded from 3.0.8.
I used xFBml verision.

Everything works well.

I'm trying to figure out how to stop the pictures of the people who LIKED from showing.

User avatar
soumik
Registered User
Posts: 486
Joined: Tue Nov 06, 2007 7:27 pm
Contact:

Re: [ALPHA] Like button for Facebook

Post by soumik » Sat Dec 24, 2011 3:35 am

packerstud wrote:I'm trying to figure out how to stop the pictures of the people who LIKED from showing.
Read the notes in my first pst.
soumik wrote: Notes:
In order to disable the display of faces, follow these steps :

Open /styles/prosilver/template/viewtopic_body.html :
Find :

Code: Select all

<div style="margin-bottom:4px"><fb:like href="{U_FB}"></fb:like></div>  
Inline find :

Code: Select all

href="{U_FB}"  
Inline Before Add :

Code: Select all

show-faces="false"   
Find :

Code: Select all

<fb:like href="{U_FB}"></fb:like>  
Inline find :

Code: Select all

href="{U_FB}"  
Inline Before Add :

Code: Select all

show-faces="false"   
Powered by chocolate

User avatar
soumik
Registered User
Posts: 486
Joined: Tue Nov 06, 2007 7:27 pm
Contact:

Re: [ALPHA] Like button for Facebook

Post by soumik » Sat Dec 24, 2011 3:37 am

knight.rider69 wrote: i wonder this mod will it be still developing ?? :?
Apart for a (almost non-) issue with IE, which does not happen with IE9, there's nothing to fix/develop.
Powered by chocolate

packerstud
Registered User
Posts: 113
Joined: Fri Jul 08, 2011 5:29 am

Re: [ALPHA] Like button for Facebook

Post by packerstud » Sat Dec 24, 2011 4:31 am

Thank you very much soumik!

Hhappy
Registered User
Posts: 43
Joined: Thu Aug 06, 2009 5:23 pm

Re: [ALPHA] Like button for Facebook

Post by Hhappy » Fri Dec 30, 2011 4:44 pm

Hi there, thank you for taking the time to read this post.

For the facebook Like i'm looking for a solution.
I'm pretty sure this should be possible but i don't have the coding knowledge for this. I've seen similar solutions for other software but not for phpbb3 (yet) (although the arcade mod has <meta property="og:image" content="{ARCADE_FB_GI}" /> )

I would like our moderators to have the option to select a checkbox next to an image in a post.
This selection would then be presented as result and shown in the header as result for og:image. That way moderators can set the image that will show when using the like button for Facebook.

If no selection is made by a mod the og:image should be the first picture in a post. (attach_ID comes to mind).

Am i dreaming or is this possible?

lqlqlq
Registered User
Posts: 84
Joined: Sat Mar 05, 2011 8:49 pm

Re: [ALPHA] Like button for Facebook

Post by lqlqlq » Thu Jan 05, 2012 3:56 pm

How to remove this bug or remove stuppid box ?
Image

User avatar
soumik
Registered User
Posts: 486
Joined: Tue Nov 06, 2007 7:27 pm
Contact:

Re: [ALPHA] Like button for Facebook

Post by soumik » Fri Jan 06, 2012 2:23 am

That's a feature, not a bug; only in your case it looks bare like that for some reason. Use the iFrame version. It should present no prompt for posting to your wall after you like something.
Powered by chocolate

kumbandit
Registered User
Posts: 1
Joined: Sun Jan 08, 2012 2:49 pm

Re: [ALPHA] Like button for Facebook

Post by kumbandit » Sat Jan 14, 2012 9:42 pm

I'm sorry, I'm new here, can anyone tell me what I'm supposed to do with those files? Where do I exactly need to upload them? Thank you.

User avatar
soumik
Registered User
Posts: 486
Joined: Tue Nov 06, 2007 7:27 pm
Contact:

Re: [ALPHA] Like button for Facebook

Post by soumik » Mon Mar 05, 2012 1:36 pm

kumbandit wrote:I'm sorry, I'm new here, can anyone tell me what I'm supposed to do with those files? Where do I exactly need to upload them? Thank you.
You need to upload them to the root of your forum, keeping the directory hierarchy intact.

You may also want to read this: How to Install MODs
Powered by chocolate

User avatar
Jorup16
Registered User
Posts: 386
Joined: Sun Dec 14, 2008 5:13 am
Location: Zacapa, Guatemala
Name: Jorge
Contact:

Re: [ALPHA] Like button for Facebook

Post by Jorup16 » Wed Apr 04, 2012 10:22 am

Works with version 3.0.10?

User avatar
Hippie459MN
Registered User
Posts: 889
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [ALPHA] Like button for Facebook

Post by Hippie459MN » Wed Apr 04, 2012 1:04 pm

Jorup16 wrote:Works with version 3.0.10?
Its working here.

maverick4546a
Registered User
Posts: 32
Joined: Tue Mar 27, 2012 12:06 pm

Re: [ALPHA] Like button for Facebook

Post by maverick4546a » Mon Apr 16, 2012 10:54 am

Hi....

I have got the code in the correct places at http://www.southernmtb.co.uk/dev but when you like some topics it only pulls the site name and a old site description and does not pull the topic out... on some.. not all..

How do I pull it so the topic and the site come out together... so when someone clicks on it they go to the topic thats liked and not just the site???

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 37 guests