Page 19 of 23

Re: [RC] phpBB Invite 2.0.2

Posted: Thu Jan 30, 2014 7:06 am
by KillBill.
FlangeMonkey wrote:Hi Guys,

What is the support like on 3.0.12?
yes
FlangeMonkey wrote: I've done an install but get the below error.

Code: Select all

						// Invite Start
						'require_ac_invite'		=> ($invite_install) ? $meghivo->select_acc_invite($config['require_ac_invite']) : false,
						// Invite End

The Find specified by the MOD could not be found

open includes/acp/acp_board.php

find

Code: Select all

						'require_activation'	=> array('lang' => 'ACC_ACTIVATION',	'validate' => 'int',	'type' => 'select', 'method' => 'select_acc_activation', 'explain' => true),
after add

Code: Select all

						// Invite Start
						'require_ac_invite'		=> ($invite_install) ? $meghivo->select_acc_invite($config['require_ac_invite']) : false,
						// Invite End

Re: [RC] phpBB Invite 2.0.2

Posted: Fri Mar 14, 2014 8:56 am
by M_Pavel
Hello!
I have phpBB 3.0.12 and try to install phbBB Invite 2.0.2 (phpBB_Invite_2.0.2_31-06-2012) via AutoMOD 1.0.3-DEV .

I have the same error 'The Find specified by the MOD could not be found' (but Find string "'require_activation' => ..... 'explain' => true)" is exactly in the place).
Do I need to edit includes/acp/acp_board.php before install or after install ?

Also, during install togher with this "Find" error AutoMOD shows errors in the "New Files":

Code: Select all

root/adm/style/acp_meghivo.html 	adm/style/acp_meghivo.html 	Copy not attempted
....
root/styles/subsilver2/theme/meghivo.css 	styles/subsilver2/theme/meghivo.css 	Copy not attempted 
I've edited files, press Retry and same error appears. Then I make Force install, is says Mode installed and files are written, but Find error still remains.

Code: Select all

Source 	Target 	Status
root/adm/style/acp_meghivo.html 	adm/style/acp_meghivo.html 	Success
.....
root/language/en/mods/info_mcp_meghivo.php 	language/en/mods/info_mcp_meghivo.php 	Success
Then I press "The MOD requires an external installer to finish installation. Click here to continue to that step" and there is an error in language. First, I've got RU from here
http://www.phpbbguru.net/community/down ... p?id=15619 and copied it to root folder in archive, but after getting errors I delete it from archive, unistalled mode, delete mode, uploaded new and istalled it. But errors about 'ru' remained.

Code: Select all

"[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 150: include(./../language/ru/mods/install_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 150: include(./../language/ru/mods/install_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 150: include(): Failed opening './../language/ru/mods/install_meghivo.php' for inclusion (include_path='.:')
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 151: include(./../language/ru/mods/info_acp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 151: include(./../language/ru/mods/info_acp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 151: include(): Failed opening './../language/ru/mods/info_acp_meghivo.php' for inclusion (include_path='.:')
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 152: include(./../language/ru/mods/info_mcp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 152: include(./../language/ru/mods/info_mcp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 152: include(): Failed opening './../language/ru/mods/info_mcp_meghivo.php' for inclusion (include_path='.:')
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 153: include(./../language/ru/mods/info_ucp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 153: include(./../language/ru/mods/info_ucp_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 153: include(): Failed opening './../language/ru/mods/info_ucp_meghivo.php' for inclusion (include_path='.:')
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 154: include(./../language/ru/mods/permissions_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 154: include(./../language/ru/mods/permissions_meghivo.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 154: include(): Failed opening './../language/ru/mods/permissions_meghivo.php' for inclusion (include_path='.:')"
also, it says
Some changes to the language files are missing. Please apply them as described HERE.

Code: Select all

BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/install/index.php
LINE: 168
CALL: trigger_error()
Also, in the /INCLUDES folder I have /INFO folder, where acp_meghivo.php is located. But there is no acp_meghivo.php in /INCLUDES itself.
In Automod mode Invite is listed as installed.

How can I use Invite mod ?

Re: [RC] phpBB Invite 2.0.2

Posted: Fri Mar 14, 2014 11:32 pm
by KillBill.
If a change in the (Automod) is not found, it will you change manual, look install.xml instruction.
The install.xml file to open it use example firefox browser.
"[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 150: include(./../language/ru/mods/install_meghivo.php): failed to open stream: No such file or directory
The mod is not included by default in the Russian language, you have to create!

Re: [RC] phpBB Invite 2.0.2

Posted: Sun Apr 20, 2014 2:33 am
by clight77
Small issue when sending out invite E-Mails, they are not not being received.
Using phpbb3 v3.0.11 Prosilver.

What am I doing wrong?

I have
Enable board-wide e-mails: enabled
Users send e-mail via board: enabled

Thanks

Re: [RC] phpBB Invite 2.0.2

Posted: Thu Apr 24, 2014 4:56 am
by KillBill.
clight77 wrote:Small issue when sending out invite E-Mails, they are not not being received.
Using phpbb3 v3.0.11 Prosilver.

What am I doing wrong?

I have
Enable board-wide e-mails: enabled
Users send e-mail via board: enabled

Thanks
Look at the server mail error log.

Re: [RC] phpBB Invite 2.0.2

Posted: Thu Apr 24, 2014 2:08 pm
by clight77
Thanks KillBill it ended up being Permissions for Admin.

Works great..

Thanks :)

Re: [RC] phpBB Invite 2.0.2

Posted: Wed May 07, 2014 11:02 pm
by KillBill.
clight77 wrote:Thanks KillBill it ended up being Permissions for Admin.

Works great..

Thanks :)
;)

Re: [RC] phpBB Invite 2.0.2

Posted: Thu May 08, 2014 2:16 pm
by Methen
Will you be updating this for version 3012?

Re: [RC] phpBB Invite 2.0.2

Posted: Thu May 08, 2014 9:16 pm
by KillBill.
Methen wrote:Will you be updating this for version 3012?
yes

Re: [RC] phpBB Invite 2.1.0

Posted: Fri May 09, 2014 5:49 pm
by KillBill.
2014-05-09
New release: phpBB Invite 2.1.0

Change:
  • [Modified] Updated modx to 1.2.6.
  • [Modified] Automod compatibility.
  • [Added] German language.
Install, Update - Requirements: Min. phpBB 3.0.12, Min phpBB Invite 2.0.2;

Re: [RC] phpBB Invite 2.1.0

Posted: Sat May 17, 2014 4:40 am
by Methen
Is there a way to set this up so that only the admin or mods can do the inviting ?

Re: [RC] phpBB Invite 2.1.0

Posted: Sat May 17, 2014 11:18 am
by KillBill.
Methen wrote:Is there a way to set this up so that only the admin or mods can do the inviting ?
yes

Look at groups Permission setting

Re: [RC] phpBB Invite 2.1.0

Posted: Sat May 17, 2014 3:06 pm
by Methen
KillBill. wrote:
Methen wrote:Is there a way to set this up so that only the admin or mods can do the inviting ?
yes

Look at groups Permission setting
thanks will check it out...

Re: [RC] phpBB Invite 2.1.0

Posted: Sat May 17, 2014 10:43 pm
by Methen
OK I am having a little bit of a problem with this, I took and installed and enabled the mod But in the user registration settings I have it set for by user email and invitations only, I log out refresh the page but when I go back there is no register to click on, also I looked in the user permissions and did not see anything related to this mod that I could disabled ...

Re: [RC] phpBB Invite 2.1.0

Posted: Sun May 18, 2014 1:58 am
by KillBill.
Methen wrote:OK I am having a little bit of a problem with this, I took and installed and enabled the mod But in the user registration settings I have it set for by user email and invitations only, I log out refresh the page but when I go back there is no register to click on, also I looked in the user permissions and did not see anything related to this mod that I could disabled ...
acp/general/User registration settings/Creating ID by invitation: Invitation + Registration

If the "Invitation Only" check out you can not register for the users.
In this case, you can register by invitation only.