[ABD] Force Garage @ First Login 0.6.0 (phpBBGarage Plugin)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

[ABD] Force Garage @ First Login 0.6.0 (phpBBGarage Plugin)

Post by Blue Blood » Thu Dec 16, 2010 8:44 pm

Modification Name: Force Garage @ First Login 0.0.2(phpBBGarage Plug-in)
Author: Blue Blood

BIG Thanks to Mike over @ http://www.stargate-portal.com for helping
Big Thanks to EFiNSTORM over @ http://www.speedjunkies.org for helping

Modification Description: At first login new users have to setup their garage.

Modification Version: 0.6.0 Beta

Version History:
Version 0.6.0 - 2010-12-24
4th Release
- Fixed Existing Forum Bug

Version History:
Version 0.5.0 - 2010-12-17
3rd Release
- ACP Enable / Disable
- Subsilver2 Support

Version History:
Version 0.0.2 - 2010-12-16
2nd Release
- Complete Rewrite

Version History:
Version 0.0.1 - 2010-12-14
1st Release

Requirements:
TESTED WITH THESE VERSIONS
phpBB 3.0.8
phpBB 3.0.7-PL
phpBB 3.0.7
phpBBGarage 2.0.B5
phpBBGarage 2.0.B4
phpBBGarage 2.0.B3

Features:
Force Users to setup garage
ACP Enable / Disable
Subsilver2 Theme

Future Features:

Screenshots:

Modification Download:
DOWNLOAD Version 0.6.0
DOWNLOAD Version 0.5.0
Last edited by Blue Blood on Fri Dec 24, 2010 4:26 pm, edited 5 times in total.

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Fri Dec 17, 2010 8:47 am

Force Garage @ First Login 0.5.0 Beta Released
Download available in first post!

Author Notes
After a few bug fixes and typos 0.5.0 is released.
I'm 98% sure there are no bugs!!
In version 0.5.0 I have added Subsilver2 and ACP Enable / Disable
I will give it a few weeks for comments, if no problems I'll change the version to 1.0.0 and submit to MODDB

Theme Support
For any other theme support just ask.
I'm not going to waste my time if no one will use them.

Language Support
If you want other languages let me know and I will try and implement them.
I only speak English so I will need help with your native language.

Know Bugs in 0.5.0
Will only work with new forums.
If you have an existing forum do not install.
Hope to have a fix soon.

IMPORTANT
This is a beta version, So as always do not install on a live board.
I will not provide any support.
In newer versions there could be major changes.
I will not provide an update file until an RC.
Last edited by Blue Blood on Tue Dec 21, 2010 7:36 am, edited 1 time in total.

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Fri Dec 17, 2010 11:17 pm

sweet thats for the update gonna install it on my site once i get home

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Sun Dec 19, 2010 12:57 am

Cool let me know if you find any bugs!!

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Mon Dec 20, 2010 10:23 pm

So i guess i found one issue, here

http://********/forums/garage.php?mode=error&EID=5
here is the error

Code: Select all

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    *   This problem can sometimes be caused by disabling or refusing to accept
          cookies.  
EDit also i already had my garage filled out so there should be some kind of check if member's id is in garage table to skip him since i got an error.

Garage Error Occured
Vehicle Garage Full
You Have Reached The Number Of Vehicles That Your Personal Garage Can Hold Set By The Administrator. To Create Anymore Vehicles You Will Need To Delete An Existing Vehicle

I had to alter myself via phpmyadmin.

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Tue Dec 21, 2010 5:52 am

EFiNSTORM wrote:So i guess i found one issue, here
here is the error

Code: Select all

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    *   This problem can sometimes be caused by disabling or refusing to accept
          cookies.  
I think I might have uploaded an old version..
Also try to refresh the template and purge the cache.
This was one of the many problems I was having.
This should not be an issue anymore.
I re uploaded 0.5.0 please DL and try again... Sorry!!
EFiNSTORM wrote:there should be some kind of check if member's id is in garage table to skip him
Yes I agree, I will start working on that!!

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Tue Dec 21, 2010 7:09 am

i have reedited my files and still same error.

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Tue Dec 21, 2010 7:34 am

EFiNSTORM wrote:i have reedited my files and still same error.
After some testing, I figured out the error.
it only shows when the user has reached the garage limit.
and because the 'user_force_garage' table value is zero it wont redirect to the garage error page.

AS IS
this mod will work only for new forums.

The user Garage ID check will fix this problem.

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Tue Dec 21, 2010 7:43 am

Blue Blood wrote:
EFiNSTORM wrote:i have reedited my files and still same error.
After some testing, I figured out the error.
it only shows when the user has reached the garage limit.
and because the 'user_force_garage' table value is zero it wont redirect to the garage error page.

AS IS
this mod will work only for new forums.

The user Garage ID check will fix this problem.
sorry about hassle if you need any help let me know.

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Thu Dec 23, 2010 6:38 am

EFiNSTORM wrote:if you need any help let me know.
It needs to see if users id is in garage_vehicles user_id
if so then update user_force_garage
if not then do the redirect.

I'm having problems with the user_id check in garage_vehicles.

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Thu Dec 23, 2010 9:12 am

Blue Blood wrote:
EFiNSTORM wrote:if you need any help let me know.
It needs to see if users id is in garage_vehicles user_id
if so then update user_force_garage
if not then do the redirect.

I'm having problems with the user_id check in garage_vehicles.
this may or may not work haven't tested it.

Hope it helps.

Edit i think i found a better way to do it will post new code in am.

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Thu Dec 23, 2010 5:28 pm

Thanks for your help!!

I have been busy getting http://www.phpBBGarageMod.com finished.
Once its 100% working I think I'm going to make it a standard option in phpbbgarage 2.0.B6.

Thanks again!!! :)

User avatar
EFiNSTORM
Registered User
Posts: 160
Joined: Fri Dec 26, 2008 4:09 am
Location: localhost

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by EFiNSTORM » Fri Dec 24, 2010 8:32 am

alright here is a hack i only added this into the funtions.php
tested it on my live board and it worked perfectly fine I will clean up the code a bit but at least we know it works :D

Mini Xmas gift.

Code: Select all

//Begin Force Garage @ first login Mod
	$userid = $user->data['user_id'];
	if ($garage_config['garage_force'])
	$sql = "SELECT u.*, v.* FROM ".USERS_TABLE." u, phpbb_garage_vehicles v
            WHERE u.user_id = $userid
            AND u.user_id = v.user_id";
	$result = $db->sql_query($sql);
	$row = $db->sql_fetchrow($result);
		
	if ( $user->data['user_id'] == $row['user_id'] )
	{
		$sql = 'UPDATE ' . USERS_TABLE . "
			SET user_force_garage = '1'
			WHERE user_id = " . $user->data['user_id'];
		$db->sql_query($sql);
		$sql = 'UPDATE ' . USERS_TABLE . "
			SET user_force_garage_notice = '1'
			WHERE user_id = " . $user->data['user_id'];
		$db->sql_query($sql);
	}
	elseif ($user->data['user_force_garage'] != 1 && $user->data['is_registered'] && !$user->data['is_bot'])
    { 
        redirect(append_sid("{$phpbb_root_path}garage_vehicle.$phpEx", 'mode=add_vehicle'));
    }
    //End Force Garage @ first login Mod

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.5.0 (phpBBGarage Plu

Post by Blue Blood » Fri Dec 24, 2010 3:28 pm

EFiNSTORM wrote:alright here is a hack i only added this into the funtions.php
tested it on my live board and it worked perfectly fine I will clean up the code a bit but at least we know it works :D

Mini Xmas gift.
Awesome you are then man...

I will update to v0.6.0 soon..

Mary Christmas EFiNSTORM

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [BETA] Force Garage @ First Login 0.6.0 (phpBBGarage Plu

Post by Blue Blood » Fri Dec 24, 2010 4:23 pm

Force Garage @ First Login 0.6.0 Beta Released
Download available in first post!

Author Notes
Thanks to EFiNSTORM!!!
Will now work will all new & Existing Forums.

Theme Support
For any other theme support just ask.
I'm not going to waste my time if no one will use them.

Language Support
If you want other languages let me know and I will try and implement them.
I only speak English so I will need help with your native language.

Know Bugs in 0.6.0
Will not allow user to add new makes & models.

IMPORTANT
This is a beta version, So as always do not install on a live board.
I will not provide any support.
In newer versions there could be major changes.
I will not provide an update file until an RC.

Locked

Return to “[3.0.x] Abandoned MODs”