[RC] Simple Audio Player Mod

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by Solidjeuh » Sat Sep 01, 2012 5:31 am

Hippie459MN wrote:Are you sure all of your files are uploaded and in the right location? Also, did you add all the edits for your style? If not that could cause the player to not show.

Also, dont forget to clear you cache in the ACP and then refresh your templates. :)
Yes, All edits are there .. Uninstalled and installed 3 times ..
The player worked before .. It just stopped working one day .. lool don't understand it :D
I don't suffer from insanity. I enjoy every minute of it.

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Sun Sep 02, 2012 8:16 pm

I'll look into this later tonight or tomorrow when I have access to my computer.

User avatar
Pthelovod
Registered User
Posts: 106
Joined: Mon Feb 22, 2010 1:32 am
Location: Россия
Name: Alexs Pthelovod
Contact:

Re: [BETA] Simple Audio Player Mod

Post by Pthelovod » Tue Sep 04, 2012 5:25 am

Good afternoon. I suggest not to use the standard files simple_header.html and simple_footer.html , because they have many cumbersome. Better in the file to register all of the Player in this mode :

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>
<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
<meta http-equiv="content-style-type" content="text/css" />
<meta http-equiv="content-language" content="{S_USER_LANG}" />
<meta http-equiv="imagetoolbar" content="no" />
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="keywords" content="" />
<meta name="description" content="" />
{META}
<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>
<!-- SIMPLE AUDIO PLAYER MOD BEGIN -->
<script language="javascript" type="text/javascript" src="{BOARD_URL}/audioplayer/swfobject.js"></script>
<!-- SIMPLE AUDIO PLAYER MOD END -->
<link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />
</head>

<div class="forabg">
			<div class="inner"><span class="corners-top"><span></span></span>

<!-- Div that contains player. -->
<table width="100%">
<tr>
<td align="center">
<div id="player">
<h1>Oops... Flash Isn't Installed!</h1>
<h1>It looks like you don't have the Flash plug-in installed on your Browser. <a href="http://www.macromedia.com/go/getflashplayer" target="_blank">Click here</a> to get it free.</h1>
</div>
</td>
</tr>
<tr>
<td align="center">
<br/>
<p class="sapcenter"><a href="http://www.urbanareas.net/info/_business_phpbb.php" target="_blank">SAP By Keith</a> | <a href="http://www.flashmp3player.org/" target="_blank">Powered By FlashMP3Player.org</a></p>
</td>
</tr>
</table>
<!-- Script that embeds player. -->
<script language="javascript" type="text/javascript">
var so = new SWFObject("flashmp3player.swf", "player", "320", "247", "9"); // Location of swf file. You can change player width and height here (using pixels or percents).
so.addParam("quality", "high");
so.addVariable("content_path","audioplayer_files"); // Location of a folder with mp3 files (relative to php script).
so.addVariable("color_path","{BOARD_URL}/audioplayer/default.xml"); // Location of xml file with color settings.
so.addVariable("script_path","flashmp3player.php"); // Location of php script.
so.write("player");
</script>
<span class="corners-bottom"><span></span></span></div></div>

</html>
So it will be safer and easier.
Sorry for bad English

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Tue Sep 04, 2012 12:34 pm

keith10456 wrote:I'll look into this later tonight or tomorrow when I have access to my computer.
I didn't forget about you... I still don't have access to my files to look into this. I should be able to get into it this afternoon.

User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [BETA] Simple Audio Player Mod

Post by Hippie459MN » Tue Sep 04, 2012 2:44 pm

All is still working perfectly fine here for me. :-)

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Tue Sep 04, 2012 4:48 pm

Solidjeuh wrote:I installed this few months ago, And was working great!
But now the songs wont load anymore.. Just keep getting a white page in the player..
I reinstalled this mod 3 times now..

Image
Weird... I don't understand how it would just not work anymore. Normally there's an action, then a reaction :)

Please post your file edits and a link to your site.

User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [BETA] Simple Audio Player Mod

Post by Hippie459MN » Tue Sep 04, 2012 4:56 pm

The only thing I could think is another mod with some conflicting code perhaps or code in the wrong place.

anne2489
Registered User
Posts: 36
Joined: Sun Oct 14, 2012 7:50 pm

Re: [BETA] Simple Audio Player Mod

Post by anne2489 » Sat Oct 20, 2012 1:59 pm

I apologize in advance for my ignorance. And thank you all for your indulgence. I am new to phpbb, and would love to give this mod a try, but have no idea how to install or find documentation to walk me through it. I have downloaded the mod, and here are my questions..

1. Is there a step by step instruction guide for installation?
2. What folder in the phpbb directory does the player files get uploaded to?
3. I am using phpbb 3.0.11 - and do have multiples styles, are there edits necessary to each style folder?
3. Do you also have to insert the mod in the ACP under BB codes?
4. What else do I need to know?

Thank you very much in advance for any assistance.

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Mon Oct 22, 2012 6:13 pm

anne2489 wrote:I apologize in advance for my ignorance. And thank you all for your indulgence. I am new to phpbb, and would love to give this mod a try, but have no idea how to install or find documentation to walk me through it. I have downloaded the mod, and here are my questions..

1. Is there a step by step instruction guide for installation?
2. What folder in the phpbb directory does the player files get uploaded to?
3. I am using phpbb 3.0.11 - and do have multiples styles, are there edits necessary to each style folder?
3. Do you also have to insert the mod in the ACP under BB codes?
4. What else do I need to know?

Thank you very much in advance for any assistance.

1. Is there a step by step instruction guide for installation?
Yes. In the download, open the install_mod.xml file with FireFox.

2. What folder in the phpbb directory does the player files get uploaded to?
Upload the contents in the "root" folder of the download to the directory that has your phpBB installation.

So if after you upload the files, you should see the following:
/yourphpBBdirectory/audioplayer (folder)
/yourphpBBdirectory/audioplayer_files (folder)
/yourphpBBdirectory/audioplayer.php (file)
/yourphpBBdirectory/flashmp3player.php (file)
/yourphpBBdirectory/flashmp3player.swf (file)
/yourphpBBdirectory/styles/yourstyle/template/audioplayer.html (file)
/yourphpBBdirectory/styles/yourstyle/theme/audioplayer.css (file)
/yourphpBBdirectory/styles/yourstyle/theme/images/simiple_audio_player_mod.png (file)

3. I am using phpbb 3.0.11 - and do have multiples styles, are there edits necessary to each style folder?
Yes. See Question 4 in the Frequently Asked Questions post in this topic.

3. Do you also have to insert the mod in the ACP under BB codes?
No.

4. What else do I need to know?
Back-up all of your phpBB files before you install this mod (or any other mod).

Fun
Registered User
Posts: 13
Joined: Sun Mar 20, 2011 2:32 pm

Re: [BETA] Simple Audio Player Mod

Post by Fun » Mon Oct 22, 2012 7:53 pm

works fine on 3.0.11
thanks Keith :D

where can I change the fontsize of the playlist?

grtz. Fun

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Mon Oct 22, 2012 8:48 pm

Glad it worked out... :)

Unfortunately the font size setting is in the swf file. All other settings could be found in: /yourphpbb/audioplayer/default.xml

Fun
Registered User
Posts: 13
Joined: Sun Mar 20, 2011 2:32 pm

Re: [BETA] Simple Audio Player Mod

Post by Fun » Mon Oct 22, 2012 9:24 pm

ok, thanks very much

anne2489
Registered User
Posts: 36
Joined: Sun Oct 14, 2012 7:50 pm

Re: [BETA] Simple Audio Player Mod

Post by anne2489 » Tue Oct 23, 2012 11:17 am

Thanks so much, Keith! Really appreciate the quick and thorough reply. Will give a whirl and let you know it turns out!

guardianwill
Registered User
Posts: 128
Joined: Sat Feb 25, 2006 3:26 am

Re: [BETA] Simple Audio Player Mod

Post by guardianwill » Wed Feb 20, 2013 11:52 pm

Greetings,

I installed this Mod flawlessly, no errors, new phpbb install and then I uploaded several audio files to play. I refreshed several times all themes, templates and imagesets as well as the general cache. Closed out the browser completely, cleared cache and all temporary files and even started a different browser though the IE browser did display the new window with the player image there. Then, since NO FILES were displayed, I tried firefox as well. Once again, it was a blank player window with all the buttons and all but no music listed to play.

So I uninstalled, deleted and reinstalled and still no change.

So I uninstalled again completely and am here now.

Help Please Thanks...

William

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Simple Audio Player Mod

Post by keith10456 » Thu Feb 21, 2013 3:43 pm

Where are you uploading the audio files to? You should be putting them in the "audioplayer_files" directory.

There are two main directories with the mod. They are "audioplayer" and "audioplayer_files". You should put the audio/music in the 2nd one.

Also, make sure you made the edits to simple_header.html (to the style that you're using).

Locked

Return to “[3.0.x] MODs in Development”