[DEV] Attach Mod

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
mikef35
Registered User
Posts: 118
Joined: Wed Jun 15, 2011 5:43 pm
Contact:

Re: [DEV] Attach Mod

Post by mikef35 » Wed Jun 13, 2012 11:12 pm

When tranfering from localhost and back to live site all the attachments break. I had to go back to to the phpbb standard. Any chance for a fix? Thanks

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Attach Mod

Post by 4_seven » Wed Jun 13, 2012 11:53 pm

seems that you dont make the mod edits in your live environment.
Last edited by 4_seven on Wed Jun 13, 2012 11:56 pm, edited 1 time in total.
Current Mods | Mod Base | php(BB) programming | No help via PM

mikef35
Registered User
Posts: 118
Joined: Wed Jun 15, 2011 5:43 pm
Contact:

Re: [DEV] Attach Mod

Post by mikef35 » Wed Jun 13, 2012 11:56 pm

I do, Just when you transfer the attachments get broken.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Attach Mod

Post by 4_seven » Wed Jun 13, 2012 11:56 pm

ive edit, strg+f5 your browser

edit: when the files broken through transfer, check your transfer settings in filezilla (known bug)

you have to uncheck (handle files without extension as ascii) in filezilla or similar
Last edited by 4_seven on Thu Jun 14, 2012 12:02 am, edited 1 time in total.
Current Mods | Mod Base | php(BB) programming | No help via PM

mikef35
Registered User
Posts: 118
Joined: Wed Jun 15, 2011 5:43 pm
Contact:

Re: [DEV] Attach Mod

Post by mikef35 » Thu Jun 14, 2012 12:01 am

4_seven wrote:ive edit, strg+f5 your browser

edit: when the files broken through transfer, check your transfer settings in filezilla (known bug)

My settings are fine, I transfer many boards. Do they break for you with this mod installed?

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Attach Mod

Post by 4_seven » Thu Jun 14, 2012 12:04 am

have edit again, may strg+f5 this site here again..

but to your question:
no, because i dont use the mod, but when i watch the file structure of the mod, if gives no reason, that it shouldnt work.

please re-read the question here
http://www.phpbb.com/community/viewtopi ... #p13155140

if that not helps, wait for the author ;)
Current Mods | Mod Base | php(BB) programming | No help via PM

mikef35
Registered User
Posts: 118
Joined: Wed Jun 15, 2011 5:43 pm
Contact:

Re: [DEV] Attach Mod

Post by mikef35 » Thu Jun 14, 2012 12:08 am

I do make the edits on the live board, thats why I transfer back and forth. But hey maybe it will get fixed or I will just figure out what I am doing wrong. It also might be that I am 7 hours ahead of my Server and when I transfer it is allocated in the wrong times.

User avatar
digioz
Registered User
Posts: 297
Joined: Thu Feb 05, 2004 9:20 pm
Location: Chicago, IL
Name: DigiOz Multimedia
Contact:

Re: [DEV] Attach Mod

Post by digioz » Thu Jun 14, 2012 5:00 am

The ModX package does not migrate existing attachments and the file structure is kept only going forward. You will have to write a script for migrating existing files.

Remember this Mod is in DEV which means it is not meant to be used on a live forum.

Pete
DigiOz Multimedia
http://www.digioz.com

mikef35
Registered User
Posts: 118
Joined: Wed Jun 15, 2011 5:43 pm
Contact:

Re: [DEV] Attach Mod

Post by mikef35 » Thu Jun 14, 2012 5:07 am

I am not using it live, just testing. But this the problem I have. The attachments i am testing are ones i put in after the mod.

User avatar
martin123456
I've Been Banned!
Posts: 726
Joined: Sat Mar 05, 2011 7:44 pm

Re: [DEV] Attach Mod

Post by martin123456 » Sat Jun 16, 2012 12:15 pm

I use this mod and transfer from local to live and back again and so on and my file system stays intact

Code: Select all

<!-- IF S_CODE_UNTIDY and S_MESS_ON_INDEX Good If_Not_TIDY_Then_SUBMIT -->

wile
Registered User
Posts: 57
Joined: Mon Apr 30, 2007 4:21 pm

Re: [DEV] Attach Mod

Post by wile » Mon Dec 23, 2013 2:42 pm

Who does delete files when no longer needed ?

I created post that contains file.

1. I removed post but attachment remains in files folder even if no longer needed.

2. 2nd scenario is about editing the post and removing attachment itself. Again attachment remains in folder.

3. Created folders should contain index.htm file. Seems to be a good practice.

User avatar
martin123456
I've Been Banned!
Posts: 726
Joined: Sat Mar 05, 2011 7:44 pm

Re: [DEV] Attach Mod

Post by martin123456 » Wed Dec 25, 2013 1:15 am

wile wrote: 3. Created folders should contain index.htm file. Seems to be a good practice.
If your server is set up ok then your get a 403 error

Example http://blades-place.dyndns.info/files/2013/November/29/ the file name is encrypted so a user would never be able to guess the name but feel free to peek at that folder.

Code: Select all

<!-- IF S_CODE_UNTIDY and S_MESS_ON_INDEX Good If_Not_TIDY_Then_SUBMIT -->

wile
Registered User
Posts: 57
Joined: Mon Apr 30, 2007 4:21 pm

Re: [DEV] Attach Mod

Post by wile » Mon Dec 30, 2013 5:47 pm

martin123456 wrote:
wile wrote: 3. Created folders should contain index.htm file. Seems to be a good practice.
If your server is set up ok then your get a 403 error

Example http://blades-place.dyndns.info/files/2013/November/29/ the file name is encrypted so a user would never be able to guess the name but feel free to peek at that folder.
In case is not - we have index.htm there.. thats the reason why phpBB uses it also in other places.

Sure, its just an advice for MOD author.

User avatar
digioz
Registered User
Posts: 297
Joined: Thu Feb 05, 2004 9:20 pm
Location: Chicago, IL
Name: DigiOz Multimedia
Contact:

Re: [DEV] Attach Mod

Post by digioz » Wed Oct 29, 2014 1:11 am

Hello Everyone,

This is just an update to let everyone know that I intend on upgrading this Attachment Mod to the new phpbb 3.1 / Symfony2 / MVC Extension format within the next few weeks, so stay tuned!

Now I just have to figure out how all the events work and how to hook up to the right event to get this going. If anyone has any suggestions on how to do that I am all ears!

Thanks,
Pete
DigiOz Multimedia
http://www.digioz.com

Movie
Registered User
Posts: 127
Joined: Sun Nov 02, 2014 2:54 pm
Location: Chicago Illinois Area.

Re: [DEV] Attach Mod

Post by Movie » Tue May 12, 2015 5:37 am

Any luck turning this into a Extension for phpbb 3.1 ?
View signatures turned off.

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 14 guests