[RC] Blog / Knowledge Base MOD 1.0.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Get Involved
User avatar
dravpper
Registered User
Posts: 23
Joined: Fri Dec 09, 2011 1:49 am
Name: William

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by dravpper »

Just added the blog is there someway to fix this

Image
User avatar
dravpper
Registered User
Posts: 23
Joined: Fri Dec 09, 2011 1:49 am
Name: William

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by dravpper »

How do you get the Categories box on the left side and user box like on your demo site. On my site it is on the right side is there any way to move it
User avatar
martin123456
I've Been Banned!
Posts: 726
Joined: Sat Mar 05, 2011 7:44 pm

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by martin123456 »

Installs and works perfect on PhpBB version 3.0.10

But i have over 500 smilies installed and they all show on the posting page so as i have so many i have them all inside a scroll box to keep it tidy

so the problem is on the blog it dont put them within a scroll box (as there is no code in place to do it within the blog files)

so the question is whats the location of the blog file that detects the smilies i have installed so i can add a scroll box code too ?
also its a awsome mod ty

edit: found it and fixed with a scroll box

Code: Select all

<!-- IF S_CODE_UNTIDY and S_MESS_ON_INDEX Good If_Not_TIDY_Then_SUBMIT -->
Qene
Registered User
Posts: 73
Joined: Sun Aug 29, 2010 10:57 pm
Location: Turkey

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by Qene »

Hello,

Can we manage New Entry and Reply screen the same as community?

Thanks,
User avatar
dravpper
Registered User
Posts: 23
Joined: Fri Dec 09, 2011 1:49 am
Name: William

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by dravpper »

Dose anyone eles see this how do I fix it

Image

cover up the smiles and no way to move it over
Last edited by dravpper on Wed Jan 04, 2012 8:15 pm, edited 2 times in total.
Qene
Registered User
Posts: 73
Joined: Sun Aug 29, 2010 10:57 pm
Location: Turkey

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by Qene »

Image is very small.
User avatar
dravpper
Registered User
Posts: 23
Joined: Fri Dec 09, 2011 1:49 am
Name: William

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by dravpper »

I tested the blog on IE9 and chrome & firefox and the new article box not showing right on IE9 it cover the smiles but went I check it on chrome and firefox it show just right.

Has anyone else getting it
User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by modernist »

You mean like this:

Image
https://camo.phpbb.com/9a4d4c7bab699e7b98aa8ea1a46403c8a6ffe200/687474703a2f2f696d6731382e696d616765736861636b2e75732f696d6731382f313336302f626c6f67716f2e6a7067
looks the same in Opera, IE9 and Firefox but I made quite a few changes plus my forum has a fixed width...
"It ain't a fit night out for man or beast."
User avatar
martin123456
I've Been Banned!
Posts: 726
Joined: Sat Mar 05, 2011 7:44 pm

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by martin123456 »

Mine looks like this

Image

ie9 has a compactablity tab

Code: Select all

<!-- IF S_CODE_UNTIDY and S_MESS_ON_INDEX Good If_Not_TIDY_Then_SUBMIT -->
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by 4_seven »

Some people get

Code: Select all

502 Bad Gateway
on download page

but i think, it's temporary..
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by 4_seven »

dravpper wrote:Dose anyone eles see this how do I fix it

http://dragonstechnology.com/blogboxsplus.png

cover up the smiles and no way to move it over
open the template, where this textarea is in and add a Conditional comment to it, so it looks like <textarea <!--[if IE]>style="width:70%;"<![endif]--> etc etc and play with the percent value.
between each change clear all available board- and browser-caches and hit strg(ctrl)+f5 in browser on your page to check the new size.
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
eMOTIVe
Registered User
Posts: 56
Joined: Thu Jan 05, 2012 11:55 pm
Name: Josh Buesking

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by eMOTIVe »

/blog.php on line 652: Undefined variable: blog_page_name
I'm also getting this when viewing an article.
User avatar
eMOTIVe
Registered User
Posts: 56
Joined: Thu Jan 05, 2012 11:55 pm
Name: Josh Buesking

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by eMOTIVe »

Something else I would suggest is to remove the right div on the blog posting section. It's unneeded and crams up the page to much on narrow themes.

Also RSS would be nice.
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by 4_seven »

eMOTIVe wrote:

Code: Select all

/blog.php on line 652: Undefined variable: blog_page_name
quick fix

open

blog.php

find

Code: Select all

  default:
    redirect(append_sid("{$phpbb_root_path}blog.$phpEx"));
}
after add

Code: Select all

if(!isset($blog_page_name))
{
$blog_page_name = '';
}
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
eMOTIVe
Registered User
Posts: 56
Joined: Thu Jan 05, 2012 11:55 pm
Name: Josh Buesking

Re: [RC] Blog / Knowledge Base MOD 1.0.0

Post by eMOTIVe »

Thank you. I did a quick fix last night on this and I believe I just removed the line entirely and it fixed it without loosing any functionality.
Locked

Return to “[3.0.x] MODs in Development”