[RC3] eMosbat TinyMCE Integration (WYSIWYG editor)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
Locked
User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

mike1984 wrote:
emosbat wrote:please read last question in first post.
Ah, OK.

Well, I'm mainly worried about basic formatting (italics etc.). The reason I need this mod is so someone on my site can paste in stories they've written off-site without having to manually enter all the BBcode.
it support most of them. I tried to convert as much as possible tags. you can test online demo too.

mike1984
Registered User
Posts: 6
Joined: Mon Dec 17, 2012 2:29 am

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mike1984 »

OK, I'm having another problem with this mod.

I installed another mod to add spoiler tags, but when people attempt to post using the WYSIWYG editor, they get this:

Image

What's going on here? The other custom BB codes (for centring) work fine....

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

add icon for custom bbcodes. more detail is in mod details page in acp. you can also disable help tip from acp.

mike1984
Registered User
Posts: 6
Joined: Mon Dec 17, 2012 2:29 am

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mike1984 »

emosbat wrote:add icon for custom bbcodes. more detail is in mod details page in acp. you can also disable help tip from acp.
Adding an icon requires finding an icon (or making one), though....

Why is the "centre" BBcode, but the spoiler one isn't? What's causing the problem here?

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

probably because you didn't set tip for center bbcode... as I said you can disable help tips to fix that

KetchupSamurai
Registered User
Posts: 30
Joined: Sun Jun 24, 2007 8:58 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by KetchupSamurai »

Nice mod, willing to test it however i just tried your demo.

I noticed when putting smilies in line with the underline code it keeps them as underlined and doesn't actually remove the under line.

Also when doing bold text then going to the next line it skips a line or two.

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

could you please give me bbcode to test?

KetchupSamurai
Registered User
Posts: 30
Joined: Sun Jun 24, 2007 8:58 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by KetchupSamurai »

emosbat wrote:could you please give me bbcode to test?
http://phpbblab.emosbat.com/phpBB3/view ... p=138#p138

is my post :p

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

you can use remove formatting button to fix that paragraph. it is from tinymce and I can not fix that.

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mladiucitelj »

KetchupSamurai wrote:Also when doing bold text then going to the next line it skips a line or two.
Also if it's not bold! :?
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

what do you mean skiping? I do not understand it :?

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mladiucitelj »

I enter some text and hit Enter. It skips a line. Look at demo.
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by emosbat »

fixed :mrgreen:

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mladiucitelj »

Great! Thanks.
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [RC3] eMosbat's TinyMCE Integration (WYSIWYG editor)

Post by mladiucitelj »

Problem...

I've installed it on my board, but I just saw it once. Now it won't load any more and looks like this:
Image
(in the middle there should be the editor)

Does it has something with JS? I have Livepreview mod and Prime subject check mod installed and lot's of others that contain JS...
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

Locked

Return to “[3.0.x] MODs in Development”