[BETA] Medal System MOD 1.0.1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
User avatar
Jessica
Former Team Member
Posts: 4340
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by Jessica » Mon Mar 24, 2014 8:10 am

Jessica wrote:Thanks the report. The fix has been made (thank you 5hock!!) and the new package will be uploaded soon.
download has been update...
EliteOps wrote:Can i edit or add more images to the medals ?
You can use the Dynamic image medal function
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

garden of green
Registered User
Posts: 108
Joined: Mon Sep 16, 2013 2:41 pm
Name: Tony
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by garden of green » Mon Mar 24, 2014 9:13 am

Hi jessica,hoping to can point out where i'am going wrong,mod installed great,guessing my issue is here,what exactly do i put in here.

Device Image:
The base name of the gif image inside the images/medals/devices directory, to be applied to dynamically create medals.
Ex. device-2.gif = device

Have upload a image by ftp,but its not showing up,thank you in advance

BioLogIn
Registered User
Posts: 160
Joined: Sun Jan 06, 2008 10:51 am

Re: [BETA] Medal System MOD 1.0.1

Post by BioLogIn » Mon Mar 24, 2014 2:54 pm

garden of green
If you only want to upload another image for medal, just put it into /images/medals/, and it's filename should appear as an option in a dropdown menu at 'Medal image' (third field from the top) in Medal settings. If it doesn't show up, well, may be some read permissions issue?

You only need 'devices' field if you want to have your medal to be changed dynamically by the script.

garden of green
Registered User
Posts: 108
Joined: Mon Sep 16, 2013 2:41 pm
Name: Tony
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by garden of green » Tue Mar 25, 2014 4:07 am

BioLogIn wrote: garden of green
If you only want to upload another image for medal, just put it into /images/medals/, and it's filename should appear as an option in a dropdown menu at 'Medal image' (third field from the top) in Medal settings. If it doesn't show up, well, may be some read permissions issue?

You only need 'devices' field if you want to have your medal to be changed dynamically by the script.
Thank you for that,works fine now,knew i was making a simple mistake somewhere,was putting the image into devices folder :roll:

garden of green
Registered User
Posts: 108
Joined: Mon Sep 16, 2013 2:41 pm
Name: Tony
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by garden of green » Thu Mar 27, 2014 2:55 am

Just noticed there are now 2 medal buttons in Navbar and displays twice in profile ?
Any idea how to fix this ?

User avatar
Jessica
Former Team Member
Posts: 4340
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by Jessica » Thu Mar 27, 2014 6:26 am

garden of green wrote:Just noticed there are now 2 medal buttons in Navbar and displays twice in profile ?
Any idea how to fix this ?
Look for duplicate edits in overall_header.html.

By "profile" do you mean the mini profile in posts or the actual profile? If it's the former, check for duplicates in viewtopic_body.html. If it's the latter, check memberlist_view.html
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

garden of green
Registered User
Posts: 108
Joined: Mon Sep 16, 2013 2:41 pm
Name: Tony
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by garden of green » Tue Apr 22, 2014 2:02 pm

Jessica wrote:
garden of green wrote:Just noticed there are now 2 medal buttons in Navbar and displays twice in profile ?
Any idea how to fix this ?
Look for duplicate edits in overall_header.html.

By "profile" do you mean the mini profile in posts or the actual profile? If it's the former, check for duplicates in viewtopic_body.html. If it's the latter, check memberlist_view.html
Thank you Jessica,all sorted now

sakkiotto
Registered User
Posts: 208
Joined: Mon Jun 13, 2005 9:45 pm

Re: [BETA] Medal System MOD 1.0.1

Post by sakkiotto » Sun May 11, 2014 9:13 pm

Hi i use ultimate point 1.0.6 -> https://www.phpbb.com/customise/db/mod/ultimate_points/
when assign a medal (200points) at user.. points not update points.. why?

User avatar
Theriddler1
Registered User
Posts: 438
Joined: Sat Aug 27, 2011 11:00 pm
Location: NL
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by Theriddler1 » Fri May 16, 2014 10:40 am

maybe someone would love this css edits i made, so i post here.

Open: viewtopic_body.html

Find:

Code: Select all

<!-- BEGIN medal -->
		<!-- BEGIN medal_row -->
			<!-- BEGIN medal_col -->
					<img src="{postrow.medal.medal_row.medal_col.MEDAL_IMAGE}" border="0" alt="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" title="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" {postrow.medal.medal_row.medal_col.MEDAL_WIDTH} {postrow.medal.medal_row.medal_col.MEDAL_HEIGHT} />
				<!-- END medal_col -->
			</dd>
			<!-- END medal_row -->
		<!-- END medal -->
Replace with:

Code: Select all

<!-- BEGIN medal -->
		<!-- BEGIN medal_row -->
			<dd class="medalborder">
			<h1><span>Medals</span></h1>
				<!-- BEGIN medal_col -->
					<img src="{postrow.medal.medal_row.medal_col.MEDAL_IMAGE}" border="0" alt="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" title="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" {postrow.medal.medal_row.medal_col.MEDAL_WIDTH} {postrow.medal.medal_row.medal_col.MEDAL_HEIGHT} />
				<!-- END medal_col -->
			</dd>
			<!-- END medal_row -->
		<!-- END medal -->
Open medals.css

At last line paste the following:

Code: Select all

.medalborder {
    border: 1px inset #B4BAC0;
    height: 100%;
}
.medalborder h1 {
    color: #000000;
    font-size: 12px;
    height: 15px;
    line-height: 16px;
    margin-left: 5px;
    margin-top: -9px;
    text-align: center;
}
.medalborder h1 span {
    background-color: #FFFFFF;
}
Demo:
http://jsfiddle.net/8LPsr/
Theriddler - Moderator @ phpBB.nl | phpBBservice.nl Team-member
ImageSupport Tools | Image My Extensions | buy me a beer Image

User avatar
«THÖMÅS®©»
Registered User
Posts: 500
Joined: Sun Feb 27, 2011 5:38 pm
Location: UK
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by «THÖMÅS®©» » Wed May 28, 2014 1:08 pm

Originally posted here: viewtopic.php?f=46&t=2244791

Hello phpBB users...

I am running a clan known as =BG= and have installed the site from a different hosting server on to my own one, but the site was on another GoDaddy server and was not getting these errors there, I cannot understand it as I have been trying to figure this out for a long time, I checked the files with the mod installer and they seem to be OK.

The error I am getting is this:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3 [1064]

SQL

SELECT forum_id, auth_option_id, auth_role_id, auth_setting FROM phpbb_acl_users WHERE user_id =

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/auth.php
LINE: 832
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/auth.php
LINE: 400
CALL: auth->acl_raw_data_single_user()

FILE: [ROOT]/includes/auth.php
LINE: 71
CALL: auth->acl_cache()

FILE: [ROOT]/includes/functions_content.php
LINE: 1277
CALL: auth->acl()

FILE: [ROOT]/includes/medals_memberlist.php
LINE: 115
CALL: get_username_string()

FILE: [ROOT]/memberlist.php
LINE: 468
CALL: include('[ROOT]/includes/medals_memberlist.php')
I am not sure what is causing that error in the installation as the file appears to be just fine to me.

Is this a known issue or is there a fix?
“No, this trick won't work... How on earth are you ever going to explain in terms of chemistry and physics so important a biological phenomenon as first love?” - Albert Einstein
"For every action has is an equal and opposite reaction". - Sir Isaac Newton
"In honor there is hope" - Alaska State Troopers

Owner & President @ =DN= Dark Nexus Multi-Gaming Clan

sakkiotto
Registered User
Posts: 208
Joined: Mon Jun 13, 2005 9:45 pm

Re: [BETA] Medal System MOD 1.0.1

Post by sakkiotto » Wed May 28, 2014 6:43 pm

sakkiotto wrote:Hi i use ultimate point 1.0.6 -> https://www.phpbb.com/customise/db/mod/ultimate_points/
when assign a medal (200points) at user.. points not update points.. why?
anyone had this problem ?

User avatar
«THÖMÅS®©»
Registered User
Posts: 500
Joined: Sun Feb 27, 2011 5:38 pm
Location: UK
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by «THÖMÅS®©» » Fri Jun 06, 2014 1:01 am

«THÖMÅS®©» wrote:Originally posted here: viewtopic.php?f=46&t=2244791

Hello phpBB users...

I am running a clan known as =BG= and have installed the site from a different hosting server on to my own one, but the site was on another GoDaddy server and was not getting these errors there, I cannot understand it as I have been trying to figure this out for a long time, I checked the files with the mod installer and they seem to be OK.

The error I am getting is this:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3 [1064]

SQL

SELECT forum_id, auth_option_id, auth_role_id, auth_setting FROM phpbb_acl_users WHERE user_id =

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/auth.php
LINE: 832
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/auth.php
LINE: 400
CALL: auth->acl_raw_data_single_user()

FILE: [ROOT]/includes/auth.php
LINE: 71
CALL: auth->acl_cache()

FILE: [ROOT]/includes/functions_content.php
LINE: 1277
CALL: auth->acl()

FILE: [ROOT]/includes/medals_memberlist.php
LINE: 115
CALL: get_username_string()

FILE: [ROOT]/memberlist.php
LINE: 468
CALL: include('[ROOT]/includes/medals_memberlist.php') 
I am not sure what is causing that error in the installation as the file appears to be just fine to me.

Is this a known issue or is there a fix?
I am getting this error still and cannot find the problem!
“No, this trick won't work... How on earth are you ever going to explain in terms of chemistry and physics so important a biological phenomenon as first love?” - Albert Einstein
"For every action has is an equal and opposite reaction". - Sir Isaac Newton
"In honor there is hope" - Alaska State Troopers

Owner & President @ =DN= Dark Nexus Multi-Gaming Clan

User avatar
Korkel
Registered User
Posts: 391
Joined: Mon Jun 02, 2014 7:09 am
Location: ~/home/Liz/Desktop
Name: Liz Aalderink
Contact:

Re: [BETA] Medal System MOD 1.0.1

Post by Korkel » Sun Jun 22, 2014 10:37 am

I like this MOD, will install it on my test board.
"If you lose your left arm, your right arm will be left."
“The most important property of a program is whether it accomplishes the intention of its user.”
Image

Vogue01
Registered User
Posts: 16
Joined: Thu May 15, 2014 4:45 pm

Re: [BETA] Medal System MOD 1.0.1

Post by Vogue01 » Fri Jun 27, 2014 6:12 pm

I installed this mod and it seems to work perfectly (so far) other than the fact that you go to a blank page after you create a topic/post. Any way to fix this?

User avatar
TheBird956
Registered User
Posts: 5
Joined: Mon Jun 30, 2014 5:09 am

Re: [BETA] Medal System MOD 1.0.1

Post by TheBird956 » Mon Jun 30, 2014 8:10 pm

I just installed it and it works perfectly!

But I have one question, what is a device image? In fact, what is that device thing?

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 24 guests

cron