[RC1] Youtube Gallery

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Suggested Hosts
User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC1] Youtube Gallery

Post by Jessica » Sun Jun 14, 2015 5:44 am

How about adding a quick reply in the comments section?

EDIT: Also, how would I change the title of my tab to something like School & Chat - Youtube Gallery when I am on the gallery page? Right now it only says my board name
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC1] Youtube Gallery

Post by Jessica » Sun Jun 14, 2015 5:58 am

spaceace wrote:adding a new video is causing an error and allow_url_fopen is turned on in the server
[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden
I got this same issue but I don't understand how to fix it. I know it's my API key config I need to check but I don't know what I did wrong

Tried everything I could think of. Is it supposed to be a browser or server key? Am I supposed to put in the referrer or IP address?

No matter what I do I still get the PHP error

EDIT: Finally got it.
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
5hocK
Registered User
Posts: 3011
Joined: Wed Nov 23, 2011 7:00 pm
Location: England

Re: [RC1] Youtube Gallery

Post by 5hocK » Sun Jun 14, 2015 4:37 pm

Jessica wrote:EDIT: Finally got it.
Mind sharing?
A thread is pretty much a topic. Stop with the pedantics will ya.

User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC1] Youtube Gallery

Post by Jessica » Sun Jun 14, 2015 4:44 pm

In APIs under APIs & auth I made sure "YouTube Data API" was enabled

Then I created a server key (APIs & auth > Credentials), leaving the textbox blank
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7077
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Sun Jun 14, 2015 9:52 pm

5hocK wrote:
Jessica wrote:EDIT: Finally got it.
Mind sharing?
Jessica wrote:In APIs under APIs & auth I made sure "YouTube Data API" was enabled

Then I created a server key (APIs & auth > Credentials), leaving the textbox blank
Getting Google API key for using with YouTube (video)

KayDee12
Registered User
Posts: 3
Joined: Tue Jun 16, 2015 12:37 am
Location: Pennsylvania

Re: [RC1] Youtube Gallery

Post by KayDee12 » Tue Jun 16, 2015 12:44 am

I am getting this error after trying to install.

Code: Select all

Adding new config variable: comments_per_page

ERROR: Config variable comments_per_page already exists.
Asked me to down load a file and here is that output:

Code: Select all

Video Gallery
PHP Version: 5.4.37-pl0-gentoo
DBMS: MySQL(i) 5.6.22
phpBB3 Version: 3.0.12

Adding new config variable: comments_per_page
ERROR: Config variable comments_per_page already exists.
Can anyone shed some light?

Thank You.

KayDee12
Registered User
Posts: 3
Joined: Tue Jun 16, 2015 12:37 am
Location: Pennsylvania

Re: [RC1] Youtube Gallery

Post by KayDee12 » Tue Jun 16, 2015 11:41 pm

Okay, I got rid of the above error/conflict. Updated my board to 3.0.14. I created the server key and entered it the ACP and clicked the submit button, nothing really happened. The page didn't load after i clicked submit. When I click on Video Categories in the ACP on the .MODS tab I receive this:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Table 'myprefixfordatabase_phpBB.phpbb_auto_video_cat' doesn't exist [1146]

SQL

SELECT * FROM phpbb_auto_video_cat ORDER by video_cat_title

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_video.php
LINE: 217
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_video->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
I installed this using AUTOMOD.

Thanks for any help :)

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7077
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Wed Jun 17, 2015 2:41 am

KayDee12 wrote:I am getting this error after trying to install.

Code: Select all

Adding new config variable: comments_per_page

ERROR: Config variable comments_per_page already exists.
Asked me to down load a file and here is that output:

Code: Select all

Video Gallery
PHP Version: 5.4.37-pl0-gentoo
DBMS: MySQL(i) 5.6.22
phpBB3 Version: 3.0.12

Adding new config variable: comments_per_page
ERROR: Config variable comments_per_page already exists.
Can anyone shed some light?

Thank You.
Do you have other mods installed? Which ones?
KayDee12 wrote:Okay, I got rid of the above error/conflict. Updated my board to 3.0.14. I created the server key and entered it the ACP and clicked the submit button, nothing really happened. The page didn't load after i clicked submit. When I click on Video Categories in the ACP on the .MODS tab I receive this:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Table 'myprefixfordatabase_phpBB.phpbb_auto_video_cat' doesn't exist [1146]

SQL

SELECT * FROM phpbb_auto_video_cat ORDER by video_cat_title

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_video.php
LINE: 217
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_video->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
I installed this using AUTOMOD.

Thanks for any help :)
Probably something wrong during installation. I suggest completely remove and reinstall the MOD carefully.

User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC1] Youtube Gallery

Post by Jessica » Wed Jun 17, 2015 6:31 pm

Jessica wrote:How about adding a quick reply in the comments section?

EDIT: Also, how would I change the title of my tab to something like School & Chat - Youtube Gallery when I am on the gallery page? Right now it only says my board name
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

KayDee12
Registered User
Posts: 3
Joined: Tue Jun 16, 2015 12:37 am
Location: Pennsylvania

Re: [RC1] Youtube Gallery

Post by KayDee12 » Thu Jun 18, 2015 2:15 pm

Looks like I got MOST of it working. I am using a custom theme, and the video link on the board index page is not showing up. For testing I changed the theme back to prosilver and after logging in, I can see the link and go to the page no problem. But not on the custom theme. I uploaded the contents of the STYLES folder to the custom theme I am using. I log in on the custom theme, manually go to my videos/index.php page but it says "You are not authorized to use this page". So, I log in again and go to the videos page and it says the same thing.

What file and code do I need to change in the new theme?

Custom theme is:
http://demo.phpbb3styles.net/Artodia%3A+Deluxe

Thanks for any help.

User avatar
salvocortesiano
Registered User
Posts: 148
Joined: Mon Mar 22, 2010 1:49 pm
Location: Florence (Italy)
Name: Salvo Cortesiano
Contact:

Italian language [RC1] Youtube Gallery

Post by salvocortesiano » Wed Jul 01, 2015 3:20 am

Hi _Vinny_,
thanks for this MOD. By the following link you can download the Italian translation of the MOD [RC1] Youtube Gallery ;)
http://www.netshadows.it/root.rar

Best regards
Salvo Cortesiano

P.S. Unfortunately I use the subsilver2 style... do you think in the future you include even this style?
Thanks!
The best way to predict the future is to invent it!
Image

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7077
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: Italian language [RC1] Youtube Gallery

Post by _Vinny_ » Wed Jul 01, 2015 4:15 am

salvocortesiano wrote:Hi _Vinny_,
thanks for this MOD. By the following link you can download the Italian translation of the MOD [RC1] Youtube Gallery ;)
http://www.netshadows.it/root.rar
Thank you.
salvocortesiano wrote:P.S. Unfortunately I use the subsilver2 style... do you think in the future you include even this style?
No, only prosilver.

User avatar
salvocortesiano
Registered User
Posts: 148
Joined: Mon Mar 22, 2010 1:49 pm
Location: Florence (Italy)
Name: Salvo Cortesiano
Contact:

Re: [RC1] Youtube Gallery

Post by salvocortesiano » Thu Jul 02, 2015 2:47 am

_Vinny_ wrote:Thank you.
U are welcome!
_Vinny_ wrote:No, only prosilver.
:o
The best way to predict the future is to invent it!
Image

User avatar
Alex Train
Registered User
Posts: 1
Joined: Fri Aug 20, 2010 8:40 am
Location: Moscow
Name: Алексей Вячеславович
Contact:

Re: [RC1] Youtube Gallery

Post by Alex Train » Sun Sep 27, 2015 12:45 pm

Add Russian languange: Download Link
Настоящий мужчина никогда не взрослеет, меняется только цена его игрушек...

Fernando Garcia
Registered User
Posts: 60
Joined: Thu Mar 06, 2014 7:06 pm
Location: Brazil

Re: [RC1] Youtube Gallery

Post by Fernando Garcia » Mon Oct 05, 2015 12:01 pm

Hi!

I have some error in ACP, after submit the changes I can't see any confirmation message.

I mean something like this:

Image

Edit:

It's normal?

Image

Edit 2:

I have this error too after click in delete comment > NO.

Image

Edit 3:

Can you help me to add a cancel button in "video_cmnt_editor.html"? I have tested this way but no works.

Code: Select all

		<input type="submit" accesskey="c" tabindex="10" name="cancel" value="Cancel" class="button2" />
		<input type="submit" name="submit" id="submit" value="{L_SUBMIT}" class="button1" tabindex="9" />
		
Best regards.

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 24 guests

cron