[RC1] Youtube Gallery

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Mon Jun 08, 2015 1:48 pm

Kevicar wrote::oops: Oh sorry !

In the installation file is marked: video_install.php and not video/install.php

Thank you ! ;)
Already fixed this. :)

Vattenpistol
Registered User
Posts: 101
Joined: Thu Dec 30, 2010 5:44 pm

Re: [RC1] Youtube Gallery

Post by Vattenpistol » Mon Jun 08, 2015 3:30 pm

_Vinny_ wrote:Version 1.0.4 RC1 is now live! See first post.

The MOD has undergone major changes, if you are still using 3.0.x and this MOD, let me know if you need help to update the MOD.
Hi Vinny!

I currently use phpbb 3.0.12, so I would really appreciate if you could post a guide or some instructions on how to update.

Also, now I get this error code:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/video.php on line 67: DOMDocument::load(http://gdata.youtube.com/feeds/api/videos/): failed to open stream: HTTP request failed! HTTP/1.0 410 Gone
 
[phpBB Debug] PHP Warning: in file [ROOT]/video.php on line 67: DOMDocument::load(): I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/videos/"

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Mon Jun 08, 2015 4:31 pm

Vattenpistol wrote:
_Vinny_ wrote:Version 1.0.4 RC1 is now live! See first post.

The MOD has undergone major changes, if you are still using 3.0.x and this MOD, let me know if you need help to update the MOD.
Hi Vinny!

I currently use phpbb 3.0.12, so I would really appreciate if you could post a guide or some instructions on how to update.

Also, now I get this error code:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/video.php on line 67: DOMDocument::load(http://gdata.youtube.com/feeds/api/videos/): failed to open stream: HTTP request failed! HTTP/1.0 410 Gone
 
[phpBB Debug] PHP Warning: in file [ROOT]/video.php on line 67: DOMDocument::load(): I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/videos/"
TO UPDATE:
- Download the last version.
- Upload the new files.
- Open includes/constants.php, find:

Code: Select all

define('VIDEO_CAT_TABLE',		$table_prefix . 'video_cat');
After add:

Code: Select all

define('VIDEO_CMNTS_TABLE',		$table_prefix . 'video_cmnts');
- Open includes/functions.php, find:

Code: Select all

'U_VIDEO'				=> append_sid("{$phpbb_root_path}video.$phpEx"),
Replace with:

Code: Select all

'U_VIDEO'				=> append_sid("{$phpbb_root_path}video/index.$phpEx"),
- Run video/install.php
- Delete video.php and video_install.php
- Purge cache.


ABOUT THE ERROR:
Be sure that your server supports allow_url_fopen, if so turn it on.

User avatar
Kevicar
Registered User
Posts: 9
Joined: Sun Apr 07, 2013 5:27 pm
Location: Neuchâtel - Switzerland
Contact:

Re: [RC1] Youtube Gallery

Post by Kevicar » Mon Jun 08, 2015 7:40 pm

Install or update works perfectly ... do not forget to set the permissions ! ;)

L'installation ou la mise à jour fonctionne parfaitement ... ne pas oublier de régler les permissions !

:D

desco
Registered User
Posts: 2
Joined: Thu Jun 11, 2015 9:56 am

Re: [RC1] Youtube Gallery

Post by desco » Thu Jun 11, 2015 10:01 am

Hi all, I installed the latest versió and made all the changes
API also
and all is well, but when to press the button upload video, I get the following error
[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5265: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5267: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5268: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5269: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)


Thanks if you can help me

desco
Registered User
Posts: 2
Joined: Thu Jun 11, 2015 9:56 am

Re: [RC1] Youtube Gallery

Post by desco » Thu Jun 11, 2015 10:07 am

Also when I accept upload video

error

[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 2684: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Thu Jun 11, 2015 7:16 pm

desco wrote:Also when I accept upload video

error

[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 2684: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3969)
Be sure that your server supports allow_url_fopen, if so turn it on.

User avatar
spaceace
Registered User
Posts: 1798
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC1] Youtube Gallery

Post by spaceace » Fri Jun 12, 2015 11:22 pm

if you follow the link from the error...
http://gdata.youtube.com/feeds/api/videos/

you get
No longer available
does that mean that youtube has made changes that need to go in the mod?

reason i'm asking is that this mod has been working great on a forum i work on and suddenly, the error started showing up

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Sat Jun 13, 2015 4:05 am

spaceace wrote:if you follow the link from the error...
http://gdata.youtube.com/feeds/api/videos/

you get
No longer available
does that mean that youtube has made changes that need to go in the mod?

reason i'm asking is that this mod has been working great on a forum i work on and suddenly, the error started showing up
The MOD has received the appropriate update. See viewtopic.php?p=14101991#p14101991

Vattenpistol
Registered User
Posts: 101
Joined: Thu Dec 30, 2010 5:44 pm

Re: [RC1] Youtube Gallery

Post by Vattenpistol » Sat Jun 13, 2015 5:00 pm

_Vinny_ wrote:
TO UPDATE:
- Download the last version.
- Upload the new files.
- Open includes/constants.php, find:

Code: Select all

define('VIDEO_CAT_TABLE',		$table_prefix . 'video_cat');
After add:

Code: Select all

define('VIDEO_CMNTS_TABLE',		$table_prefix . 'video_cmnts');
- Open includes/functions.php, find:

Code: Select all

'U_VIDEO'				=> append_sid("{$phpbb_root_path}video.$phpEx"),
Replace with:

Code: Select all

'U_VIDEO'				=> append_sid("{$phpbb_root_path}video/index.$phpEx"),
- Run video/install.php
- Delete video.php and video_install.php
- Purge cache.


ABOUT THE ERROR:
Be sure that your server supports allow_url_fopen, if so turn it on.
Thank you, I have just updated and everything is working fine!

I have one question though. Earlier I used:

Code: Select all

<a href="{video.U_VIEW_VIDEO}" title="{video.VIDEO_TITLE}"><img src="http://img.youtube.com/vi/{video.YOUTUBE_ID}/hqdefault.jpg" /></a>
to retreive better quality on the thumbnails. But it seems like you have changed the {video.YOUTUBE_ID}. So now I'm wondering what I should use instead?

Vattenpistol
Registered User
Posts: 101
Joined: Thu Dec 30, 2010 5:44 pm

Re: [RC1] Youtube Gallery

Post by Vattenpistol » Sat Jun 13, 2015 5:14 pm

I figured it out. I checked out the {S_VIDEO_THUMBNAIL} and saw that you used http://img.youtube.com/vi/ID/default.jpg.

So I changed this part in ../video/index.php:

Code: Select all

'S_VIDEO_THUMBNAIL'	=> 'http://img.youtube.com/vi/' . censor_text($row['youtube_id']) . '/default.jpg'
into this

Code: Select all

'S_VIDEO_THUMBNAIL'	=> 'http://img.youtube.com/vi/' . censor_text($row['youtube_id']) . '/hqdefault.jpg'

User avatar
spaceace
Registered User
Posts: 1798
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC1] Youtube Gallery

Post by spaceace » Sat Jun 13, 2015 9:48 pm

got everything updated to the latest version and everything is good :D

User avatar
spaceace
Registered User
Posts: 1798
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC1] Youtube Gallery

Post by spaceace » Sat Jun 13, 2015 9:56 pm

adding a new video is causing an error and allow_url_fopen is turned on in the server
[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC1] Youtube Gallery

Post by _Vinny_ » Sat Jun 13, 2015 10:05 pm

Vattenpistol wrote:I figured it out. I checked out the {S_VIDEO_THUMBNAIL} and saw that you used http://img.youtube.com/vi/ID/default.jpg.

So I changed this part in ../video/index.php:

Code: Select all

'S_VIDEO_THUMBNAIL'	=> 'http://img.youtube.com/vi/' . censor_text($row['youtube_id']) . '/default.jpg'
into this

Code: Select all

'S_VIDEO_THUMBNAIL'	=> 'http://img.youtube.com/vi/' . censor_text($row['youtube_id']) . '/hqdefault.jpg'
Nice. I'll update soon to HD. ;)
spaceace wrote:adding a new video is causing an error and allow_url_fopen is turned on in the server
[phpBB Debug] PHP Warning: in file [ROOT]/video/posting.php on line 81: file_get_contents(https://www.googleapis.com/youtube/v3/v ... rt=snippet): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden
From the link error:
{
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "ipRefererBlocked",
"message": "There is a per-IP or per-Referer restriction configured on your API key and the request does not match these restrictions. Please use the Google Developers Console to update your API key configuration if request from this IP or referer should be allowed.",
"extendedHelp": "https://console.developers.google.com"
}
],
"code": 403,
"message": "There is a per-IP or per-Referer restriction configured on your API key and the request does not match these restrictions. Please use the Google Developers Console to update your API key configuration if request from this IP or referer should be allowed."
}
}
Checkout your API key configuration at Google Developers Console.

User avatar
spaceace
Registered User
Posts: 1798
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC1] Youtube Gallery

Post by spaceace » Sat Jun 13, 2015 11:07 pm

_Vinny_ wrote:Checkout your API key configuration at Google Developers Console.
all fixed and working now. thanks :D

Locked

Return to “[3.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 20 guests