[RC] jQuery Pack for phpBB

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

[RC] jQuery Pack for phpBB

Post by emosbat » Fri Mar 29, 2013 10:51 am

Modification Name: jQuery Pack for phpBB

Author: emosbat

Modification Description::
this is a package of jquery library (and jqueryui library) that MOD developers and style designers use as requirement for their MODs/styles that call jquery.

The goal is using `one` standard library in all MODs/styles to remove all jquery conflict problem when use such MODs/styles together.

MOD developers and style designers:
this would be useful MOD if you agree to use it in your MODs/styles instead including jquery yourself, otherwise wouldn't be useful! so I would be glad if you will use it in your MODs/styles that need jquery to remove jquery conflict problem. this need your cooperation, do not include jquery in your mods yourself and instead use this mod.

Modification Version:: 0.0.1

Requirements: phpBB 3.0.*

Features:
  • acp option to enable/disable
  • acp option to use direct call from google or use local files
  • acp option to enable/disable use of jqueryui
  • acp option to change location of code (header or footer)
Modification Download:

Download jQuery Pack for phpBB

Demo URL:

http://phpbbmods.emosbat.com/

Image Donate:

would you like donate? my bitcoin is 1NEkMQUBCbV73VMZKjTdLREcfgGkWig39M



MOD writers/ Style designers FAQ:
  • how I use this MOD in my MOD package?
  • 1. simply tell it as a requirment in your mod package. 2. or you can include latest version of this mod within your mod package and refer it in modx. 3. do not forget to remove jquery entry from your mod.
  • how I check that this mod is enable?
  • you can check for [c]$config['jquerypack_enable'][/c] existence: [c]isset($config['jquerypack_enable'])[/c] and tell end-user that it is required.
list of MODs that use this MOD: list of styles that use this MOD:
Last edited by emosbat on Sat Jul 27, 2013 11:33 am, edited 16 times in total.

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] jQuery Pack for phpBB

Post by Mess » Fri Mar 29, 2013 11:16 am

This should be part of standard phpBB.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by RMcGirr83 » Fri Mar 29, 2013 11:57 am

jQuery will be in 3.1
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Galandas
Registered User
Posts: 731
Joined: Thu Jul 23, 2009 4:11 pm
Location: Italy
Name: Rey
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by Galandas » Fri Mar 29, 2013 12:00 pm

Very good indeed.
English is not my native language My CDB Contributions My RC extensions

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by Jessica » Fri Mar 29, 2013 4:09 pm

Very nice!
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Galandas
Registered User
Posts: 731
Joined: Thu Jul 23, 2009 4:11 pm
Location: Italy
Name: Rey
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by Galandas » Fri Mar 29, 2013 8:54 pm

I have a question
I have 3 mod with the - jquery.min.js

versions are as follows
  • jQuery v1.9.1; here are 2
  • jQuery v1.8.3
If they gate the 3 jquery.min.js, the 3 mods should work right?
English is not my native language My CDB Contributions My RC extensions

User avatar
ViolaF
Registered User
Posts: 1457
Joined: Tue Aug 14, 2012 11:52 pm

Re: [DEV] jQuery Pack for phpBB

Post by ViolaF » Fri Mar 29, 2013 10:31 pm

All jQuery mods should always work with the latest min ;)

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [DEV] jQuery Pack for phpBB

Post by mladiucitelj » Fri Mar 29, 2013 11:06 pm

Great! I often have a jquery conflict and I'm getting tired of this. Hopethis is going to be a superb solution.
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [DEV] jQuery Pack for phpBB

Post by emosbat » Sat Mar 30, 2013 8:14 am

Galandas wrote:I have a question
I have 3 mod with the - jquery.min.js

versions are as follows
  • jQuery v1.9.1; here are 2
  • jQuery v1.8.3
:
If they gate the 3 jquery.min.js, the 3 mods should work right?
as Viola said
ViolaF wrote:All jQuery mods should always work with the latest min ;)
there are little changes in 1.9 that maybe need to adjust in old source code. should test it.

User avatar
Galandas
Registered User
Posts: 731
Joined: Thu Jul 23, 2009 4:11 pm
Location: Italy
Name: Rey
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by Galandas » Sat Mar 30, 2013 9:52 am

in that case did not understand the features of the mod
jquery if three are in conflict, we must eliminate at least two if they are equal
I thought this mod, replace all the jquery min.
English is not my native language My CDB Contributions My RC extensions

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [DEV] jQuery Pack for phpBB

Post by emosbat » Sat Mar 30, 2013 10:25 am

Galandas wrote:in that case did not understand the features of the mod
jquery if three are in conflict, we must eliminate at least two if they are equal
I thought this mod, replace all the jquery min.
it is totaly depend on mod writers cooperation. :roll:
if they agree to use this mod instead including jquery themself then this mod would be useful.
I myself will use this mod for all of my mods ,very soon, instead of including deferent jquery in every mod, so for example if you install both mod1 and mod2 from me, you will not get jquery conflict from them.

User avatar
Galandas
Registered User
Posts: 731
Joined: Thu Jul 23, 2009 4:11 pm
Location: Italy
Name: Rey
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by Galandas » Sat Mar 30, 2013 10:47 am

ok I get it thanks :)
English is not my native language My CDB Contributions My RC extensions

User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [DEV] jQuery Pack for phpBB

Post by mladiucitelj » Sat Mar 30, 2013 12:24 pm

emosbat wrote:I myself will use this mod for all of my mods ,very soon, instead of including deferent jquery in every mod, so for example if you install both mod1 and mod2 from me, you will not get jquery conflict from them.
This is a must have. Like I said, I'm tired of those conflicts. Want to use more jQuery mods, but some I have to uninstall because of conflicts.
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [DEV] jQuery Pack for phpBB

Post by keith10456 » Sun Apr 07, 2013 4:30 pm

I like the idea... I'm going to look at my mods wen I'm on my computer to see how I can implement this.

User avatar
emosbat
Registered User
Posts: 564
Joined: Sat Jan 28, 2012 1:25 pm

Re: [DEV] jQuery Pack for phpBB

Post by emosbat » Sun Apr 07, 2013 4:59 pm

keith10456 wrote:I like the idea... I'm going to look at my mods wen I'm on my computer to see how I can implement this.
great :)

Locked

Return to “[3.0.x] MODs in Development”