[MODDB] Search Engine Friendly (SEO) URLs 1.0.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
ecwpa
Registered User
Posts: 107
Joined: Thu Sep 25, 2003 2:13 am
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 7

Post by ecwpa »

well, now all pages are broken

and images have urls like

http://localhost/styles/prosilver/image ... e_logo.gif

maybe thats why it works in your localhost
carefull, not english speaker native here
User avatar
Handyman`
Former Team Member
Posts: 1751
Joined: Thu Feb 03, 2005 8:44 pm
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 7

Post by Handyman` »

ecwpa wrote:well, now all pages are broken

and images have urls like

http://localhost/styles/prosilver/image ... e_logo.gif

maybe thats why it works in your localhost
Image
why did you post a localhost link? it gave a 404 for me because my localhost is not my forum.
http://startrekguide.com My Mod Queue || 1/16/10 Display Posts Anywhere 1.2.0 RC5, Cash MOD 1.0.0 b1, MOD Version Check, AJAX Chat, SEO MOD, AJAX QR, Photo Gallery
MOD Development Manager (version 0.2.0-dev with MODX Generator)
TheInvisible
Registered User
Posts: 25
Joined: Thu May 31, 2007 2:10 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 7

Post by TheInvisible »

Hi
I know what was the problem now. It was "." in .htaccess but now everything's looks ok but if you enter on any topic (http://forum.e-medycyna.org) like: http://forum.e-medycyna.org/f2-og%C5%82 ... hpbb3.html you can see that something is wrong, (it doesnt reading .css files i think [propably localisation isnt ok]) and if I try go back and click on logo i have: http://forum.e-medycyna.org/f2-og%C5%82 ... /index.php
what's wrong?
Greetings
Sorry of my nationals but many Polish are cool people. :)
ecwpa
Registered User
Posts: 107
Joined: Thu Sep 25, 2003 2:13 am
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 7

Post by ecwpa »

GroovePlugs wrote:Image
why did you post a localhost link? it gave a 404 for me because my localhost is not my forum.

links are like that in my live testing forum
carefull, not english speaker native here
User avatar
Handyman`
Former Team Member
Posts: 1751
Joined: Thu Feb 03, 2005 8:44 pm
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 7

Post by Handyman` »

ecwa and TheInvisible,
Neither of you guys finished the installation.
You have to also install the prosilver.txt for any prosilver type styles and subsilver.txt for any subsilver type styles.

Make sure to refresh the templates when you are finished.
Last edited by Handyman` on Sun Jun 03, 2007 10:23 pm, edited 1 time in total.
http://startrekguide.com My Mod Queue || 1/16/10 Display Posts Anywhere 1.2.0 RC5, Cash MOD 1.0.0 b1, MOD Version Check, AJAX Chat, SEO MOD, AJAX QR, Photo Gallery
MOD Development Manager (version 0.2.0-dev with MODX Generator)
User avatar
Handyman`
Former Team Member
Posts: 1751
Joined: Thu Feb 03, 2005 8:44 pm
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by Handyman` »

Updated to Beta 8.
Changes in this version:
  1. Several bugs in pagination fixed
  2. fixed bug where topics ending with a number would create false pagination
  3. Fixed a couple missing urls
  4. Fixed a couple wrong urls
Update from Beta 7 provided.

Let me know if anybody needs an upgrade script from Beta 6… it wasn't completely compatible with RC1, so I'm assuming it's not needed.
http://startrekguide.com My Mod Queue || 1/16/10 Display Posts Anywhere 1.2.0 RC5, Cash MOD 1.0.0 b1, MOD Version Check, AJAX Chat, SEO MOD, AJAX QR, Photo Gallery
MOD Development Manager (version 0.2.0-dev with MODX Generator)
ecwpa
Registered User
Posts: 107
Joined: Thu Sep 25, 2003 2:13 am
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by ecwpa »

i finished, even the prosilver part, for some reason all templates urls redirect to "localhost"

do you have any live forum with the mod running?
carefull, not english speaker native here
garrone
Registered User
Posts: 12
Joined: Thu Nov 20, 2003 8:17 pm
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by garrone »

GroovePlugs wrote:Updated to Beta 8.
Changes in this version:
  1. Several bugs in pagination fixed
  2. fixed bug where topics ending with a number would create false pagination
  3. Fixed a couple missing urls
  4. Fixed a couple wrong urls
Update from Beta 7 provided.

Let me know if anybody needs an upgrade script from Beta 6… it wasn't completely compatible with RC1, so I'm assuming it's not needed.
Hi, I visited you forum and when I click on page 2, 3... I return on the same page.
Vacanze in Agriturismo.
TheInvisible
Registered User
Posts: 25
Joined: Thu May 31, 2007 2:10 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by TheInvisible »

Hi, it's look good but if i post a reply and I wanna go back address is like: http://forum.e-medycyna.org/viewtopic.p ... 2&p=14#p14

Second problem is this that in last update polish words was ok and now we have "?". What can I do?
Sorry of my nationals but many Polish are cool people. :)
User avatar
StaticFX
Registered User
Posts: 82
Joined: Mon Mar 19, 2007 2:33 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by StaticFX »

i do not have an htaccess file in my phpbb3 root.. only one in my main server root (php5 tweak)

should i just create one for the bb3? (or should i have had one after install???) lol all works fine btw

EDIT:
I put up the htaccess file...

tried your instructions for testing it:
"To test, do the first part of the installation only (.htaccess)
and put in a url like this -> forum/t1-test.html"

i get a page not found... not anything about topic not exsisting.. good? or no.. im not sure what is supposed to happen if that doesnt work...
Thanks
flycker
Registered User
Posts: 25
Joined: Fri Jun 01, 2007 2:27 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by flycker »

Here's an idea:
Remove the session ID (SID) if the visitor is a spider/bot.

Like this (I use this SEO tips in phpBB2): http://www.devside.net/articles/phpbb
TheInvisible
Registered User
Posts: 25
Joined: Thu May 31, 2007 2:10 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by TheInvisible »

How I can include polish symbols? Becouse now I have: "?" but it should be: "ł ą ę ś ć ó" etc. (i'm know about url_encode) and that it will be %20 etc - one upgrade back it was ok now it's not.
Sorry of my nationals but many Polish are cool people. :)
User avatar
darkera13
Registered User
Posts: 91
Joined: Sun Jun 03, 2007 7:12 pm
Location: Ha Noi, Viet Nam
Contact:

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by darkera13 »

Has a small bug. I cant go to top of page, so i try to fix it. It done now.
Sorry, my English not well so if you dont understand please forgive me :D

Code: Select all

#-----[ OPEN ]------------------------
#
styles/prosilver/template/viewtopic_body.html
#
#-----[ FIND ]------------------------
#
<div class="back2top"><a href="#wrap" class="top" title="{L_BACK_TO_TOP}">{L_BACK_TO_TOP}</a></div>
#
#-----[ REPLACE WITH ]------------------------
#
<div class="back2top"><a href="{U_VIEW_TOPIC}#wrap" class="top" title="{L_BACK_TO_TOP}">{L_BACK_TO_TOP}</a></div>
Have fun!
TheInvisible
Registered User
Posts: 25
Joined: Thu May 31, 2007 2:10 pm

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by TheInvisible »

Hi. :)
I have only one problem :) When I post a reply or edit a post, after this I have "normal" link (like: http://forum.xxx.xx/viewtopic.php?f=8&t=8&p=25#p25)
Sorry of my nationals but many Polish are cool people. :)
matgallis
Registered User
Posts: 108
Joined: Fri Oct 13, 2006 1:03 am

Re: [BETA] Search Engine Friendly (SEO) URLs 1.0.0 Beta 8

Post by matgallis »

I have a question,

So lets say forum xyz gets an enormous amount of traffic and post topics are similar, will this ruin the links?
Locked

Return to “[3.0.x] MODs in Development”