[BETA] Quick Posting MOD 3.0.B1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

Hey Lew,

I am curious before I install 3.0 is this bug fixed?
When I disable Topic Icons, it also disables my smilies as well. I would only like to have smilies. Also I am having the same problem as okada1314 with the Quick Topic. It doesn't show up
User avatar
daroPL
Translator
Posts: 515
Joined: Tue Mar 27, 2007 11:58 am
Location: Poznan, Poland
Name: Darek
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by daroPL »

User avatar
LEW21
Registered User
Posts: 117
Joined: Sat Sep 24, 2005 11:51 am
Location: Warsaw, Poland
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by LEW21 »

Stitch, probably they are fixed, but you should check it on your localhost :P

DaroPL, I have already read full coding guidelines :P I just like camelCase and count(), so I used them. I'm planning to change them to normal_case and sizeof() in final version, so QP3 will be accepted by MODs team.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

Lew,

I just tried installing 3.0 and I can't even get past the database update: Here is the error message I am getting when I try to execute it.

Code: Select all

Error
There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem

ERROR: Unclosed quote @ 67
STR: '
SQL: ALTER TABLE phpbb_3users ADD user_qp smallint(4) UNSIGNED DEFAULT \'31\' NOT NULL



SQL query: 

ALTER TABLE phpbb_3users ADD user_qp smallint(4) UNSIGNED DEFAULT \'31\' NOT NULL 

MySQL said:  

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\'31\' NOT NULL' at line 1
ALSO: Do I have to uninstall 2.0 completely before I install 3.0? Is there an update fron 2.0 to 3.0?
NipponSquad
Registered User
Posts: 1
Joined: Mon Jul 09, 2007 3:21 pm

Re: [BETA] Quick Posting MOD 3.0.B1

Post by NipponSquad »

I've just tried install version 2 to my test forum running RC3...

i've done all the steps apart from the final:
DIY Instructions
These are manual instructions that cannot be performed automatically. You should follow these instructions carefully.

Clear cache/ folder (delete everything without .htaccess)
Install ACP module (group "Board Management [acp_board]", name "Quick Posting")
i don't really understand what this means, mainly the install ACP module bit... i don't get it...

I've completed every other step and the forum doesnt seem to have any change at all to it at the moment, on a visual basis

Rob
User avatar
LEW21
Registered User
Posts: 117
Joined: Sat Sep 24, 2005 11:51 am
Location: Warsaw, Poland
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by LEW21 »

Stitch625, try this query:

Code: Select all

ALTER TABLE phpbb_3users ADD user_qp smallint(4) UNSIGNED DEFAULT \'31\' NOT NULL
Stitch625 wrote:ALSO: Do I have to uninstall 2.0 completely before I install 3.0? Is there an update fron 2.0 to 3.0?
You should uninstall it, but everything will probably work without doing it. Automatic DB installer will uninstall 0.x, 1.x, 2.0 and 3.0.BETA1 automatically.

NipponSquad,
Clear cache/ folder (delete everything without .htaccess)
was needed in old versions of phpBB3, in RCs you can just go to your ACP and click on "Purge cache".
Install ACP module (group "Board Management [acp_board]", name "Quick Posting")
means that you have to go to ACP -> SYSTEM -> MODULE MANAGEMENT -> Administrator Control Panel -> General -> Board configuration, find "Quick Posting" on a list near "Add module" button and click on it, then enable that module by clicking on Enable near it.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

Thanks for your reply Lew. I don't know what this DB installer is that your talking about so I manually uninstalled 2.0 but I am having a problem with removing the DB Qeuries.

Code: Select all

INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_topic', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_reply', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_reply_title', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_options', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_icons', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_smilies', 1);

ALTER TABLE phpbb_users ADD user_display_quick_topic tinyint(1) UNSIGNED DEFAULT 1 NOT NULL;
User avatar
okada1314
Registered User
Posts: 209
Joined: Sat Oct 29, 2005 10:51 am

Re: [BETA] Quick Posting MOD 3.0.B1

Post by okada1314 »

Stitch625 wrote:Thanks for your reply Lew. I don't know what this DB installer is that your talking about so I manually uninstalled 2.0 but I am having a problem with removing the DB Qeuries.

Code: Select all

INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_topic', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_reply', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_reply_title', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_options', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_icons', 1);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('display_quick_post_smilies', 1);

ALTER TABLE phpbb_users ADD user_display_quick_topic tinyint(1) UNSIGNED DEFAULT 1 NOT NULL;
Are u all work in this mod??
User avatar
LEW21
Registered User
Posts: 117
Joined: Sat Sep 24, 2005 11:51 am
Location: Warsaw, Poland
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by LEW21 »

Stitch625, don't do anything with them, QP3 installer that will be included in the next beta will automatically delete their effect from your DB.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

Ok Lew thanks> But I would feel better to get that portion uninstalled now.

[EDIT] Hey I just noticed that this mod is only for prosilver :| What about subsilver?
User avatar
LEW21
Registered User
Posts: 117
Joined: Sat Sep 24, 2005 11:51 am
Location: Warsaw, Poland
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by LEW21 »

I will add subsilver2 template in one of next betas/RCs, but probably not in Beta2.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

LEW21 wrote:Stitch625, try this query:

Code: Select all

ALTER TABLE phpbb_3users ADD user_qp smallint(4) UNSIGNED DEFAULT \'31\' NOT NULL
Lew, This is the exact query that I ran and those errors came up. I have tried it on two different boards and I get the same error.
TRICHES.FR
Registered User
Posts: 75
Joined: Sat Jun 09, 2007 5:23 pm

Re: [BETA] Quick Posting MOD 3.0.B1

Post by TRICHES.FR »

Can you post a live demo please ?

Thanks.
User avatar
LEW21
Registered User
Posts: 117
Joined: Sat Sep 24, 2005 11:51 am
Location: Warsaw, Poland
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by LEW21 »

I copied it and forgot to edit it :P

Code: Select all

ALTER TABLE phpbb_3users ADD user_qp smallint(4) UNSIGNED DEFAULT '31' NOT NULL
Now it should work.

TRICHES.FR, I can, but it will be useless :P You can see all features (except smilies) on the screenshot and demo won't give you any more possibilities. And you will have to login, because QP works only for registered users.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA] Quick Posting MOD 3.0.B1

Post by Stitch625 »

Thanks Lew,

Sorry I was too thick to figure that out myself. Anyway, do you have an idea when you will have this mod ready for subsilver2? I would really like to add this to my live board.
Locked

Return to “[3.0.x] MODs in Development”