[Beta] Contact Board Administration 0.1.4

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
Locked
Ashok
Registered User
Posts: 38
Joined: Wed Jan 02, 2008 9:07 pm

Re: [Beta] Contact Board Administration 0.1.4

Post by Ashok »

JunglistPerfection wrote:Is this mod safe to install on phpBB3 Gold?
I have been using it on phpBB 3 Gold for some time now without any problems. I did make some modifications to the mod to tailor it to my needs. Please see earlier posts in the thread.

That said, it is a MOD under development, and as far as I know, has not been submitted for validation by the mod author to the phpBB team. Therefore, I suppose, installation and usage of this mod is at your own risk.
Stipendiat
Registered User
Posts: 35
Joined: Fri Sep 21, 2007 1:58 pm

Re: [Beta] Contact Board Administration 0.1.4

Post by Stipendiat »

Problem with UTF-8

Has anybody a solution?
immelody
Registered User
Posts: 1
Joined: Thu Mar 06, 2008 11:07 pm

Re: [Beta] Contact Board Administration 0.1.4

Post by immelody »

Maybe someone here can tell me what I'm doing wrong. I have, as far as I'm aware, installed this mod correctly. I've enabled it, and done the settings for it. But for some reason, it is not working. It's not broken anything on my board.


http://www.ctsites.net/phpBB3/contact.php


I'm not sure if it's an error with mySQL, if I've done something incorrectly, or I'm just SOL by an act of God. Any help would be appreciated.
updown
Registered User
Posts: 542
Joined: Sat Jan 05, 2008 6:53 am

Re: [Beta] Contact Board Administration 0.1.4

Post by updown »

updown wrote:If have problems with special characters in the message - especially with German Umlauts, they appear in the final-email as two questionmarks '??'

I already checked the UTF-8 encoding, but I think this maybe not considered in the code of the contact-mod itself, since the predefined text is shown right with Umlauts, the included message isn't.

Has anybody an idea, or better: a solution?
Stipendiat wrote:Problem with UTF-8

Has anybody a solution?
Why is this mod not supporting UTF-8 :?: Can this be fixed :?: :roll:
User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [Beta] Contact Board Administration 0.1.4

Post by ChriZathens »

updown wrote:
updown wrote:If have problems with special characters in the message - especially with German Umlauts, they appear in the final-email as two questionmarks '??'

I already checked the UTF-8 encoding, but I think this maybe not considered in the code of the contact-mod itself, since the predefined text is shown right with Umlauts, the included message isn't.

Has anybody an idea, or better: a solution?
Stipendiat wrote:Problem with UTF-8

Has anybody a solution?
Why is this mod not supporting UTF-8 :?: Can this be fixed :?: :roll:
open contact.php

find

Code: Select all

$subject        = str_replace("\n", '', trim(request_var('subject', '')));
$message        = trim(request_var('message', ''));
$reason            = str_replace("\n", '', request_var('reason', ''));
   
replace with

Code: Select all

$subject        = str_replace("\n", '', trim(request_var('subject', '', true)));
$message        = trim(request_var('message', '', true));
$reason            = str_replace("\n", '', request_var('reason', '', true));
   
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...
Stipendiat
Registered User
Posts: 35
Joined: Fri Sep 21, 2007 1:58 pm

Re: [Beta] Contact Board Administration 0.1.4

Post by Stipendiat »

Thank you so much!
:)
updown
Registered User
Posts: 542
Joined: Sat Jan 05, 2008 6:53 am

Re: [Beta] Contact Board Administration 0.1.4

Post by updown »

Thanks ChriZathens! Works fine!

Easy and effective - that's the way I like it... :mrgreen:
modbo
Registered User
Posts: 45
Joined: Wed Jan 12, 2005 10:26 am

Re: [Beta] Contact Board Administration 0.1.4

Post by modbo »

I don´t receive emails send by the contact mod. Any ideas?
Sending emails over user profile works, email post box works.
But still no emails over contact mod.

Someone here with a german translation for the mod? :P
User avatar
topdown
Registered User
Posts: 635
Joined: Wed Sep 19, 2007 5:16 pm
Location: NE Wisconsin
Name: Jeff Behnke
Contact:

Re: [Beta] Contact Board Administration 0.1.4

Post by topdown »

I have been chasing this for 2 days, I had this installed on a board and now I was building a fresh install with some updates to other mods and can't seem to get this fixed.
I even deleted the tables for it under the config in the database and manually installed it from the previous working version, but it just doesn't work.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3373: Undefined index: contact_enable
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3393: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3395: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)
and the admin contact panel gives me this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /adm/index.php on line 290: Undefined index: contact_enable
[phpBB Debug] PHP Notice: in file /adm/index.php on line 291: Undefined index: contact_enable
[phpBB Debug] PHP Notice: in file /adm/index.php on line 290: Undefined index: contact_confirm
[phpBB Debug] PHP Notice: in file /adm/index.php on line 291: Undefined index: contact_confirm
[phpBB Debug] PHP Notice: in file /adm/index.php on line 290: Undefined index: contact_confirm_guests
[phpBB Debug] PHP Notice: in file /adm/index.php on line 291: Undefined index: contact_confirm_guests
[phpBB Debug] PHP Notice: in file /adm/index.php on line 272: Undefined index: contact_max_attempts
[phpBB Debug] PHP Notice: in file /adm/index.php on line 341: Undefined index: contact_method
[phpBB Debug] PHP Notice: in file /adm/index.php on line 286: Undefined index: contact_reasons
[phpBB Debug] PHP Notice: in file /adm/index.php on line 272: Undefined index: contact_bot_user
[phpBB Debug] PHP Notice: in file /adm/index.php on line 341: Undefined index: contact_bot_forum
[phpBB Debug] PHP Notice: in file /adm/index.php on line 149: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 151: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2922)

If I shut the debug off then in the admin panel when I try to enable it I end up with

Code: Select all

General Error
SQL ERROR [ mysqli ]

Duplicate entry 'contact_enable' for key 1 [1062]

SQL

INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES ('contact_enable', 1, 0)

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 156
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_board.php
LINE: 438
CALL: set_config()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_board->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
Its driving me nuts. :roll:

Any ideas Evil ?

Thank You
User avatar
gara
Registered User
Posts: 40
Joined: Wed Mar 12, 2008 4:10 am
Location: Colombia
Contact:

Re: [Beta] Contact Board Administration 0.1.4

Post by gara »

modbo wrote:I don´t receive emails send by the contact mod. Any ideas?
Sending emails over user profile works, email post box works.
But still no emails over contact mod.

Someone here with a german translation for the mod? :P
I have the same wrong, way forum and way privated messages the mod functions perfectly.. but the mode "email" don't function...

i try to change this
saaiberke wrote:In contact.php

search for

Code: Select all

					$messenger->to($contact_users[$i]['user_email'], $contact_users[$i]['username']);
change to

Code: Select all

					$messenger->to("youremailaddress@here");
Apply also the change abover these last post to avoid the mail being sent several times. :)

That did the trick on my board.

Grtz,

Nic
but nothing.. some idea?
Nueva Comunidad

PaginaLatinos.Com Aqui
PaginaLatinos.Com Aqui
User avatar
gara
Registered User
Posts: 40
Joined: Wed Mar 12, 2008 4:10 am
Location: Colombia
Contact:

Re: [Beta] Contact Board Administration 0.1.4

Post by gara »

gara wrote:
modbo wrote:I don´t receive emails send by the contact mod. Any ideas?
Sending emails over user profile works, email post box works.
But still no emails over contact mod.

Someone here with a german translation for the mod? :P
I have the same wrong, way forum and way privated messages the mod functions perfectly.. but the mode "email" don't function...

i try to change this
saaiberke wrote:In contact.php

search for

Code: Select all

					$messenger->to($contact_users[$i]['user_email'], $contact_users[$i]['username']);
change to

Code: Select all

					$messenger->to("youremailaddress@here");
Apply also the change abover these last post to avoid the mail being sent several times. :)

That did the trick on my board.

Grtz,

Nic
but nothing.. some idea?
30 MINUTES AFTER... the email arrived to the email of the admin (me)

thanks and in this moment don't have wrongs.

thanks for the mod :D
Nueva Comunidad

PaginaLatinos.Com Aqui
PaginaLatinos.Com Aqui
Andey
Registered User
Posts: 20
Joined: Tue Jan 08, 2008 1:38 am

Re: [Beta] Contact Board Administration 0.1.4

Post by Andey »

is there a 3.0.0 version around?
goodpatronage
Registered User
Posts: 19
Joined: Sun Jan 13, 2008 2:48 pm

Re: [Beta] Contact Board Administration 0.1.4

Post by goodpatronage »

Hi there, need help here,

Why i don't get any email if someone has contacted me?
It works like a charm when i set to pm for "contact Method"....
but when i set contact method to email....nothing comes up....
modbo
Registered User
Posts: 45
Joined: Wed Jan 12, 2005 10:26 am

Re: [Beta] Contact Board Administration 0.1.4

Post by modbo »

goodpatronage wrote:Hi there, need help here,

Why i don't get any email if someone has contacted me?
It works like a charm when i set to pm for "contact Method"....
but when i set contact method to email....nothing comes up....
Had the same problem. Check your email settings in ACP.
Do you receive email if you subscribe a forum or get a PM?
User avatar
Elias
Registered User
Posts: 5136
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: [Beta] Contact Board Administration 0.1.4

Post by Elias »

How can i make it only create the new posts by this 1 X user?
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|
Offering private web hosting. Contact me for details.
Locked

Return to “[3.0.x] MODs in Development”