[MODDB] Auto Groups 0.2.3

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Ideas Centre
Locked
magicfun
Registered User
Posts: 382
Joined: Fri Apr 28, 2006 8:50 pm

Re: [RC] Auto Groups 0.2.2

Post by magicfun » Wed Sep 19, 2007 4:26 pm

will applying the colors be updated correctly in the next MOD release? I'd like to use this feature...thanks.

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: [RC] Auto Groups 0.2.2

Post by A_Jelly_Doughnut » Wed Sep 19, 2007 6:25 pm

Yes, it will. I finally have designed a foolproof method to handle this :)
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

justinv
Registered User
Posts: 81
Joined: Tue Nov 21, 2006 11:28 am

Re: [RC] Auto Groups 0.2.2

Post by justinv » Fri Sep 21, 2007 2:44 pm

after i installed this mod, i got this problem after adding a new group

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_user.php on line 2343: group_create(./../includes/functions_autogroup.) [function.group-create]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions_user.php on line 2343: group_create(./../includes/functions_autogroup.) [function.group-create]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions_user.php on line 2343: group_create() [function.include]: Failed opening './../includes/functions_autogroup.' for inclusion (include_path='.:/usr/local/lib/php')

Fatal error: Call to undefined function: auto_groups_create() in /home/cwalkcentr/domains/cwalkcentral.nl/public_html/forum/includes/functions_user.php on line 2346
what to do know??

Know i found where the problem is, its in functions_users.php and the code

Code: Select all

// auto groups MOD
		// since we're changing a group, find users who belong in the new group
		if (!function_exists('auto_groups_create'))
		{
			include($phpbb_root_path . 'includes/functions_autogroup.'.$phpEx);
		}

		$auto_add_users = auto_groups_create($group_attributes);
		// end auto groups MOD 
if i delete that, i can add the groups again, but the mod dont work then... any solutions??

justinv
Registered User
Posts: 81
Joined: Tue Nov 21, 2006 11:28 am

Re: [RC] Auto Groups 0.2.2

Post by justinv » Fri Sep 21, 2007 2:59 pm

i found it :D


in your installation guide you this whas wrong..

Code: Select all

// auto groups MOD
      // since we're changing a group, find users who belong in the new group
      if (!function_exists('auto_groups_create'))
      {
         include($phpbb_root_path . 'includes/functions_autogroup.'.$phpEx);
      }

      $auto_add_users = auto_groups_create($group_attributes);
      // end auto groups MOD 
it must be

Code: Select all

// auto groups MOD
      // since we're changing a group, find users who belong in the new group
      if (!function_exists('auto_groups_create'))
      {
         include($phpbb_root_path . 'includes/functions_autogroup.php'.$phpEx);
      }

      $auto_add_users = auto_groups_create($group_attributes);
      // end auto groups MOD 

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: [RC] Auto Groups 0.2.2

Post by A_Jelly_Doughnut » Fri Sep 21, 2007 6:36 pm

Actually, the correct fix there is to do this:

Code: Select all

      // auto groups MOD
      // since we're changing a group, find users who belong in the new group
      if (!function_exists('auto_groups_create'))
      {
         global $phpEx;
         include($phpbb_root_path . 'includes/functions_autogroup.'.$phpEx);
      }

      $auto_add_users = auto_groups_create($group_attributes);
      // end auto groups MOD
Hopefully I'll get the chance to package 0.2.3 this weekend.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [RC] Auto Groups 0.2.2

Post by RedTrinity » Sat Sep 22, 2007 2:15 am

I think I may be having a problem with the latest version not setting graduated members as "default group" once they have been moved into that group.

Even though I have all groups currently marked for this to happen, the last couple of new users that have signed up have not changed to have the new group as their default group, and I have had to do it manually :S

I will test this further now with a test account to confirm, but from what I have seen sofar there appears to be some kind of problem there...

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: [RC] Auto Groups 0.2.2

Post by A_Jelly_Doughnut » Sat Sep 22, 2007 2:19 am

There are a couple of bugs in 0.2.2 that need to be fixed...0.2.3 expected soon 8-)
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [RC] Auto Groups 0.2.2

Post by RedTrinity » Sat Sep 22, 2007 2:22 am

Ok no worries dude, just thought I might bring it up before you release the new one in case you didn't know about it :D

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [RC] Auto Groups 0.2.2

Post by ChriZathens » Tue Sep 25, 2007 8:09 am

Good morning to all!!! ;)
A_Jelly_Doughnut , a few things I noticed using your mod:
I have a forum where users must have 10 post to post a new topic. So users are automatically added in a group with new topic permissions as soon as they reach 10 posts...
In ACP I have set minimum 10 posts to enter the group.
If the user goes inside that forum, no "NewTopic" icon appears ;)
As soon as the user has ten posts, then the "NewTopic" icon appears and he can post- great till here!!!

While the user is logged in, I change minimum posts to 80 and save settings. If the user refreshes the page, the "NewTopic" icon does not disappear and he can post. If he logs out and then logins again, the "NewTopic" icon is now hidden.. Is this supposed to happen this way?

And another thing
I want users to enter the mentioned group after 10 posts and 30 days of membership
The post thing works. But when user reaches 10 posts he can post a new topic, although he is only a member for 15 days... :?:
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: [RC] Auto Groups 0.2.2

Post by A_Jelly_Doughnut » Tue Sep 25, 2007 12:38 pm

ChriZathens: The first issue will be fixed by the 0.2.3 release (whenever I find the time to actually release it ... won't be today).
The second issue ... if you have the group's maximum days set to 45, this should happen. If it is not set that way, it should not happen. (although I did find a bug in "days" handling...but I don't remember which version it was / will be fixed in) The MOD uses AND logic. You must have ten posts and be a member for 30 days in order to join the group.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [RC] Auto Groups 0.2.2

Post by ChriZathens » Tue Sep 25, 2007 2:38 pm

A_Jelly_Doughnut wrote:ChriZathens: The first issue will be fixed by the 0.2.3 release (whenever I find the time to actually release it ... won't be today).
Ok, We'll just wait... ;)
A_Jelly_Doughnut wrote:
The second issue ... if you have the group's maximum days set to 45, this should happen. If it is not set that way, it should not happen. (although I did find a bug in "days" handling...but I don't remember which version it was / will be fixed in) The MOD uses AND logic. You must have ten posts and be a member for 30 days in order to join the group.
I have the group's minimum days set to 30 and minimum posts to 10. So, the user is supposed to have at least
10 posts AND be a member for 30 days to post a new topic, right??
What I said before, is that when he reaches 10 posts he is allowed to post a new topic, although the minimum days of registration don't match the criteria (He is a member for only 15 days and I have set minimum days to 30)
So I guess that the AND logic does not work in this case...

Is there something I did not understand?? Sorry, English is not my mother lang, so sometimes it's easy to get the wrong meaning of something... :oops:
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: [RC] Auto Groups 0.2.2

Post by A_Jelly_Doughnut » Tue Sep 25, 2007 2:45 pm

I checked, and the bug in the days handling is also fixed for 0.2.3.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [RC] Auto Groups 0.2.2

Post by ChriZathens » Tue Sep 25, 2007 6:00 pm

Ok, that's great...
If I notice anything else (it's not very easy to test, though - I'm running Olympus on localhost for now just for testing purposes) I will post it here!!! ;)
Nice mod, definitely a must-have one...!
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

Danaldinho
Registered User
Posts: 675
Joined: Sat Aug 11, 2007 8:43 pm

Re: [RC] Auto Groups 0.2.2

Post by Danaldinho » Thu Sep 27, 2007 11:31 am

so could i use this for my forum

i am going to make a new forum with like special stuff in, but i only want people to have acces, say over 50 posts

so will this work :?: thanks :)

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [RC] Auto Groups 0.2.2

Post by RedTrinity » Thu Sep 27, 2007 11:43 am

Danaldinho wrote:so could i use this for my forum

i am going to make a new forum with like special stuff in, but i only want people to have acces, say over 50 posts

so will this work :?: thanks :)
Yes.

Locked

Return to “[3.0.x] MODs in Development”