[Beta] Stargate Portal 1.0.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
Locked
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Stitch625 » Sun Nov 07, 2010 5:10 am

I took a fresh install of phpBB3.0.7 with sgp3.1.2 on a local host and installed it using AutoMod.
These are the problems I am having.

Subsilver-Forums do not show but portal works fine.
My custom style-Right hand blocks don't show but everything else works.
Prosilver- Everything works fine.

I still have not found any miss placed edits.

Also one other problem I am having is that after I tried moving the "News" block I can no longer see it unless I log out. I have refreshed the templates and cache even cleared the cache and cookies in FireFox.

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Sun Nov 07, 2010 6:27 am

I just found out there is new edits that are required Mike just updated github a minute ago but is still checking for something that needs fixing on one of the sites I worked on so it might be updated again just to let you know.

If your custom style is not showing block on one side most likely. - STOP I just had a brain storm (that's Dangerous you know). Some times , some styles require the portal files in the style directory compare subsilver with your style see if any old portal.html or other portal files are in that custom style directory

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Fri Nov 12, 2010 5:51 am

Why, in the MCP does it show a percent sign next to the "s" in "TIME"??? How do I fix this, and what is it supposed to say??? (X-Treme template) Thanks!!!

Image

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Fri Nov 12, 2010 6:16 am

Also, and I know I have asked this earlier. But why can I not place a mod on the portal page? It either does not render or half the data is missing, whereas it works fine on the index page. Kind of sucks that mods cannot be placed on the portal to free up room on the index. Suggestions, thoughts? It seems like a path issue, but maybe someone can chime in...

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Fri Nov 12, 2010 9:43 pm

Also, I am doing a mod and it does not show a subsilver template, just prosilver. The mod says I need to look for this:

Code: Select all

<!-- IF FORUM_DESC or MODERATORS or U_MCP -->
in viewforum_body.html but I do not see this in subsilver, where is this code in subsilver??? Thanks!!

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Fri Nov 12, 2010 10:36 pm

For the % problem Check your edits
What mod are you trying to place on the portal page can you give us more info?
As far as doing a mod and you can't find something it best if you ask the mod developer that made the mod.
This is the Stargate Portal discussion area. if you are asking about a stargate install the instructions for subsilver2 is in the xml file.

You might want to elaborate on your problem.
thanks

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Fri Nov 12, 2010 11:58 pm

Mitch1063 wrote:For the % problem Check your edits
What mod are you trying to place on the portal page can you give us more info?
As far as doing a mod and you can't find something it best if you ask the mod developer that made the mod.
This is the Stargate Portal discussion area. if you are asking about a stargate install the instructions for subsilver2 is in the xml file.

You might want to elaborate on your problem.
thanks
Which file do I look in for the edit on the % problem? Not sure where to look? Thanks

Well I was just wondering why mods only will install on the index page, and cannot be merged over onto the portal page? Is it because its a path issue for the mods and the portal page/blocks being in its own folder???? Thanks! When I install mods on the PORTAL page, and NOT the INDEX page they never work. Its only when I bring them over to the Index page do they work correctly, but whats the point? A portal, in my opinion should have the bulk of the stuff... any help appreciated. Thanks!

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Sat Nov 13, 2010 12:31 am

Also, one more thing. I have noticed that the Xtreme template does not show the RSS icon for the built in RSS feed for PHPBB3.07. Is it simply adding an icon? If so where so that the software can read it? Thanks again! Almost done on the conversion. Everyone loves the new look!!

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Sat Nov 13, 2010 2:40 am

You still have not said what Mods can't install on to the portal page.
There are a lot of mods that output onto a block for instance
Mchat
Handyman's chat
phpBB Gallery
phpBB arcade
just to name a few search around stargate-portal.com and you can find the different blocks made available.

As far as the feed Icon its not there by default you have to add it Please read http://www.phpbb.com/community/viewtopi ... &t=2029415


I verified the time% I will file a bug report to Mike at the support forum
Thanks

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Sat Nov 13, 2010 3:07 am

Mitch1063 wrote:You still have not said what Mods can't install on to the portal page.
There are a lot of mods that output onto a block for instance
Mchat
Handyman's chat
phpBB Gallery
phpBB arcade
just to name a few search around stargate-portal.com and you can find the different blocks made available.

As far as the feed Icon its not there by default you have to add it Please read http://www.phpbb.com/community/viewtopi ... &t=2029415


I verified the time% I will file a bug report to Mike at the support forum
Thanks

Thanks!! Well, if you look at my site:

https://www.gunsgrubandgold.com/forum/index.php

None of the boxes at the bottom of the index: Karma, advanced stats (lots of added code for attachments, etc), who is online (with added code for 24 hour), Ultimate points bank amounts, points, etc. will NOT render properly on the portal. Maybe I'm doing something wrong, but if you could help me I would like to put these boxes and some others on the portal page not the index.

Thanks again, I will check out the info you left, hopefully you can help me on the above question as well. Have a great weekend.

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Sat Nov 13, 2010 3:18 am

Praetorian Guard wrote:
Thanks!! Well, if you look at my site:

https://www.gunsgrubandgold.com/forum/index.php

None of the boxes at the bottom of the index: Karma, advanced stats (lots of added code for attachments, etc), who is online (with added code for 24 hour), Ultimate points bank amounts, points, etc. will NOT render properly on the portal. Maybe I'm doing something wrong, but if you could help me I would like to put these boxes and some others on the portal page not the index.

Thanks again, I will check out the info you left, hopefully you can help me on the above question as well. Have a great weekend.
You have to Make blocks for them and if the index,php requires edits for variables then most likely when you create a block you need code for the php part of the Block to pass the variable to pass to the html part of the block.
More info is in the support forum. on making blocks

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Sat Nov 13, 2010 3:43 am

Mitch1063 wrote:
Praetorian Guard wrote:
Thanks!! Well, if you look at my site:

https://www.gunsgrubandgold.com/forum/index.php

None of the boxes at the bottom of the index: Karma, advanced stats (lots of added code for attachments, etc), who is online (with added code for 24 hour), Ultimate points bank amounts, points, etc. will NOT render properly on the portal. Maybe I'm doing something wrong, but if you could help me I would like to put these boxes and some others on the portal page not the index.

Thanks again, I will check out the info you left, hopefully you can help me on the above question as well. Have a great weekend.
You have to Make blocks for them and if the index,php requires edits for variables then most likely when you create a block you need code for the php part of the Block to pass the variable to pass to the html part of the block.

Thanks! This is the part I do not understand. Is it a simple fix or will I have to do some coding? I'm not very good... :cry:
More info is in the support forum. on making blocks
I've been looking on the stargatestyles board and cannot find info on how to make blocks. Thanks!

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Sat Nov 13, 2010 4:12 am

Praetorian Guard wrote:I've been looking on the stargatestyles board and cannot find info on how to make blocks. Thanks!
Try http://www.stargate-portal.com/forum/portal.php

User avatar
Praetorian Guard
Registered User
Posts: 789
Joined: Wed Oct 07, 2009 12:42 am

Re: [Beta] Stargate Portal 1.0.0

Post by Praetorian Guard » Sat Nov 13, 2010 4:32 am

Thanks!! One more thing. How do I change the site logo for the index page and the portal??? I've been looking in the portal mods tab and can't figure it out. Thanks again!

User avatar
Mitch1063
Registered User
Posts: 525
Joined: Wed Jul 28, 2004 2:49 pm
Location: WWW
Contact:

Re: [Beta] Stargate Portal 1.0.0

Post by Mitch1063 » Sat Nov 13, 2010 4:46 am

Praetorian Guard wrote:Thanks!! One more thing. How do I change the site logo for the index page and the portal??? I've been looking in the portal mods tab and can't figure it out. Thanks again!
the logo is in the styles/YOURSTYLENAME/theme/images/logo directory

Locked

Return to “[3.0.x] MODs in Development”