[BETA] Topic Tag Prefixes MOD 0.1.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
Locked
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by ham1299 »

Drugs wrote:You messed up installing it somewhere.
Well, yeah, I figured that out. I just am not sure exactly where.
Heather
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by ham1299 »

nevermind. I found it. It was in adm/style/acp_forums.html
Heather
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by ham1299 »

Nevermind. I see that's the fix mentioned in the first post ...
Heather
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by ham1299 »

Nevermind again. I'm just gonna wait for a stable release ...
Last edited by ham1299 on Sun Mar 09, 2008 3:08 am, edited 1 time in total.
Heather
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by Jaymie1989 »

Hi,

Im getting this error.
[phpBB Debug] PHP Notice: in file /common.php on line 224: require(./includes/functions_topic_tags.php) [function.require]: failed to open stream: No such file or directory

Fatal error: require() [function.require]: Failed opening required './includes/functions_topic_tags.php' (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\phpBB3\common.php on line 224
Iv checks the line and its this

Code: Select all

require($phpbb_root_path . 'includes/functions_topic_tags.' . $phpEx);
Which is from this

Code: Select all

// Added by Topic Tags MOD
require($phpbb_root_path . 'includes/functions_topic_tags.' . $phpEx);
// End Added by Topic Tags MOD
I cant see anything wrong with the line, So what is wrong?
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by Tripp »

Uh....the error means what it says

You missed uploading functions_topic_tags.php
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs
moozer
Registered User
Posts: 102
Joined: Sat Nov 10, 2007 10:36 pm
Location: Netherlands
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by moozer »

hello guys and girls,

i am working on a mod to start a topic by filling in a form. i want to give this new topic a default tag.
can someone give me a hint about how to give a new topic in a perticulair forum a default tag?

thanks for your time ;)
Board at http://www.noobdude.com , Running phpbb3, Template(s) used: ProSilver, Language(s) used: English, Its hosted on a local server, Version of PHP used: 5.2.0, Database and version used: MySQL 5
demon327
Registered User
Posts: 847
Joined: Thu Nov 16, 2006 2:16 pm

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by demon327 »

is this mod still under Development??, cause i saw the first post has not bin updated since june 2007
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by Jaymie1989 »

Last edited by Highway of Life on Tue Jul 03, 2007 6:26 pm
It was July.

I know that Highway has alot of mods that he is working on, This maybe near the bottom of the list.
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
Bubyx
Registered User
Posts: 6
Joined: Tue Aug 28, 2007 4:31 pm

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by Bubyx »

I am using this mod for a very long time now and i noticed some of bugs!

I am curious when will the final release will be out?!??

Bugs i've noticed:
  • When posting, and hit preview, my tag get lost!
  • When the time between two topics are to fast and when the board notice you that "You can't submit another post so soon after your last one" tag disappear either!
I manage to make the mod working on acidtech style, but for these bugs I am not such an expert so I will be pleased if highway can solve that!

Thanks in advance!
User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by Highway of Life »

Bubyx wrote:Bugs i've noticed:
  • When posting, and hit preview, my tag get lost!
  • When the time between two topics are to fast and when the board notice you that "You can't submit another post so soon after your last one" tag disappear either!
Thanks for reporting these.
The phpBB 3.0.0 Posting functions are a bit difficult to work into with a MOD, (thus why I’m really looking forward to the 3.2 posting section cleanup. :)

Jamie is correct, I’m working on a lot of other MODs at the moment so this one is at the bottom of the list for the moment. I have some partial development into the Next Beta but its not quite ready for another release.
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.
chicken dippa
Registered User
Posts: 108
Joined: Sun Apr 22, 2007 2:14 am

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by chicken dippa »

Great, will install this soon :)
CyberCop
Registered User
Posts: 9
Joined: Sat Sep 22, 2007 5:23 pm

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by CyberCop »

nothing to do, I tried many times to install this mod and never it works :cry:

I can't understand, I make all what it's write into the xml file, and also i use prosilver style for the forum where I need the prefix, but nothing to do...

And I have no errors, simply the tags aren't there

I activate the topic tags option for those forum and also create some tags, all works in acp panel, but not in posting page... what it could be?
CyberCop
Registered User
Posts: 9
Joined: Sat Sep 22, 2007 5:23 pm

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by CyberCop »

CyberCop wrote:nothing to do, I tried many times to install this mod and never it works :cry:

I can't understand, I make all what it's write into the xml file, and also i use prosilver style for the forum where I need the prefix, but nothing to do...

And I have no errors, simply the tags aren't there

I activate the topic tags option for those forum and also create some tags, all works in acp panel, but not in posting page... what it could be?
OK; I solved some problem, but the tags are showed only in topic list and in topic body, If I make a search for new message the tags aren't listed, it's the same for you?

And how could I make it works on X-Treme style?
User avatar
sieben
Registered User
Posts: 24
Joined: Fri Jul 04, 2003 10:51 pm
Location: Germany
Contact:

Re: [BETA] Topic Tag Prefixes MOD 0.1.0

Post by sieben »

waiting for the future features
Future Features:

* Admin configurable Forum-specific topic prefixes, specific set for Topic Authors and Moderators (separately)
* Admin Topic prefix override - override the global set or disable topic prefixes completely for a specific forum
* Option to allow user/moderator to set a custom topic prefix (on a per-forum basis)
Locked

Return to “[3.0.x] MODs in Development”